1. Dancing Terps's Avatar
    I got a new Storm (last one had issues) and lost all of my 3rd party Apps. I reinstalled App World and all of the free apps but couldn't get my purchased apps back. I tried logging into my world to get them back but it won't work.

    I get the following:

    -Authenticating

    -Loading Purchases

    -Please wait while your my world contents are retrieved. You will receive confirmation when the action is complete

    -Unable to authenticate user at this time. Please try again later.

    I have tried numerous times with no luck. I know I am putting in the correct user name and password for Paypal but it still wont work.

    Anyone know what to do?

    Thanks.

    -Marc
    10-06-09 03:16 PM
  2. iMunky's Avatar
    I am having this same issue on my Tour.

    I emailed support about this several days ago, and have yet to receive a response.
    10-19-09 02:27 PM
  3. Bach56's Avatar
    You may need to change you PIN to the new device.
    10-19-09 02:43 PM
  4. pkcable's Avatar
    Moving this over to 3rd Party Apps
    10-19-09 02:46 PM
  5. timrosenfeld's Avatar
    If updating your PIN info doesn't work... sounds like you're going to have to call RIM. Good luck!
    10-20-09 05:33 AM
  6. TaZ52083's Avatar
    Try emailing customer support for blackberry app world.
    10-20-09 11:46 AM
  7. Dancing Terps's Avatar
    I e-mailed the individual applications and they came back to me and said I needed to contact app world directly. I e-mailed app world and they sent back a canned BS message. I then e-mailed app world billing and never got a response.

    What do you mean by change your pin? On app world?
    10-28-09 09:36 AM
  8. Dancing Terps's Avatar
    I finally got the answer. It's very straight forward.

    In order to have My World (On App World) authenticate you as a user, you have to have a valid credit card attached to your PayPal account.

    I only had my bank account attached and that's why it wouldn't let me in to My World.

    Hope this helps to anyone who sees this going forward who has the same problem.
    10-28-09 05:58 PM
  9. RMN200's Avatar
    Try reloading OS, seems to be a lot of "hidden" bugs in the apps. (especially app world, fbook, app center)
    10-29-09 03:46 AM
LINK TO POST COPIED TO CLIPBOARD