1. scapelo's Avatar
    Hi,
    I'm facing some problems with my new Blackberry bold 9700.
    After install the kindle app, I've been receiving the error message about wi-fi connection, but the Blackberry is connected and the browser working perfectly.
    Am I doing something wrong? Is there any configuration missing?
    Thanks...
    12-29-11 06:16 PM
  2. Rootbrian's Avatar
    Are you on a blackberry specific data plan? A social or messaging or e-mail data plan won't work.

    If you're on a full blackberry data plan (not messaging/social/e-mail), then you might need to adjust the APN settings under TCP/IP in the options. If you're on OS 5, it'll be under Advanced Settings. Otherwise, go into options and type TCP and select that option. Use the APN settings from your carrier, which should resolve the kindle app's error.
    12-29-11 06:24 PM
  3. scapelo's Avatar
    Thanks. I will try...
    12-30-11 07:30 PM
  4. Luxbot's Avatar
    I am having this same problem. The weirdest thing is that it worked perfectly fine before -- though at some point, it stopped syncing. I can read books that I've uploaded onto my media card, but I have to work around the sign-in screen in order to access my library -- in other words, I have to do this:

    1. Open Amazon Kindle.
    2. Go to the sign-in screen.
    3. Hit the options button to get to the "Home" option.
    4. Access library.


    It's a pain in the . I'd rather just be able to log into Amazon and sync my stuff up, but whenever I try, I get "No Internet Connection: Please check your Wi-Fi or Mobile Network connection and try again." I am certain that my Internet wifi connection works as I can access Opera Mini, the regular browser, and all my other apps that use wifi just fine.

    I have a Blackberry Curve 8900, and I am using 5.0. Does anyone have any suggestions? I have already re-installed Kindle a billion times, removed and re-inserted my media card, tried everything I can think of. I'm on a MacBook Pro.

    Thanks for any help.
    03-19-12 05:35 PM
  5. Rootbrian's Avatar
    I am having this same problem. The weirdest thing is that it worked perfectly fine before -- though at some point, it stopped syncing. I can read books that I've uploaded onto my media card, but I have to work around the sign-in screen in order to access my library -- in other words, I have to do this:

    1. Open Amazon Kindle.
    2. Go to the sign-in screen.
    3. Hit the options button to get to the "Home" option.
    4. Access library.


    It's a pain in the . I'd rather just be able to log into Amazon and sync my stuff up, but whenever I try, I get "No Internet Connection: Please check your Wi-Fi or Mobile Network connection and try again." I am certain that my Internet wifi connection works as I can access Opera Mini, the regular browser, and all my other apps that use wifi just fine.

    I have a Blackberry Curve 8900, and I am using 5.0. Does anyone have any suggestions? I have already re-installed Kindle a billion times, removed and re-inserted my media card, tried everything I can think of. I'm on a MacBook Pro.

    Thanks for any help.
    What version of OS 5 are you running? If you want to try and reload it or update to one not from your carrier, a later release, you'll need to use a virtual machine to do so. I recommend Virtualbox from www.virtualbox.org. Borrow a windows XP or 7 disc from a friend once you get it setup, then proceed to getting that installed, or just download Boot Camp.
    Luxbot likes this.
    03-19-12 05:55 PM
  6. Luxbot's Avatar
    So, it finally worked for me. I think the problem is that I'm on a pay-as-you-go plan from AT&T, and even though wifi works just fine for my other apps, Kindle requires a data plan to be able to sync up -- though not to read your books (you can still read your books that you have downloaded onto your Blackberry whether you have a data plan or not. You just can't log in).

    I was able to log into Kindle just now, after I added more funds to my GoPhone account, but it doesn't explain why I was unable to continue syncing even though I already had money in my account. So, I am still not sure what the issue is, even though it's not a problem for me anymore.
    03-19-12 06:09 PM
LINK TO POST COPIED TO CLIPBOARD