1. vincentnyc's Avatar
    doesn't work. on google talk, it said "connection error (65): problem recieving data from server." on msn messenger it said "service not enable for this handheld." am i missing a service book or something? can someone confirm if goodletalk and msn messenger supposed to work on tmobile network? can someone let me know what is the problem and how to fix this? thx in advance.

    ps i have EDGE on the upper right hand corner and can surf the web on my curve.
    11-26-08 02:20 PM
  2. Reed McLay's Avatar
    That is interesting, from previous discussion, I am under the impression there is no prepaid BIS service available through T-Mobile.

    Without BIS, you will not be able to use Email, BBMessenger or any third party software. Your Internet Browser should not work either, are you using the Hotspot Browser.

    11-26-08 02:32 PM
  3. vincentnyc's Avatar
    well i bought one of those unlimited minute and data ebay tmobile sim card. and i'm currently using the tzones browser...how do i send myself the necessary service book in order to get it to work. btw...did u edit my signature?
    11-26-08 02:38 PM
  4. Reed McLay's Avatar
    Yes, check your PMs.

    A data plan is not the same as BlackBerry Internet Service (BIS). If you can make phone calls, you already have your current service books.

    Good to know, the T-Zones (WAP) Browser does work with a data only plan.
    11-26-08 02:42 PM
  5. anon(1175881)'s Avatar
    T-Mobile does offer BIS on Flex pay accounts.
    11-26-08 02:43 PM
  6. vincentnyc's Avatar
    ok...how do i tell if i have bis on my bb or not and how do i send myself the necessary service book if i need it for google talk and msn messenger?

    btw...can someone confirm if google talk and msn messenger is supposed to work on tmobile usa network on a bb curve?
    11-26-08 02:46 PM
  7. vincentnyc's Avatar
    well...when my account was activated...i recieve a 2 message to my one. one was a txt message saying welcoming me to flex pay. and the other was from "blackberry" and it said "your handheld has been registered with the wireless network."

    so do i have bis or not? and what must i do to get it...can i send myself service book or register "host routing table" again?
    11-26-08 03:00 PM
  8. Navan's Avatar
    Go to the Tmobile BIS site and register your account with BIS...then send the service books from your account, and register your host routing table...then it should work.
    11-26-08 07:07 PM
  9. vincentnyc's Avatar
    ok just an update...use my tzone browser since i dont have a bb browser on my curve and try to create an email account and then send service book to myself. it did said "succesfully send." but it doesn't seem to add any service book...i still have 9 service books (same as before and after i activated my flex account). here are the 9 service books:

    bbfs1[bbim]
    provisioning [otasl]
    mms config 2.0 [wptcp]
    t-mobile usa wap browserconfig [browserconfig]
    t-mobile usa wap transport [wap]
    wap push config [wappushconfig]
    mms client [mms]
    bbfs1 [keynego]
    bbfs1 [bbimconfig]

    when i was under bes on at&t i remember i have more service book than the above.

    now here are my questions:

    1. i know i definately dont have bis...since i dont have bb browser and was trying to set up email but nothing is coming in. also try to send service book to myself and nothing new come in. so i guess i just have a generic data plan? am i correct?
    2. can someone please confirm if msn messenger (more important to me) and google talk (not that important to me) work on tmobile with or without bis plan?
    3. can i call up tmobile and tell them to give me bis plan since i have a generic data plan? but won't they question me since i bought this unlimited minute data sim card from ebay? i heard tmobile doesn't allow this.

    can someone out there who is a blackberry expert provide any advice? thx in advance.
    Last edited by vincentnyc; 11-26-08 at 08:23 PM.
    11-26-08 08:15 PM
LINK TO POST COPIED TO CLIPBOARD