1. whitespy1's Avatar
    I have an application that I used to run on my old Curve and it never gave me a problem, now I went to a 9300 3G and it keeps shutting down my app every time it goes into keyboard lock. How do I stop this? The app I am using is Instamapper. I need this app to keep running and it won't, can some on help?

    Warren
    12-20-10 02:30 PM
  2. stackberry369's Avatar
    Your bb shutting an app?the bb is smarter than I thought.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-20-10 03:09 PM
  3. whitespy1's Avatar
    every time the BB goes into device lock the app stops working and I need it to keep running. I think it is a setting but for the life of me I can't find which one. The app itself is very simple, it's either on or off and the bb terminates it upon locking.
    12-20-10 03:48 PM
  4. albee 1's Avatar
    Can you put the bb into standby instead? If you press the red key it should put the app into the background while still active. Try this before locking or putting into standby. Press and hold the bb key to popup the app switcher to reactivate.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-20-10 05:33 PM
  5. whitespy1's Avatar
    That didn't help.
    The first time I tried I ended shutting off the BB then did it while in the program and then locked the BB and it still terminated the app. This defeats going to the new phone, how frustrating.
    12-21-10 10:33 AM
  6. aparkins30's Avatar
    That didn't help.
    The first time I tried I ended shutting off the BB then did it while in the program and then locked the BB and it still terminated the app. This defeats going to the new phone, how frustrating.
    Sometimes the preference is in the application itself, for example I give google latitude permission to always run in the background....I think I could turn my phone off turn it on and it would automatically be running in the background still
    12-21-10 11:04 AM
  7. albee 1's Avatar
    Like aparkins said. Got Menu/Options/Applications. Click the app and edit permissions. Make sure all are set to Allow or Auto.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-10 11:22 AM
  8. whitespy1's Avatar
    That still didn't do the trick. Actually every thing was on allow. The same question has been brought up on the Apps web site. I sure hope there is a fix some where.
    12-21-10 01:12 PM
  9. aparkins30's Avatar
    That still didn't do the trick. Actually every thing was on allow. The same question has been brought up on the Apps web site. I sure hope there is a fix some where.
    Because the same question has been brought up on the apps web site it sounds like the application isn't correctly interacting with the BB OS. Stupid question (hopefully) but are you running the most up to date OS for your phone?
    12-21-10 04:25 PM
  10. hondateg91's Avatar
    Did you recently load os 6 onto yor phone? Its possbile the app hasn't been updated to work with the new OS.
    12-21-10 04:40 PM
  11. BoldtotheMax's Avatar
    That is probably the culprit^^^

    Posted from my CrackBerry at wapforums.crackberry.com
    12-21-10 09:10 PM
  12. albee 1's Avatar
    Hopefully we hear back from whitespy, hondateg may have hit the nail!

    Posted from my CrackBerry at wapforums.crackberry.com
    12-22-10 12:58 PM
LINK TO POST COPIED TO CLIPBOARD