08-25-13 05:45 AM
1,385 ... 4142434445 ...
tools
  1. Sean_In_Columbus's Avatar
    You can avoid 3 shortcuts keys by just creating your one and two letters shortcuts. They will then launch (if you have set 'Auto Launch After First Click' to Yes). You can also make AA launch AA if you avoid creating AAX (X being any letter) shortcut.
    Gotcha - Gonna stick to the A & AA only format as much as I can and if I use an AAA, I can just launch it with a tap or trackpad click! Thanks!

    No, if you have A and AA shortcuts and you hit AA, then SCM finds a single match (AA) and launches it. On the other hand, if you have AA and AAA shortcuts, hitting AA will cause SCM to find AA and AAA
    Ah - yeah, that makes sense - my logic was flawed. Thanks for the clearing that up.

    All in all, none of my issues are deal breakers - SCM is an awesome app that just adds to why I don't think I'll ever go wiothout a tactile keyboard. BTW, I am a recent Quick Launch convert. I liked QL but it has nowhere the tweakability and customization POWER that SCM does! PERIOD. (Plus my intitials are SCM)!

    Thanks again everyone!

    One more issue to bounce - my date and time are at the bottom of the shortcuts list and are tiny. Shouldn't they be above (or in) the header?
    02-02-12 02:44 PM
  2. the_man_from_nowhere's Avatar
    Just out of curiousity, couldn't you just verify the length of what your searching, say "AA", with the search results? Wouldn't that solve the current issue? For example, if you type "A", and have the algorithm only return results with "A" in the shortcut and has a length of 1, eliminating AA and AAA as possiblities, and since there should only be only one command to A, you could just launch the result. Same with Sean's AA issue, say he should press AA, the program could then search results containing AA and have a length of two, eliminating AAA as a possibility. I'm currently a computer engineering major, although I'm fresh into the major, I have taken a few intro to computer programming courses in java and C++, and it just seems like an easy fix, maybe I'm missing something?
    02-02-12 03:38 PM
  3. Vijik's Avatar

    All in all, none of my issues are deal breakers - SCM is an awesome app that just adds to why I don't think I'll ever go wiothout a tactile keyboard. BTW, I am a recent Quick Launch convert. I liked QL but it has nowhere the tweakability and customization POWER that SCM does! PERIOD. (Plus my intitials are SCM)!
    Glad to see you like SCM. Hopefully, when you feel comfortable with macros, you can share your macros on this thread.

    (Plus my intitials are SCM)!


    One more issue to bounce - my date and time are at the bottom of the shortcuts list and are tiny. Shouldn't they be above (or in) the header?
    In newer version of SCM, date/time text is moved from header to footer of the main screen.
    02-03-12 04:05 AM
  4. Vijik's Avatar
    Just out of curiousity, couldn't you just verify the length of what your searching, say "AA", with the search results? Wouldn't that solve the current issue? For example, if you type "A", and have the algorithm only return results with "A" in the shortcut and has a length of 1, eliminating AA and AAA as possiblities, and since there should only be only one command to A, you could just launch the result. Same with Sean's AA issue, say he should press AA, the program could then search results containing AA and have a length of two, eliminating AAA as a possibility. I'm currently a computer engineering major, although I'm fresh into the major, I have taken a few intro to computer programming courses in java and C++, and it just seems like an easy fix, maybe I'm missing something?
    If it was designed like that, it would mean that SCM should always wait a bit (800 -1000 mS) after second click to see if you wanted to click the 3rd key.
    That would again mean a delay in launching all shortcuts with 2 shortcut keys.
    02-03-12 04:10 AM
  5. data77's Avatar
    I wanted to toggle between these 2 settings. Can anyone help me? Thank you!

    Security --> Password --> Lock After -> 1 minute
    AND
    Security --> Password --> Lock After -> 30 minute
    02-11-12 09:47 PM
  6. Vijik's Avatar
    I wanted to toggle between these 2 settings. Can anyone help me? Thank you!

    Security --> Password --> Lock After -> 1 minute
    AND
    Security --> Password --> Lock After -> 30 minute
    Try this one:

    Delay100;
    Input $time,Enter 0 for 30Min, 7 for 1Min;
    Launch Options;
    Delay100;
    KeyLock A;
    Delay50;
    NavClick; /*Password Page Opened*/
    Delay50;
    MenuItemFromTop4; /* Go to Lock After */
    Navclick;
    Delay50;
    MenuItemFromTop $time; /* go to 30Min or 1Min */
    Navclick;
    ESCKey;
    delay50;
    Navclick;
    KeyXXXX; /* replace XXXX with your device Password */
    ENTERKey;
    ESCKey;
    ESCKey;



    Before "Launch Options;" you could use the macros that were once posted on this thread where macros made sure that none of the Options pages was already open.
    Last edited by Vijik; 02-12-12 at 12:12 AM.
    02-11-12 11:29 PM
  7. data77's Avatar
    Thanks much. for some reason it goes to 2 minute instead of 1 and also goes to 1 hour instead of 30 minutes.

    Maybe it is an easy fix. Looking forward to your help. Thanks!!

    Try this one:

    Delay100;
    Input $time,Enter 0 for 30Min, 7 for 1Min;
    Launch Options;
    Delay100;
    KeyLock A;
    Delay50;
    NavClick; /*Password Page Opened*/
    Delay50;
    MenuItemFromTop4; /* Go to Lock After */
    Navclick;
    Delay50;
    MenuItemFromTop $time; /* go to 30Min or 1Min */
    Navclick;
    ESCKey;
    delay50;
    Navclick;
    KeyXXXX; /* replace XXXX with your device Password */
    ENTERKey;
    ESCKey;
    ESCKey;



    Before "Launch Options;" you could use the macros that were once posted on this thread where macros made sure that none of the Options pages was already open.
    02-13-12 10:51 PM
  8. Vijik's Avatar
    Thanks much. for some reason it goes to 2 minute instead of 1 and also goes to 1 hour instead of 30 minutes.

    Maybe it is an easy fix. Looking forward to your help. Thanks!!
    When you go to
    Security --> Password --> Lock After

    1- What is the first item on the list (30 Min or 1 Hour)?

    2- What is the 7th item on the list (2 Min or 1 Min)?

    3- From top of Lock After items what is the position of "30 Min" and "1 Min" (First item on top is item 1).
    02-15-12 08:40 PM
  9. TomCanuck's Avatar
    Is there a way to disable Shortcuts from the space key.
    Yes, look in the Common Config... :\

    You can choose from a number of different home screen hotkeys or disable it altogether
    Last edited by Juggalo20; 02-15-12 at 09:38 PM.
    02-15-12 09:35 PM
  10. dimm0k's Avatar
    With the new 7.1 OS for the 99xx, there's the option for DLNA media serving... Actually surprised to see it available in SCM via "Media Server" AppName, but it works allows me to turn it on via SCM. Is there a way to have to turn it off as well?
    02-17-12 09:10 AM
  11. TomCanuck's Avatar
    With the new 7.1 OS for the 99xx, there's the option for DLNA media serving... Actually surprised to see it available in SCM via "Media Server" AppName, but it works allows me to turn it on via SCM. Is there a way to have to turn it off as well?
    disconnect then reconnect wifi, i *THINK*

    here's how I tested:

    with radio and wifi connected,
    launched Media Server,
    Got message about turing in file sharind,
    Launched media server to see what it did and it did nothing,
    Disconnected Wifi,
    launched media server and it displayed message about turning on, which leads me to believe it had turned off when i disconnected wifi.
    launched media server again to see what it did and it did nothing
    connected to wifi
    launched media server again to see what it did, did nothing
    disconnected from wifi,
    launched media server, again got a message about turning it on.

    so i can only assume disconnecting from wifi is turning it off.

    this is buggy on 7.1.0.267 i *think*, it screwed my screen horribly, like moved the bottom right corner of the display up to the upper left corner of my screen. as in. the icons which are along the bottom of my screen (in a 1 teir dock, closed) were up in the left hand corner.

    THE FIX for this, is to launch any app. and your screen will readjust.

    I'm using a theme as well though, so who knows if that plays into it.
    Vijik likes this.
    02-17-12 10:34 AM
  12. dimm0k's Avatar
    disconnect then reconnect wifi, i *THINK*

    here's how I tested:

    with radio and wifi connected,
    launched Media Server,
    Got message about turing in file sharind,
    Launched media server to see what it did and it did nothing,
    Disconnected Wifi,
    launched media server and it displayed message about turning on, which leads me to believe it had turned off when i disconnected wifi.
    launched media server again to see what it did and it did nothing
    connected to wifi
    launched media server again to see what it did, did nothing
    disconnected from wifi,
    launched media server, again got a message about turning it on.

    so i can only assume disconnecting from wifi is turning it off.

    this is buggy on 7.1.0.267 i *think*, it screwed my screen horribly, like moved the bottom right corner of the display up to the upper left corner of my screen. as in. the icons which are along the bottom of my screen (in a 1 teir dock, closed) were up in the left hand corner.

    THE FIX for this, is to launch any app. and your screen will readjust.

    I'm using a theme as well though, so who knows if that plays into it.
    Looks like that did it, toggling Wi-Fi turns off the media server and toggling Wi-Fi back on again does not start the media server again.

    Might be your theme because it's not shifting anything for me...
    02-17-12 10:52 AM
  13. Vijik's Avatar
    Good observation Juggalo.

    Media sharing doesn't mess up anything on my BB either (I don't use any theme).
    02-18-12 12:10 AM
  14. TomCanuck's Avatar
    Really? No themes? You guys are missing out hah. I've read they can be buggy, but this is the first issue I've had so far. Not bad in my opion, since Media Server isn't accessable without 3rd party launching as far as I know.
    02-18-12 12:24 AM
  15. deejayburnout's Avatar
    Been using the following set of commands for a reset/battery pull

    While0 IsAppRunning Home Screen;
    Do0;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    EndWhile0;

    It works but it has a few 'flaws' with it.

    1. Sometimes it needs an additional keypress to make it work.

    2. It often seems not to work and locks up my device. After a few mins my device works again then I have to try again.

    Luckly I can use the alt + caps + Del combo on my keyboard.

    Is there a way to do the combo via the macro. I did try but nothing seems to happen.

    Drawn from my mind by my fingers onto my 9900.
    02-19-12 10:45 AM
  16. TomCanuck's Avatar
    Been using the following set of commands for a reset/battery pull

    While0 IsAppRunning Home Screen;
    Do0;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    BackLightOff;
    EndWhile0;

    It works but it has a few 'flaws' with it.

    1. Sometimes it needs an additional keypress to make it work.

    2. It often seems not to work and locks up my device. After a few mins my device works again then I have to try again.

    Luckly I can use the alt + caps + Del combo on my keyboard.

    Is there a way to do the combo via the macro. I did try but nothing seems to happen.

    Drawn from my mind by my fingers onto my 9900.
    Yeah, the macro has never been advertised as perfect heh.

    No it is not possible to do alt+shift+del via macro. RIM's apis don't allow for 3 button presses at the same time. Like..... there's just no way to simulate holding alt then pressing and holding shift then hitting DEL.

    Keystroke injection only allows for 2 keys :<

    That's what prompted finding of that backlightoff macro. heh, dont be shy to screw around with it and see if you can make it work better for you. as it is it works for me....
    if it messes up your phone, not my fault :P but iunno what else you can do.
    02-19-12 10:55 AM
  17. Vijik's Avatar
    Yeah, the macro has never been advertised as perfect heh.

    No it is not possible to do alt+shift+del via macro. RIM's apis don't allow for 3 button presses at the same time. Like..... there's just no way to simulate holding alt then pressing and holding shift then hitting DEL.

    Keystroke injection only allows for 2 keys :<

    That's what prompted finding of that backlightoff macro. heh, dont be shy to screw around with it and see if you can make it work better for you. as it is it works for me....
    if it messes up your phone, not my fault :P but iunno what else you can do.
    Correct.
    I have specifically asked RIM if key injection allowed injecting 3 keys and they said no.
    Maybe that is done intentionally so that no app can do a device restart without a prompt.
    02-20-12 12:00 PM
  18. Chopper110's Avatar
    HHHEEEEEEELLLLLLPPPPPP !!!!!!!!!!

    Just bought version 5.9.5.1 from BB App World and it wont launch. Trying to run it on 9900 v7.

    A window pops up telling me that the trial version needs the key entered in the common configeration page!

    I cant get in to the app and cant find this page anywere else.

    Can anyone help please?
    02-25-12 01:46 PM
  19. TomCanuck's Avatar
    HHHEEEEEEELLLLLLPPPPPP !!!!!!!!!!

    Just bought version 5.9.5.1 from BB App World and it wont launch. Trying to run it on 9900 v7.

    A window pops up telling me that the trial version needs the key entered in the common configeration page!

    I cant get in to the app and cant find this page anywere else.

    Can anyone help please?
    Open App World, go into "My World" find ShortcutMe, scroll all the way to the bottom (on App World 3.x), and you'll see "License Key" copy paste that into ShortcutMe.

    To enter it into ShortcutMe, launch ShortcutMe, hit the menu key, go into Common Config
    02-25-12 01:53 PM
  20. flashop's Avatar
    I also recommend after you put in your product key and have macros setup to do a backup that way it saves it to the sd card. I will save the product key as well so if you ever need to do a restore then you brings every back as it was.

    Sent from my BlackBerry 9930 using Tapatalk
    TomCanuck likes this.
    02-25-12 01:59 PM
  21. flashop's Avatar
    Social Feeds Macro
    I like social feeds for posting to twitter and facebook at the same time. I have found a few macros on this thread that work but had errors from time to time so I have finally found a combination that's been working for ever a week for me without errors and I figured I would share. The error I was getting was "your post must contraint text" because the old macro was doing the macro twice instead of once.

    App name:
    Feeds

    Macro:
    LaunchAndWait Feeds;
    MENUKey;
    KeyN;
    NavClick;

    I have my hotkey as U for Update Status but that's just how I do it.

    Sent from my BlackBerry 9930 using Tapatalk
    02-25-12 02:11 PM
  22. Chopper110's Avatar
    Open App World, go into "My World" find ShortcutMe, scroll all the way to the bottom (on App World 3.x), and you'll see "License Key" copy paste that into ShortcutMe.

    To enter it into ShortcutMe, launch ShortcutMe, hit the menu key, go into Common Config
    Thanks for that, key now entered.

    One interesting point, I had to down grade from the version downloaded from appworld to 5.8.1.5_T

    Now the headache! I am looking at the screen shots on my PC and not seeing anything like that on the 9900. Am I going wrong?

    How does this work with NFC_Shortcuts?

    I want to start simple with, Bluetooth on Wifi off, for in the car and the reverse for when I get home. Is this easy?

    Sorry, but I seem to have a big mental block with the app
    02-25-12 02:52 PM
  23. TomCanuck's Avatar
    Thanks for that, key now entered.

    One interesting point, I had to down grade from the version downloaded from appworld to 5.8.1.5_T

    Now the headache! I am looking at the screen shots on my PC and not seeing anything like that on the 9900. Am I going wrong?

    How does this work with NFC_Shortcuts?

    I want to start simple with, Bluetooth on Wifi off, for in the car and the reverse for when I get home. Is this easy?

    Sorry, but I seem to have a big mental block with the app
    That point isn't interesting unless you explain WHY you had to downgrade.

    No ideal what you're talking about with screen shots on your pc.

    It works with NFC_Shortcuts by you configuring a NFC tag to launch ShortcutMe with the 3 letter shortcut for the SCM shortcut you wish to launch.

    The function you want is somewhat easy. Anything related to detecting if Bluetooth is on is kind of annoying thanks to RIM forcing a prompt, but doable. I'll update this post with the macro for it when I get home later.
    02-25-12 03:02 PM
  24. Chopper110's Avatar
    That point isn't interesting unless you explain WHY you had to downgrade.

    No ideal what you're talking about with screen shots on your pc.

    It works with NFC_Shortcuts by you configuring a NFC tag to launch ShortcutMe with the 3 letter shortcut for the SCM shortcut you wish to launch.

    The function you want is somewhat easy. Anything related to detecting if Bluetooth is on is kind of annoying thanks to RIM forcing a prompt, but doable. I'll update this post with the macro for it when I get home later.
    The reason for the down grade was, when I checked for updates SCM's web site stated that the version from Appworld was wrong and that I needed 5.8.1.5_T

    The screen shots I am reffering to are the ones on SCM's website, also shown on appworld. I have nothing like them.
    02-25-12 03:10 PM
  25. chautime's Avatar
    I'm new with the shortcutme macros. This is actually my first one. Appreciate any assistance anyone can provide. I'm trying to create a macro that closes an app called Bugme that starts in the background. I read post #336 in this thread and came up with this:

    If0;
    IsAppRunning bugme;
    Then0;
    Launch bugme;
    MENUkey;
    Delay100;
    MenuItemFromBottom3;
    Delay100;
    NavClick;
    Delay100;
    NavMoveDown1;
    NavClick;
    EndIf0;

    I think I have a syntax problem as I get an error: Error reading integer number (If).

    Here's the sequence - check and see if the app is running, if yes, launch app. Then Click menu, goto option that is 3rd from the bottom (Exit) and click. The app has a secondary menu that pops up with 3 options. I select the middle option and click.

    Can someone please help me out with this? Any tips and hints for a newbie would also be appreciated.
    02-26-12 04:08 PM
1,385 ... 4142434445 ...
LINK TO POST COPIED TO CLIPBOARD