08-25-13 05:45 AM
1,385 ... 4041424344 ...
tools
  1. TomCanuck's Avatar
    Sorry for the delay. I couldn't find Social Feeds in App World (dunno? Maybe cuz I'm on os 7.1?) Anyways, so I had to find time to load it manually, which I did tonight at work.

    Vijik is 100% correct. Use Feeds

    LaunchAndWait Feeds;
    MenuKey;
    *Keyr;
    NavClick;

    Posted from my CrackBerry at wapforums.crackberry.com
    01-19-12 11:30 PM
  2. TomCanuck's Avatar
    No clue if I've posted this in the past or not. If I have here's an update. If I haven't here's a macro I use to handle my ringer profile switching.

    I use it as a replacement for the built in Q hotkey. So I always know what it's changing to. How I have it set, is if my ringer profile is set to normal, it'll switch to vibrate, if it's set to vibrate then it will switch to normal, if it's set to something else I'll be asked what I wish to swtich to if I don't respond within 3 seconds it defaults to vibrate.

    If I have posted this before. Then this update contains a fix for an empty variable. Previously if I didn't enter any text into the input box, and just hit the EnterKey or clicked continue the macro would continue running but wouldn't make any changes. This occured because by clicking "Continue" or hitting the EnterKey the variable was being set, so IsDefined was returning TRUE but the variable was blank. Fixed this by setting $fixnull to blank (Set $fixnull= then doing comparison (If1 IsDefined $pro && $pro != $fixnull)

    To adapt this to your match your "Normal" profile or whatever one you wish to substitute in place of it, look for the red bolded line, change the 70 to match the ringer volume of the profile you wish to use. You can find the ringer volume by switching to the profile then running the macro:

    Set $rpv=GetProfileVolume;
    Show $rpv;

    Or by going into your BlackBerry ringer profiles, looking at the phone ringer volume and multiplying by 10 (mine's set to 7 in ringer profiles, so it's 70 in the macro)

    This was written back originally on OS 7.0 I think, but recent modifications have been on SCM 5.9.5.1_OS7_T on 9900/7.1.0.205.

    And with that... The macro

    Set $fixnull=;
    If0 IsProfileOnVibOnly;
    Then0;
    Launch Profile_Selector;
    Delay100;
    *Keyn;
    NavClick;
    ElseIf0 GetProfileVolume == 70;
    Launch Profile_Selector;
    Delay100;
    *Keyv;
    NavClick;
    Else0;
    Input $pro,enter the first letter of the profile to switch to #3000;
    If1 IsDefined $pro && $pro != $fixnull;
    Then1;
    Launch Profile_Selector;
    Delay100;
    *Key$pro;
    NavClick;
    Else1;
    Launch Profile_Selector;
    Delay100;
    *Keyv;
    NavClick;
    EndIf1;
    EndIf0;

    Posted from my CrackBerry at wapforums.crackberry.com
    Vijik likes this.
    01-20-12 02:05 AM
  3. Vijik's Avatar
    Juggalo20, Very cool macro.

    I am working on a new version of ShortcutMe, and already have added 2 new macros called 'IsValidNumber' and 'IsValidText'.
    Those 2 macros are made to address the same issue you (and others) have seen regarding variables that supposed to be set at macro runtime, but are either left empty or not set to proper value.
    TomCanuck and B4me like this.
    01-20-12 05:35 AM
  4. TomCanuck's Avatar
    Juggalo20, Very cool macro.

    I am working on a new version of ShortcutMe, and already have added 2 new macros called 'IsValidNumber' and 'IsValidText'.
    Those 2 macros are made to address the same issue you (and others) have seen regarding variables that supposed to be set at macro runtime, but are either left empty or not set to proper value.
    Ahha. Nice

    Posted from my CrackBerry at wapforums.crackberry.com
    01-20-12 05:38 AM
  5. quik4life's Avatar
    How do I get 3 or 4 macros to run in one macro? For example, I have two macros named WiFi On (WIO) and Profile Vibrate (PV). How do I create a macro to have both run at the same time?

    This is what I did:

    Macros:
    ImportMacro WIO;
    ImportMacro PV;

    But then an error came out same it was not found to import from! (Whatever that means...)

    Any help would be greatly appreciated.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-20-12 10:09 PM
  6. TomCanuck's Avatar
    How do I get 3 or 4 macros to run in one macro? For example, I have two macros named WiFi On (WIO) and Profile Vibrate (PV). How do I create a macro to have both run at the same time?

    This is what I did:

    Macros:
    ImportMacro WIO;
    ImportMacro PV;

    But then an error came out same it was not found to import from! (Whatever that means...)

    Any help would be greatly appreciated.

    Posted from my CrackBerry at wapforums.crackberry.com
    ImportMacro does just that, it ONLY imports any Macros from those shortcuts. If you have no macros in a shortcut, it throws the error that there are none.

    To launch multiple shortcuts use

    App Name: CascadedShortcuts
    Parameter: Shortcut1;Shortcut2;Etc

    Note that this will not work if the shortcuts are to launch a urls.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-20-12 10:12 PM
  7. quik4life's Avatar
    Thank you soooo much!!!

    Thanks for everyone's help. This has got to be the greatest app ever created!!
    TomCanuck likes this.
    01-20-12 10:58 PM
  8. jc_halifax's Avatar
    I'd try the alternative launches. I've run into a few oddities that the launched app behaved weird, but alternative launch fixed.

    If the app is free, I'll download and toy with it and see if i can get it working. If it's free just toss a link here.
    Tried alternative launches but doesn't seem to launch the app at all. The app is free on AppWorld here: http://appworld.blackberry.com/webst.../20708?lang=en

    Any help would be greatly appreciated!
    01-24-12 10:46 AM
  9. TomCanuck's Avatar
    Tried alternative launches but doesn't seem to launch the app at all. The app is free on AppWorld here: Buy Endomondo Sports Tracker PRO - Download Endomondo Sports Tracker PRO - Buy Apps from BlackBerry App World

    Any help would be greatly appreciated!
    That link is to the $3.99 version. But I did find the free version. I've tried everything i can think of. The app's foreground name, the application's module names, the name in the escreen process list ... all with alternative launches. And I can't get it to launch properly.... I get the corruption error when i launch the app's foreground name without alternative launches. and nothing else i tried worked at all :\

    But.... All is not lost I don't think. I did a little testing, and I don't see any issues with that corruption message. My history is still there and the application behaves fine from what I can tell... so I suggest using (modify this for the paid version if you need to)

    App Name: Macro
    Macros:
    LaunchAndWait Endomondo Free;
    NavClick;

    This will click "Ok" about that corruption message. Let me know if there is actually a problem with the Endomondo app not working properly with this though. Just so I know if this ever comes up again.

    Written/tested using. 5.9.5.1_OS7_T on 9900/7.1.0.205
    01-24-12 10:05 PM
  10. jc_halifax's Avatar
    That link is to the $3.99 version. But I did find the free version. I've tried everything i can think of. The app's foreground name, the application's module names, the name in the escreen process list ... all with alternative launches. And I can't get it to launch properly.... I get the corruption error when i launch the app's foreground name without alternative launches. and nothing else i tried worked at all :\

    But.... All is not lost I don't think. I did a little testing, and I don't see any issues with that corruption message. My history is still there and the application behaves fine from what I can tell... so I suggest using (modify this for the paid version if you need to)

    App Name: Macro
    Macros:
    LaunchAndWait Endomondo Free;
    NavClick;

    This will click "Ok" about that corruption message. Let me know if there is actually a problem with the Endomondo app not working properly with this though. Just so I know if this ever comes up again.

    Written/tested using. 5.9.5.1_OS7_T on 9900/7.1.0.205
    Ooops, sorry about the link. Yes, the app does seem to perform fine. Of course, I never thought of adding a NavClick at the end, lol. Thanks for even taking the time to look at this. You're awesome!
    TomCanuck likes this.
    01-27-12 05:25 AM
  11. visortgw's Avatar
    Try

    Launch Feeds;

    And as Juggalo20 wrote sometimes (all depending on how BB OS behaves from one version to another) you need to use *Key instead of Key macro.

    Posted from my CrackBerry at wapforums.crackberry.com
    @vijik: I am experiencing similar issues launching the Device Switch wizard (in order to automate backups to the microSD card in OS v7 or newer). I have tried using both DeviceSwitch from the app list as well as Launch DeviceSwitch from a macro with and without Alternative Launchings -- nothing works unless the app is already in the background. As a workaround, I can use Universal Search, but it is not foolproof. Any other ideas?
    01-27-12 12:14 PM
  12. TomCanuck's Avatar
    @vijik: I am experiencing similar issues launching the Device Switch wizard (in order to automate backups to the microSD card in OS v7 or newer). I have tried using both DeviceSwitch from the app list as well as Launch DeviceSwitch from a macro with and without Alternative Launchings -- nothing works unless the app is already in the background. As a workaround, I can use Universal Search, but it is not foolproof. Any other ideas?
    I'm no Vijik, but I made the macro for you. You probably have to modify it, the presence or lack there of of BlackBerry Bridge AND NFC play a part in the NavMoves.

    Written/tested using 5.9.5.1_OS7_T on 9900/7.1.0.205

    LaunchAndWait Toolkit;
    NavMoveDown2;
    NavMoveRight4;
    NavClick;

    That's as far as you get with macros. Looks like input simulation is blocked from here on out.

    edit 1
    i think it has to be done this way, seems you can't launch Device Switch without the toolkit open, If you notice, open them manually, then close "Setup" and device switch closes also,
    Last edited by Juggalo20; 01-27-12 at 01:37 PM.
    visortgw and Vijik like this.
    01-27-12 01:15 PM
  13. visortgw's Avatar
    I'm no Vijik, but I made the macro for you. You probably have to modify it, the presence or lack there of of BlackBerry Bridge AND NFC play a part in the NavMoves.

    Written/tested using 5.9.5.1_OS7_T on 9900/7.1.0.205

    LaunchAndWait Toolkit;
    NavMoveDown2;
    NavMoveRight4;
    NavClick;

    That's as far as you get with macros. Looks like input simulation is blocked from here on out.

    edit 1
    i think it has to be done this way, seems you can't launch Device Switch without the toolkit open, If you notice, open them manually, then close "Setup" and device switch closes also,
    As always, you are a tremendous asset to this forum and thread -- once again you pointed me in the right direction! Here is the completed macro to Backup Device to microSD (delays are based upon personal experience):

    Application Name: Macro
    Macro:
    Delay1000;
    InjectDelay100;

    Set $loop=1;
    While0 IsAppRunning Toolkit && $loop<9;
    LaunchAndWait Toolkit;Do0;
    EscKey;
    Inc $loop;
    EndWhile0;

    NavMoveDown2;Delay100;
    NavMoveRight4;Delay100;
    NavClick;Delay500;

    NavClick;Delay100;
    NavClick;Delay100;
    NavMoveDown1;Delay100;
    NavClick;Delay100;

    PasswordKey[Insert password without brackets]; Delay250;
    NavMoveDown1;
    PasswordKey[Repeat password without brackets]; Delay250;
    NavMoveDown2;Delay250;
    NavClick;

    I also suggest using the Encrypt Passwords capability:

    In SCM macro editor after substituting your password of choice (same password twice) where indicated above without brackets, hit BlackBerry® key, and select "Encrpyt Passwords" from pull-down menu. Save macro.
    TomCanuck and Vijik like this.
    01-27-12 02:09 PM
  14. TomCanuck's Avatar
    As always, you are a tremendous asset to this forum and thread -- once again you pointed me in the right direction! Here is the completed macro to Backup Device to microSD (delays are based upon personal experience):

    Application Name: Macro
    Macro:
    Delay1000;
    InjectDelay100;

    Set $loop=1;
    While0 IsAppRunning Toolkit && $loop<9;
    LaunchAndWait Toolkit;Do0;
    EscKey;
    Inc $loop;
    EndWhile0;

    NavMoveDown2;Delay100;
    NavMoveRight4;Delay100;
    NavClick;Delay500;

    NavClick;Delay100;
    NavClick;Delay100;
    NavMoveDown1;Delay100;
    NavClick;Delay100;

    PasswordKey[Insert password without brackets]; Delay250;
    NavMoveDown1;
    PasswordKey[Repeat password without brackets]; Delay250;
    NavMoveDown2;Delay250;
    NavClick;

    I also suggest using the Encrypt Passwords capability:

    In SCM macro editor after substituting your password of choice (same password twice) where indicated above without brackets, hit BlackBerry® key, and select "Encrpyt Passwords" from pull-down menu. Save macro.
    What OS version are you running? Sucks they seem to have blocked input simulation on 9900/7.1.0.205 I can't use your macro
    01-27-12 08:27 PM
  15. visortgw's Avatar
    What OS version are you running? Sucks they seem to have blocked input simulation on 9900/7.1.0.205 I can't use your macro
    BlackBerry® Bold™ 9930 (aka Touch), OS v7.1.0.163 (rel 457), Platform 5.1.0.137, aka VZW MR2

    Posted from my CrackBerry at wapforums.crackberry.com
    01-27-12 08:30 PM
  16. TomCanuck's Avatar
    Posting this because... Well I can't for the life of me spot an error, yet I cannot make this work. Hoping someone can help

    Non working part of my macro;

    While9 IsAppForeground MediaCommon;
    Do9;
    *EscKey;
    EndWhile9;

    What blows me away, is this kind of works. It presses EscKey once but that's it. I tried. I know the foreground app name doesn't change, because if I try

    While9 IsAppForeground MediaCommon;
    Do9;
    *EscKey;
    Ding100;
    EndWhile9;

    The ding loops forever. I've also tried

    While9 IsAppForeground MediaCommon;
    Do9;
    EscKey;
    EndWhile9;

    And

    While9 IsAppForeground MediaCommon;
    Do9;
    *EscKey;
    EscKey;
    EndWhile9;

    I don't understand :'(
    01-27-12 10:40 PM
  17. Sean_In_Columbus's Avatar
    I am trying to set up my shortcuts so that the first letters of shortcut names associate with the actual shortcut keys - like below:

    A - Alarm Toggle
    AA - Analyzer
    AAA - App World

    Weird thing - when I set them up this way, the 2 key shortcut (AA) does not run when I press the A key twice - it only runs when I scroll to it in the SCM shortcut list and press the trackpad (or tap it on the touch screen). The AAA and the A key presses fire their prospective shortcuts but the AA doesn't.

    If I remove the AAA, the AA works. Is this a glitch or is this a built in limitation of the software?

    I apologize if this is posted elsewhere, but my searches yielded no fruit.

    Thanks in advance,
    Sean
    02-02-12 12:25 PM
  18. franzfume's Avatar
    Yep I also noticed it-
    02-02-12 12:30 PM
  19. TomCanuck's Avatar
    I am trying to set up my shortcuts so that the first letters of shortcut names associate with the actual shortcut keys - like below:

    A - Alarm Toggle
    AA - Analyzer
    AAA - App World

    Weird thing - when I set them up this way, the 2 key shortcut (AA) does not run when I press the A key twice - it only runs when I scroll to it in the SCM shortcut list and press the trackpad (or tap it on the touch screen). The AAA and the A key presses fire their prospective shortcuts but the AA doesn't.

    If I remove the AAA, the AA works. Is this a glitch or is this a built in limitation of the software?

    I apologize if this is posted elsewhere, but my searches yielded no fruit.

    Thanks in advance,
    Sean
    Yep I also noticed it-
    What SCM version (so i know which versions to check this out on if i have it) and OS version/devices are you guys running?
    02-02-12 12:34 PM
  20. Sean_In_Columbus's Avatar
    Oops - my apologies.

    I am running ShortcutMe_Touch Ver.: 5.9.5.1_OS7_T on a Verizon 9930 with BB OS7.1.0.163 (Platform 5.1.0.137).
    02-02-12 12:42 PM
  21. Vijik's Avatar
    @Sean_In_Columbus,

    It is not a glitch. It is designed like that.

    Generally when you hit a series of shortcut keys, as soon as a single match is found for those keys, the shortcut will be launched. If you have other shortcuts with the same keys as part of their shortcut keys (shortcut key conflict), then it doesn't launch.

    The exception for the above rule is auto launch with single click that you control by setting "Auto launch after 1st click" in Common Config page.


    Case 1:
    Shortcuts A, AA, AAA
    Hitting AA will not launch AA because AAA has AA as part of it's keys.

    Case 2:
    Shortcuts A, AA, AB
    Hitting AA will launch AA

    Case 2:
    Shortcuts A, AA, AA
    Hitting AA will not launch AA. It will only show AA, AA shortcuts



    This feature can be used to quickly sort and see shortcuts.

    Case 3:
    Shortcuts:
    .....
    ACA Apps, Calculator
    ACM Apps, Camera
    AMO Apps, My Own Icons
    ....

    When you hit A, you can see all of your Apps shortcuts (ACA, ACM, AMO)
    When you hit AC you see all of your Apps with name starting with C (ACA, ACM)

    This is useful when you have many shortcuts. Many people don't remember all the shortcut keys if they have more than 50 shortcuts.
    This will help them to narrow down the shortcut list before finding and launching one.
    02-02-12 12:52 PM
  22. Sean_In_Columbus's Avatar
    OK - that's what I figured. However, the 3 different key strokes (or even 2) is what I am trying to avoid. Having to type 3 keys all over the keyboard is kind of counterproductive to the whole shortcut concept. I was hoping to be able to use simple, same letter key combos so I don't have to hunt and peck for 3 different keys - I gues I am kind of a streamline nut that way but oh well.

    Quick question though - according to what you explained about why AAA won't work, in the A, AA only scenario, shouldn't AA be canceled out by A since A is already taken?

    Thanks a million for your timely and thorough explanation.
    Sean
    02-02-12 01:14 PM
  23. TomCanuck's Avatar
    OK - that's what I figured. However, the 3 different key strokes (or even 2) is what I am trying to avoid. Having to type 3 keys all over the keyboard is kind of counterproductive to the whole shortcut concept. I was hoping to be able to use simple, same letter key combos so I don't have to hunt and peck for 3 different keys - I gues I am kind of a streamline nut that way but oh well.

    Quick question though - according to what you explained about why AAA won't work, in the A, AA only scenario, shouldn't AA be canceled out by A since A is already taken?

    Thanks a million for your timely and thorough explanation.
    Sean
    no, there's an option in the config for this. I always thought it applied to 2 letter shortcuts as well (hence why i went to test) but apparently it only applies to 1 letter. In the Common Config you can enable/disable 1 letter shortcuts (if there's a 2 or more letter shortcut that starts with the same letter) forgive my poor explination heh it's the 'Auto Launch After First Click" option in the Common Config
    02-02-12 01:17 PM
  24. Sean_In_Columbus's Avatar
    no, there's an option in the config for this. I always thought it applied to 2 letter shortcuts as well (hence why i went to test) but apparently it only applies to 1 letter. In the Common Config you can enable/disable 1 letter shortcuts (if there's a 2 or more letter shortcut that starts with the same letter) forgive my poor explination heh it's the 'Auto Launch After First Click" option in the Common Config
    Mm-hmm - I'm aware of the 'Auto Launch After First Click' setting. When I switch it to no, ONLY the 3 letter shortcuts work and the 1 and 2 letter shortcuts don't work...

    It looks like I have to find a way to condense same letter my shortcuts to 2 keys and rely on the scroll and/or tap execution of the 3 letter ones. Very acceptable and do-able - especially with such a great app! Can't have everything...

    Thanks everyone!
    02-02-12 01:23 PM
  25. Vijik's Avatar
    OK - that's what I figured. However, the 3 different key strokes (or even 2) is what I am trying to avoid. Having to type 3 keys all over the keyboard is kind of counterproductive to the whole shortcut concept. I was hoping to be able to use simple, same letter key combos so I don't have to hunt and peck for 3 different keys - I gues I am kind of a streamline nut that way but oh well.
    You can avoid 3 shortcuts keys by just creating your one and two letters shortcuts. They will then launch (if you have set 'Auto Launch After First Click' to Yes).
    You can also make AA launch AA if you avoid creating AAX (X being any letter) shortcut.

    Quick question though - according to what you explained about why AAA won't work, in the A, AA only scenario, shouldn't AA be canceled out by A since A is already taken?

    Thanks a million for your timely and thorough explanation.
    Sean
    No, if you have A and AA shortcuts and you hit AA, then SCM finds a single match (AA) and launches it.

    On the other hand, if you have AA and AAA shortcuts, hitting AA will cause SCM to find AA and AAA
    02-02-12 01:26 PM
1,385 ... 4041424344 ...
LINK TO POST COPIED TO CLIPBOARD