08-25-13 05:45 AM
1,385 ... 1415161718 ...
tools
  1. Vijik's Avatar
    That sounds nice. How will that work with scheduled macros? Will the launch recur? Like after reset, if the while is not met, will it continue trying to launch the macro until the while is met or it will just fail to launch and stop?

    Will these math/comparison operators be available for other macros?
    I plan to make those operators (>,<,!=,==) available for both "While" and "If" macros.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-24-11 07:53 PM
  2. Vijik's Avatar
    I am not sure if there is an API to get CPU load. I will look for that in the APIs.

    In the mean time, I got the While-loop working. I also added support for Not ('!' In front of a ISxxxx macros), and added following maros:

    - Vibrator xxx (BB vibes for xxx mSecs.)

    - SetBrightness xxx (sets lcd brightness to xxx value)

    - BackLightOff

    - BackLightOn

    - IdleSeconds. (Returns # of seconds the device is not used)

    Still testing and fine tuning. I have plans to put it on the beta link within the next 10 hours.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-26-11 10:48 AM
  3. gbsn's Avatar
    Vijik, i was wondering if you could check up on the restore function of SCM and what conflicts its having with "IF" statements, or if it has something to do with them being multilined. I backed up the config, upgraded the OS, restored the OS, then restored SCM config and now im missing quite an amount of shortcuts, and restored more than once and restarted the phone. Most had IF statements, but others were just plain options accessing, like the one i posted to uninstall a specific application. I basically went down from like 214 to 191.

    In fact, i can see the missing shortcuts in the backup file, but they dont show or are not being restored into SCM.


    Its nice to see more and more OS interactions ;D
    Last edited by gbsn; 04-27-11 at 06:27 PM.
    04-27-11 05:33 PM
  4. Vijik's Avatar
    I will check the source code and see if I find anything that can cause that.
    If I can't find anything I will ask you about more info. Info that can help me to know what to look for.

    Let you know.
    04-27-11 06:27 PM
  5. gbsn's Avatar
    I edited my last post :b i can see the missing shortcuts in the backup text file, but they are not being restored into SCM.
    04-27-11 06:28 PM
  6. Vijik's Avatar
    .115 is now ready for download.

    Before you download:
    The syntax for IF-sentence is changed. You need to remove the ';' after IFx in your macros.

    The new syntax for IF is:

    If2 IsInHolster;Then2;....
    (no ';' after IF)


    Example for the new While-Loop feature is:

    While3 IdleSeconds<10;Do3; Vibrate 300; delay5000; EndWhile3;/* your main macros*/

    If this macro is called using Scheduled Launch, then it will not do anything before 10 seconds after you don't touch your BB. As you are using your BB, it will warn you by vibrating your BB.
    (the number after While, Do, EndWhile can be a number between 0 and 9)


    Operators supported for While and If are:
    >, <, !=, ==

    Adding a ! in front of a macro starting with IS will toggle the result that macro.

    Make sure you don't end up in a infinite While loop!
    Last edited by Vijik; 04-27-11 at 07:35 PM.
    04-27-11 06:41 PM
  7. Vijik's Avatar
    I edited my last post :b i can see the missing shortcuts in the backup text file, but they are not being restored into SCM.
    Good news.
    Would you be able to email (support at shortcutme dot com) the ones not showing up?
    04-27-11 06:42 PM
  8. gbsn's Avatar
    Good news.
    Would you be able to email (support at shortcutme dot com) the ones not showing up?
    You want me to email these or post them here?

    edit: Just sent you the email, they are not hidden, they are just not restoring into SCM, as i did a backup with the current ones and the ones that didnt get restored are not showing in the backup file. I made a backup of the old backup file though.
    Last edited by gbsn; 04-27-11 at 07:08 PM.
    04-27-11 06:50 PM
  9. sushistew's Avatar
    can i make a macro to upload photos from bb to a certain page on CB?
    and how would i do it. i have not made any macros yet i have a Torch on OS 6.0.0.534 if you needed to know
    04-27-11 09:15 PM
  10. visortgw's Avatar
    .115 is now ready for download.

    Before you download:
    The syntax for IF-sentence is changed. You need to remove the ';' after IFx in your macros.

    The new syntax for IF is:

    If2 IsInHolster;Then2;....
    (no ';' after IF)


    Example for the new While-Loop feature is:

    While3 IdleSeconds<10;Do3; Vibrate 300; delay5000; EndWhile3;/* your main macros*/

    If this macro is called using Scheduled Launch, then it will not do anything before 10 seconds after you don't touch your BB. As you are using your BB, it will warn you by vibrating your BB.
    (the number after While, Do, EndWhile can be a number between 0 and 9)


    Operators supported for While and If are:
    >, <, !=, ==

    Adding a ! in front of a macro starting with IS will toggle the result that macro.

    Make sure you don't end up in a infinite While loop!
    I believe that I have discovered a bug in this latest build (, but it may have been hidden in previous versions)...

    App. Name: (Blank) or Nothing
    Macro:
    While0 IdleSeconds<10; Do0;
    Vibrate 50; Delay100; Vibrate50;
    Delay5000;
    EndDo0;
    Launch APPLICATION;
    Delay1000;
    Launch Home Screen;


    In this case, I am trying to launch APPLICATION in the background only if there is no recent keyboard activity. The shortcut does not show up in the ShortcutMe shortcut list (apparently due to the empty App. Name) even though the shortcut can be invoked by typing the shortcut key. The primary issue is that I can no longer edit the shortcut.
    04-27-11 09:42 PM
  11. Vijik's Avatar
    Visortgw, SCM is supposed to inform you about missing AppName and not allow you to leave the Shortcut Setting page without selecting an AppName.
    I will fix this soon.
    You can bring that shortcut to life by adding an AppName to that shortcut in the shortcutmeconfig.txt on the root directory of your micro SD card and then hit Restore menu item in SCM.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-28-11 01:34 PM
  12. Vijik's Avatar
    can i make a macro to upload photos from bb to a certain page on CB?
    and how would i do it. i have not made any macros yet i have a Torch on OS 6.0.0.534 if you needed to know
    The first step in writing SchortcutMe macros is to find out how you can do the same task manually on your BB.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-28-11 01:36 PM
  13. visortgw's Avatar
    Visortgw, SCM is supposed to inform you about missing AppName and not allow you to leave the Shortcut Setting page without selecting an AppName.
    I will fix this soon.
    You can bring that shortcut to life by adding an AppName to that shortcut in the shortcutmeconfig.txt on the root directory of your micro SD card and then hit Restore menu item in SCM.

    Posted from my CrackBerry at wapforums.crackberry.com
    @Vijik: Two items:
    1. It validates on creation, but not NOT edit. Please don't "fix" the missing AppName validation too quickly. Given your new conditional macros (i.e., if, else, while, ...), it is often desirable NOT to launch an app until a certain condition is met. For example, if the device is not idle, wait until it is before launching a background app. Could you possibly allow "Nothing" (or the like) as a valid AppName, and just process the macro?
    2. It appears that the IsAppRunning macro is now backwards -- I now need to put the "!" operator in front of IsAppRunning instances that used to work.
    Last edited by visortgw; 04-28-11 at 06:10 PM.
    04-28-11 04:41 PM
  14. Vijik's Avatar
    @visortgw

    If you don't want anything to be launched, AppName should be set to Macro.

    IsAppRunning and IsAppForeground macros don't work at all on .115
    I have to fix that too.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-28-11 06:38 PM
  15. visortgw's Avatar
    @visortgw

    If you don't want anything to be launched, AppName should be set to Macro.

    IsAppRunning and IsAppForeground macros don't work at all on .115
    I have to fix that too.

    Posted from my CrackBerry at wapforums.crackberry.com
    @Vijik: You, sir, are amazing! The Macro AppName is exactly what I was looking for! This application is super flexible, and it just gets better with every release.

    Please let me us know once the IsAppRunning and IsAppForeground macros are fixed.

    Thanks again!
    04-28-11 07:46 PM
  16. Vijik's Avatar
    Thanks.

    .116 is ready for download.

    New in .116:

    - IsAppRunning and IsAppForeground macros should now work (Please confirm)

    - When creating/editing a shortcut, the AppName should be set to anything else than 'Nothing', otherwise a warning message will pop up.

    - Shortcuts with AppName not set, should now show up in the main screen (please confirm)
    (gbsn, can you see all of your 214 shortcuts now?)
    04-28-11 08:29 PM
  17. visortgw's Avatar
    Thanks.

    .116 is ready for download.

    New in .116:

    - IsAppRunning and IsAppForeground macros should now work (Please confirm)

    - When creating/editing a shortcut, the AppName should be set to anything else than 'Nothing', otherwise a warning message will pop up.

    - Shortcuts with AppName not set, should now show up in the main screen (please confirm)
    (gbsn, can you see all of your 214 shortcuts now?)
    IsAppRunning is still not working if the app name contains a blank (e.g., "Skype mobile") -- it appears to always return FALSE.
    Last edited by visortgw; 04-28-11 at 09:52 PM.
    04-28-11 09:41 PM
  18. Vijik's Avatar
    IsAppRunning is still not working if the app name contains a blank (e.g., Skype mobile) -- it appears to always return FALSE.
    Currently spaces are deleted by the macro engine before decoding, and that causes this for apps with space in their name.
    I will fix it.
    Those macros, unlike in .115, work in .116 for apps without space in their name.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-28-11 09:56 PM
  19. gbsn's Avatar
    Currently spaces are deleted by the macro engine before decoding, and that causes this for apps with space in their name.
    I will fix it.
    Those macros, unlike in .115, work in .116 for apps without space in their name.

    Posted from my CrackBerry at wapforums.crackberry.com
    Using string notation? isapprunning "skype mobile" :b

    As for the shortcuts, they are not in the list because they didnt get restored, not because they are hidden or app name is set to nothing. I never set app name to nothing, i may have like 3 o 4 like that from uninstalled applications, but apart from these, they either have macro or the application in app name. Its actually something to do with the way it restores shortcuts with multi lined macros, as all macros i had multi lined are gone , I will just type them again using my old backup, but this time in one line.
    04-29-11 02:54 PM
  20. Vijik's Avatar
    IsAppRunning is still not working if the app name contains a blank (e.g., "Skype mobile") -- it appears to always return FALSE.
    .117 has the fix for the problem reported regarding apps with space in their name.

    So, it should be okay to have a macro like this:

    While2 IsAppRunning Skype Mobile;Do2;.....;EndWhile2;....

    gbsn, no need for "" even that it was a good idea.

    I will (hopefully) fix the restore issue in the next rev.
    04-29-11 03:17 PM
  21. Vijik's Avatar
    Using string notation? isapprunning "skype mobile" :b

    As for the shortcuts, they are not in the list because they didnt get restored, not because they are hidden or app name is set to nothing. I never set app name to nothing, i may have like 3 o 4 like that from uninstalled applications, but apart from these, they either have macro or the application in app name. Its actually something to do with the way it restores shortcuts with multi lined macros, as all macros i had multi lined are gone , I will just type them again using my old backup, but this time in one line.
    I don't think the problem is the line shift in your macros.

    Do you see
    <NewFormat>
    on top of shortcutme's backup file on micro SD card?

    The problem might be that the New Format Reading doesn't kick in when you are restoring your shortcuts.

    If you can wait a day, I try to fix this issue so that you don't need to rewrite your macros.
    04-29-11 06:09 PM
  22. visortgw's Avatar
    .117 has the fix for the problem reported regarding apps with space in their name.

    So, it should be okay to have a macro like this:

    While2 IsAppRunning Skype Mobile;Do2;.....;EndWhile2;....

    gbsn, no need for "" even that it was a good idea.

    I will (hopefully) fix the restore issue in the next rev.
    Confirmed!
    04-29-11 07:22 PM
  23. Vijik's Avatar
    Confirmed!
    Good. Thanks.
    04-29-11 08:46 PM
  24. Vijik's Avatar
    gbsn,

    I take back what I wrote about the line shift.

    The problem IS the line shift. I am working on a fix for that.
    04-29-11 08:48 PM
  25. Vijik's Avatar
    .118 is ready for download.

    Your macro shortcuts with multi lined macros should now get restored using Restore Config menu item.
    04-29-11 10:13 PM
1,385 ... 1415161718 ...
LINK TO POST COPIED TO CLIPBOARD