1. rocco225's Avatar
    So I should have known better but I just upgraded my OS over the air and now the Google Mobile app won't complete installation. While its trying to launch for the first time, I get the message, "Google Mobile App can't connect...."

    I tried the following:

    1. Restart
    2. Toggled wi-fi on/off
    3. Toggled bluetooth on/off
    4. Delete the app, re-downloaded, and re-installed it
    5. Reset firewall
    6. Set all Google app permission settings to Allow

    What's going on? Everything else data related works. I'm posting this with my berry as we speak.

    Bold 9650


    Posted from my CrackBerry at wapforums.crackberry.com
    10-27-10 06:47 PM
  2. knicksfan's Avatar
    I am having the same problem.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-27-10 06:55 PM
  3. RegE's Avatar
    I'm having the same issue. I have Google Mobile App v3.8.22 and when I attempt to open the app, it states, "Completing installation." After a few seconds, I get a window that states, "Google Mobile App can't connect to the internet. Please check your network settings and restart. If needed, you can find help here: http://mobile.google.com/support."

    For the life of me, I can't figure out why GMA fails to connect when everything else connects fine. I can't begin to imagine what network settings can be tweaked to permit connection. And lastly, Google's Support has nothing that references such an issue. In searching this issue on Google, I found similar issues dating back as far as 2007; however, not one solution can be found. There's not even a hint as whether it's an app issue, an OS issue or a compatibility issue.

    Of course, this issue began after upgrading to .983 ...guess this is another instance of 'one step forward and two steps backward'.

    10-27-10 10:04 PM
  4. rocco225's Avatar
    Now today it seems to be working fine. It must have been a network problem on the Google side. I just assumed it was something on my end because it worked before I did the .983 update and it didn't work afterward.
    10-28-10 11:42 AM
  5. RegE's Avatar
    Thanks for the post and the 'heads-up' - you saved me from an anxiety attack. I just tried mine and it works now too. I've been researching for the last couple hours. Must have been a Google network issue like you said because I haven't made any changes to my settings or rebooted my phone since the last time it failed at 3am.
    10-28-10 01:13 PM