1. Sportsmen's Avatar
    I posted something similar to this but did not see if anyone had a fix.

    On 3.2.1 I could click get directions, and use my location and it would find me almost instantly. On 4.0.2 it takes forever, and can never find my position within 10 minutes. I did notice, when I am on wifi at my house then it can find my position instantly.

    I was wondering if anyone else was having this problem, or If I was doing something wrong.
    05-01-10 01:51 PM
  2. sedalia066's Avatar
    Must be something about your settings. We were out all day today on a garden tour without a hitch in location and directions multiple times from different locations. 2-3minutes tops and most were under a minute. The app was a wonder for us today.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-01-10 04:13 PM
  3. pacmanghostx's Avatar
    Could it be that the app is trying to get the location from the cell tower?

    Make sure you're the location is turned on rather than the GPS being set for E911 only...
    05-01-10 04:15 PM
  4. Sportsmen's Avatar
    google maps has allow all, for its settings, and my gps is ON.

    your current location is unavailable waiting for GPS.....
    05-01-10 04:26 PM
  5. NurseBerryAddict's Avatar
    if you are trying to use it in a building you'll get that message or if there is not a clear view of the sky. I know if I don't have the phone by the window in the vehicle it doesn't always work. It needs a clear view of the sky to bounce a signal off the satellite.
    05-02-10 08:35 AM
  6. decypher44's Avatar
    I didn't even know 4.0.2 was out. Had 4.0.1.
    05-02-10 10:36 AM
  7. Sportsmen's Avatar
    if you are trying to use it in a building you'll get that message or if there is not a clear view of the sky. I know if I don't have the phone by the window in the vehicle it doesn't always work. It needs a clear view of the sky to bounce a signal off the satellite.
    I could use 3.2.1 in my house, or in the car, or anywhere and I never had that problem. Actually with 4 I can only get a signal in my house on wifi
    05-03-10 02:56 AM
  8. Sportsmen's Avatar
    Ok someone sent me the 3.2 file which is a .cod, and 3.2.1 which is a .jad. How can I load this back on my BB. I tried to do it from Desktop manager and it gave me an error when i tried to lead the .cod file.
    05-03-10 02:59 AM
  9. ttfmaep's Avatar
    Here is a BlackBerry browser link to 3.2.1:

    Google

    Or you could load your .cod file with BBSAK. If you don't already have BBSAK on your computer it is probably easier to use the OTA link.
    05-03-10 08:41 AM
  10. jabbs1's Avatar
    I didn't even know 4.0.2 was out. Had 4.0.1.
    Lol same here
    05-03-10 11:57 AM
  11. TRD604's Avatar
    I'm still using 3.2.1

    I guess I should not upgade then.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-03-10 12:27 PM
  12. lnichols's Avatar
    I got a new 9630 to replace defective and have the same issue with 4.0.2. 3.2.1 worked great, the new one can't find position ever. Going back to 3.2.1.
    05-03-10 02:57 PM
  13. Sportsmen's Avatar
    Here is a BlackBerry browser link to 3.2.1:

    Google

    Or you could load your .cod file with BBSAK. If you don't already have BBSAK on your computer it is probably easier to use the OTA link.
    This link is for 4.0.2


    I cannot install BBSAK because I only have 64 bit OS's. DO you know another program I couls use to get 3.2.1 back?
    05-03-10 08:46 PM
  14. ttfmaep's Avatar
    This link is for 4.0.2


    I cannot install BBSAK because I only have 64 bit OS's. DO you know another program I couls use to get 3.2.1 back?
    I just now downloaded 3.2.1 with this link.
    05-03-10 09:35 PM
  15. TRD604's Avatar
    That link directed me to 3.2.1

    Posted from my CrackBerry at wapforums.crackberry.com
    05-03-10 10:34 PM
  16. Sportsmen's Avatar
    wow

    I tried again I clicked on the link and it says

    version 4.0.2
    05-03-10 11:02 PM
  17. ttfmaep's Avatar
    it seems the google gods are against you!

    I had installed 4.0.1 last week. I found that link to 3.2.1 and a couple of people in other threads were able to downgrade with it. So when you said it was 4.0.2 for you, I was just curious. I wondered if Google started redirecting the link. But as I said last night, I got 3.2.1 to replace 4.0.1 on my device.

    The only other suggestions I can give you are:
    1. If you still have BlackBerry maps on your phone, open that and see if the GPS can find you. If it can, leave it running in the background and then try Google Maps.
    2. Keep checking for updates to Google Maps.

    Good Luck!
    05-04-10 08:25 AM
LINK TO POST COPIED TO CLIPBOARD