08-12-09 12:11 AM
35 12
tools
  1. AlwaysLostSometimes's Avatar
    Is anyone's Google Maps working? My Sprint Navigation and Blackberry Maps works fine, but my Google Maps which I use for Google Latitude can't seem to either

    1) Be accurate within 5 meters as to where I'm at. Keeps coming up "Location within 500 Meters". (That's nearly 6 Football fields off from where I'm at.)
    and/or
    2) Can't even get the GPS to become available. "GPS Unavailable" But BB Maps and Sprint Navigation work fine when I see this message.

    I just wanted to make sure I'm not the only one. Thanks in advance.
    07-23-09 11:03 AM
  2. Sprockethead's Avatar
    Doesn't work on Sprint. Google's fault.
    07-23-09 11:06 AM
  3. habakkuk's Avatar
    Google Maps does not work properly on VZW either. Same issue as the OP.
    07-23-09 11:20 AM
  4. bucwylde23's Avatar
    Google Maps does not work properly on VZW either. Same issue as the OP.
    To clarify it doesn't work properly for YOU. Works fine for many others. My google maps on VZW locks on very quick, within 5 seconds or less every time I open it.
    07-23-09 11:25 AM
  5. dkcbears's Avatar
    Google Maps does not work properly on VZW either. Same issue as the OP.
    Google Maps works fine for me. I'm on Big Red with Tour.
    07-23-09 11:26 AM
  6. Aver's Avatar
    Google Maps does not work properly on VZW either. Same issue as the OP.
    Locks on almost instantly for me, dunno what's wrong with your phone lol.
    07-23-09 11:28 AM
  7. Mikeosu02's Avatar
    Here is how I resolved this issue:

    First, make sure GPS is set to "Device GPS" and "Location On." (Options > Advanced Options > GPS).

    Second, go to your application list (Options > Advanced Options > Applications), scroll down to Google Maps (you should be running 3.0.2), highlight Google Maps, and press the Blackberry Button. Under "Edit Permissions" all three options (Connections, Interactions, and User Data) should be set to "Allow". Under "Edit Default Permissions" all three options should be set to "Allow".

    Before changing these options, GMaps was giving me a location withing 500 - 1900 meters (cell tower triangulation). After changing these options, it's down to less than 10 meters. Hope this works for you.
    07-23-09 11:34 AM
  8. Sprockethead's Avatar
    Here is how I resolved this issue:

    First, make sure GPS is set to "Device GPS" and "Location On." (Options > Advanced Options > GPS).

    Second, go to your application list (Options > Advanced Options > Applications), scroll down to Google Maps (you should be running 3.0.2), highlight Google Maps, and press the Blackberry Button. Under "Edit Permissions" all three options (Connections, Interactions, and User Data) should be set to "Allow". Under "Edit Default Permissions" all three options should be set to "Allow".

    Before changing these options, GMaps was giving me a location withing 500 - 1900 meters (cell tower triangulation). After changing these options, it's down to less than 10 meters. Hope this works for you.
    Just a note to the OP that this will not work for Sprint. This is how VZW customers should have the app setup on their phones. For sprint customers, we have to wait for a patch.
    07-23-09 11:36 AM
  9. AlwaysLostSometimes's Avatar
    Just a note to the OP that this will not work for Sprint. This is how VZW customers should have the app setup on their phones. For sprint customers, we have to wait for a patch.
    I just tried it on 3 other phones. (Mothers, sisters, cousin) who all have Tours and it's not working for them either. They are getting the exact same messages I am. I think you have the best and correct answer. Not to say others are wrong (That proves that it only works on the Verizon for now since most of the Verizon users seem to not be having this problem). As for Sprint users what are the chances of getting that many phones with the GPS acting the same way. At that point I can't say it's the phone, just the app that needs a patch as you've stated.

    Thanks for the responses everyone.
    07-23-09 11:47 AM
  10. habakkuk's Avatar
    Here is how I resolved this issue:

    First, make sure GPS is set to "Device GPS" and "Location On." (Options > Advanced Options > GPS).

    Second, go to your application list (Options > Advanced Options > Applications), scroll down to Google Maps (you should be running 3.0.2), highlight Google Maps, and press the Blackberry Button. Under "Edit Permissions" all three options (Connections, Interactions, and User Data) should be set to "Allow". Under "Edit Default Permissions" all three options should be set to "Allow".

    Before changing these options, GMaps was giving me a location withing 500 - 1900 meters (cell tower triangulation). After changing these options, it's down to less than 10 meters. Hope this works for you.
    Thanks Mike, turns out my permissions were set to Custom. Just changed it, will let you know if it works. At least it says "waiting for GPS" now.
    07-23-09 11:47 AM
  11. Mikeosu02's Avatar
    BVR -- Thanks. I assumed someone had at least tried to change permissions on Sprint. I know when I downloaded the app for Verizon, it automatically set permissions to custom, and GPS did not work.
    07-23-09 11:49 AM
  12. AlwaysLostSometimes's Avatar
    Here is how I resolved this issue:

    First, make sure GPS is set to "Device GPS" and "Location On." (Options > Advanced Options > GPS).

    Second, go to your application list (Options > Advanced Options > Applications), scroll down to Google Maps (you should be running 3.0.2), highlight Google Maps, and press the Blackberry Button. Under "Edit Permissions" all three options (Connections, Interactions, and User Data) should be set to "Allow". Under "Edit Default Permissions" all three options should be set to "Allow".

    Before changing these options, GMaps was giving me a location withing 500 - 1900 meters (cell tower triangulation). After changing these options, it's down to less than 10 meters. Hope this works for you.
    Went about trying this, but all 3 were already at allow. Everything you stated was already set on phone as default. No luck for Sprint Users just yet. But thanks for the help. I do appreciate it. Also, one thing I did notice is that my version of Google Maps has a Magnify Glass for zooming in and out Icon, yet my sisters doesn't and we are both running the same version. But it really doesn't matter that much either since we both can't get it to work.
    07-23-09 11:50 AM
  13. Jeff5886's Avatar
    GM works flawlesly on here, but to be honest, i perfer BBmaps as it tells MPH
    07-23-09 11:58 AM
  14. habakkuk's Avatar
    Getting the "GPS temporarily unavailable" message. I'll try it again when I get home, might be the concrete jungle that's blocking the signal. That's strange, because my Sprint and AT&T friends have no issues w/ their GPS locking on in downtown; granted they don't have BB's.
    07-23-09 12:24 PM
  15. AnonBlackberry's Avatar
    I can't get the GPS to work on Verizon with the Tour either. I've changed all the settings that people have suggested. I even reinstalled gmaps. Any other thoughts?
    07-23-09 12:34 PM
  16. ruby_red's Avatar
    I was having this same problem with the Vz Tour, but I switched my GPS settings to "Location on" and it was fixed.
    07-23-09 12:37 PM
  17. petes99's Avatar
    interesting.. hope this solves what i came here for! Gmaps not finding the GPS often, and other GPS apps nuke when they try to access it! Thx for the post..
    07-23-09 12:48 PM
  18. tediprude's Avatar
    My Google Maps works just fine on my Bold. I love it. It allowed me to stop using my TomTom gps thingy. IU also use "Where".

    Perhaps some of those similar apps you have are stepping on each other. I don't know - just guessing though.

    Peace...
    07-23-09 12:50 PM
  19. nyc_rock's Avatar
    Google Maps does not work properly on VZW either. Same issue as the OP.
    Google maps is working fine on VZW. It worked fine on my storm and now on my tour.
    07-23-09 01:22 PM
  20. Tdubby's Avatar
    LOL google maps doesn't even work on my 8330 with everything on and allow
    07-23-09 01:29 PM
  21. whatzap's Avatar
    Im a newbee to all this stuff.Where do you download these map apps from?
    Thx
    07-23-09 01:43 PM
  22. tediprude's Avatar
    Im a newbee to all this stuff.Where do you download these map apps from?
    Thx
    You can try Google for the mobile app. And if you install the Crackberry Launcher on your phone - you can go to the "Free App" list and just have a ball. Or you can see here under the "Downloads & Tools" tab at the top of this page.

    Peace
    07-23-09 01:47 PM
  23. AlwaysLostSometimes's Avatar
    It seems like the app hasn't been updated for the Tour. For those who've got it working on there Tours, lucky are you all. It works perfectly fine on my 8350i, but no such luck on any Tour I've tested it on. I even went over to the Sprint store earlier today and just got back from it about 15 minutes ago. They had a tester phone on display and no such luck. It showed 600 meters off. I guess google needs to update this app for the Tour; for all of us.
    07-23-09 01:53 PM
  24. bucwylde23's Avatar
    LOL google maps doesn't even work on my 8330 with everything on and allow
    The 8330 does not support GPS in google maps or any other 3rd party apps. Only in VZ navigator and BB maps.

    It's already been stated previously that there needs to be a updated Gmaps version released by google for this to work on Sprint. No settings changes are going to fix this for anyone.
    07-23-09 01:55 PM
  25. chrisg23's Avatar
    nice name man
    07-23-09 02:20 PM
35 12
LINK TO POST COPIED TO CLIPBOARD