1. mattaholt's Avatar
    I have a Blackberry Curve with BlackBerry System Software version 4.3 for the 8300 series. The company I work for uses Google Apps hosted Gmail for corporate e-mail so instead of using BlackBerry Messenger, I am using Mail By Google version 1.5.1 that was downloaded at m.google.com/a/ (the Blue Icon version)

    For the first two days the Mail by Google software worked perfectly. Then I started getting the following message at random:

    Username and password do not match. You provided ()

    After several attempts sometimes it will let me login and other times it returns the same message. For instance I am in Mail By Google and begin to compose a message. When I press send it kicks me back to that screen. Some days it works fine.

    Another person at work who also got a Blackberry is having the same problems. We are located in different areas and it doesnt seem to make a difference where the device is physically for the error to occur.

    Reading other post online a few people recommended contacting RIM via our service provider (CellularSouth in this case). I tried that yesterday and after talking with a rep at Research in Motion he said it was a Google issue and that there was no table for them to add the address to as the post had suggested.

    So now I am stuck. At random I get kicked out of the Mail by Google with the error message mentioned above. Eventually I can log back in but I am not sure what I can to do resolve the problem. Is it a BlackBerry or Google issue?

    Any thoughts would be appreciated.

    Matt
    07-18-08 09:10 AM
  2. mattaholt's Avatar
    A little more on this problem. It appears to consistently happen when trying to send mail. When I compose or reply to a message it comes up "Sending..." and after about 1 minute it kicks me out to the login screen with the message "Username and password do not match. You provided () [OK]". I login again and it says "We have saved the message you were composing before the application unexpectedly quit. [OK]" It then takes me back to the message.

    It almost acts like the ports or protocol used for accessing Google's outgoing mail is blocked. Is there a port sniffer for the Blackberry?

    Matt
    07-21-08 09:57 AM
  3. mattaholt's Avatar
    I have been unable to find a solution to this problem. Several users of the normal gmail software reported a similar issue that was corrected by turning off HTTPS. However the hosted Gmail (blue client icon) does not seem to have that as an option.

    Has any one else found a solution?

    Matt
    Last edited by mattaholt; 11-08-08 at 10:17 AM.
    09-09-08 04:21 PM
LINK TO POST COPIED TO CLIPBOARD