1. andy957's Avatar
    I installed the Gmail app on my new (Telus) Tour. While I can read and send email fine, for some reason it's not pulling emails to the phone from my Gmail accounts like it does on my Curve 8900 (and did on my Pearl 8130), until I manually go into each account and click "Refresh".

    On the other phones, I'd also see a little yellow "lightning bolt" sort of icon on the Google Mail icon in the Downloads folder indicating that there was new mail.

    I went to the Settings option in Gmail, and the first option is indeed checked, to alert me when new messages arrive. It also says to make sure that the Blackberry notification feature is set up properly. If I go to Notifications, I see the two email accounts that are on telus.blackberry.com for me, but the Google mail accounts aren't there, maybe this could be the reason?

    Anyway on the 8900 and 8130, I didn't have to do anything special to make this work and unfortunately I use this app a LOT so I'm hoping someone knows what I need to do to fix it.

    Thanks.
    07-16-09 07:14 PM
  2. PooThrowingMonkey's Avatar
    Do you have it set up as a POP or IMAP account? If POP, switch it over to IMAP.
    07-16-09 07:23 PM
  3. andy957's Avatar
    Do you have it set up as a POP or IMAP account? If POP, switch it over to IMAP.
    In my browser (on my PC) they're set up as IMAP, but I'm not using a browser on my 9630 to access the email, I'm using the downloaded Gmail mobile client (m.google.com/app). It works perfectly on my 8900, never had a problem, the LED comes on instantaneously when a new email arrives. It's not only not lighting up on the Tour, but it's not appearing in my Gmail mobile client until I manually hit "Refresh" off of the menu.
    07-16-09 07:31 PM
  4. blueyestm's Avatar
    you don't need the gmail app, just set up a new email on your bb like any other and it will push to it
    07-16-09 07:33 PM
  5. andy957's Avatar
    Well, here perhaps is the problem.

    When I installed Gmail mobile on my Tour, it installed Gmail for mobile (beta), version 2.0.7.1264, and it says Platform: BlackBerry-47. On the 8900, it's running Gmail 2.0.6.1269 (because the 8900 is running OS 4.6, not 4.7).

    Maybe this is a beta bug?
    07-16-09 07:34 PM
  6. andy957's Avatar
    you don't need the gmail app, just set up a new email on your bb like any other and it will push to it
    Nobody needs it, but I like it, it mimics the Gmail interface and works like a charm. This appears to be a bug with the 4.7 beta version that was installed when I downloaded it.

    I'm heading over to Google to post a question about this.

    Thanks everyone.
    07-16-09 07:35 PM
  7. Dawgpound77's Avatar
    works fine for me
    07-16-09 10:48 PM
  8. larrymcj's Avatar
    @andy957:

    There is a known problem with the current Gmail app 2.0.7 (including the betas) when used with a Tour (actually the problem is OS 4.7.40). I first found this out when I got my Tour and posted the following in the "BlackBerry Tour 9630 Tour" forum here. I also posted it on the Google Mobile Help Forum - BlackBerry Section. Here's the deal....whenever I find out anything I'll post to you back on this thread and would appreciate it if you did the same. BTW, I also can't stand Gmail IMAP...it's horrible compared to the app itself on a BB.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~
    I installed the Gmail Mobile App on the new BlackBerry Tour and it worked just fine at first...until the first time I had to reboot the phone.* After that Gmail was still there, and worked fine, but the "Gmail - New Mail" option was missing under "Sound Profile - Ring Tone/Alerts - Other". *After this, the sound notification alert for new mail on Gmail could not be changed from what it was initially set to.

    Uninstalling/reinstalling Gmail didn't fix this...I had to completely wipe the BlackBerry (under Security Options) and then start over again and add the Gmail Mobile App.* Anyone else having this problem? *I suspect it's a problem the Tour's OS (4.7.40) is having with the Gmail Mobile App, but then again it might be something the Gmail App is causing.
    ~~~~~~~~~~~~~~~~~~~~~~~~~~

    Here's a workaround that I've found by trial and error and it works well.

    - Completely wipe your handheld (under Security Options - BBMenu)
    - When back to "out of the box" condition install Gmail 2.0.7 as usual
    - Setup your Gmail account on the BB
    - IMPORTANT STEP: Go to Sound Profile - Ring Tones/Alerts and you then see "Gmail - New Mail" as it should appear.
    - Configure your new Gmail notifications as you'd like and save them
    - Reboot your phone...the "Gmail - New Mail" entry will no longer be there
    - Install Gmail App again (it will ask if you want to overwrite current version...say yes)
    - Reconfigure your Gmail as usual

    You'll now have everything you want regarding the Gmail App except you will not be able to change the "Gmail - New Mail" notification settings because that entry is gone forever from the Sound Profile unless you completely wipe the phone again. FWIW, I've done these steps about three times now and they do work. The Gmail icon changes with new mail, the LED lights with new mail, I get the sound notification I first selected with new mail...it all works, but it just can't be changed.
    07-17-09 07:40 AM
  9. andy957's Avatar
    @andy957:

    There is a known problem with the current Gmail app 2.0.7 (including the betas) when used with a Tour (actually the problem is OS 4.7.40). I first found this out when I got my Tour and posted the following in the "BlackBerry Tour 9630 Tour" forum here. I also posted it on the Google Mobile Help Forum - BlackBerry Section. Here's the deal....whenever I find out anything I'll post to you back on this thread and would appreciate it if you did the same. BTW, I also can't stand Gmail IMAP...it's horrible compared to the app itself on a BB.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~
    I installed the Gmail Mobile App on the new BlackBerry Tour and it worked just fine at first...until the first time I had to reboot the phone.* After that Gmail was still there, and worked fine, but the "Gmail - New Mail" option was missing under "Sound Profile - Ring Tone/Alerts - Other". *After this, the sound notification alert for new mail on Gmail could not be changed from what it was initially set to.

    Uninstalling/reinstalling Gmail didn't fix this...I had to completely wipe the BlackBerry (under Security Options) and then start over again and add the Gmail Mobile App.* Anyone else having this problem? *I suspect it's a problem the Tour's OS (4.7.40) is having with the Gmail Mobile App, but then again it might be something the Gmail App is causing.
    ~~~~~~~~~~~~~~~~~~~~~~~~~~

    Here's a workaround that I've found by trial and error and it works well.

    - Completely wipe your handheld (under Security Options - BBMenu)
    - When back to "out of the box" condition install Gmail 2.0.7 as usual
    - Setup your Gmail account on the BB
    - IMPORTANT STEP: Go to Sound Profile - Ring Tones/Alerts and you then see "Gmail - New Mail" as it should appear.
    - Configure your new Gmail notifications as you'd like and save them
    - Reboot your phone...the "Gmail - New Mail" entry will no longer be there
    - Install Gmail App again (it will ask if you want to overwrite current version...say yes)
    - Reconfigure your Gmail as usual

    You'll now have everything you want regarding the Gmail App except you will not be able to change the "Gmail - New Mail" notification settings because that entry is gone forever from the Sound Profile unless you completely wipe the phone again. FWIW, I've done these steps about three times now and they do work. The Gmail icon changes with new mail, the LED lights with new mail, I get the sound notification I first selected with new mail...it all works, but it just can't be changed.
    Hi Larry, and all I can say is THANKS! for a great response - not only thorough and detailed, but well-written (it's such a pleasure to see good spelling and grammar on one of these forums! LOL) and technically understandable.

    So, to address your points:

    I promise to post here when/if I hear anything or discover anything that could potentially address this issue. I've also posted over on the Google boards but all I get are answers from people telling me to use the standard BB email app, they don't seem to understand I don't want to do that! So no fruitful replies there...yet. I don't know if Google employees monitor those threads, but I hope they do. There clearly seems to be an issue with the 2.0.7 beta and the Tour (I'd be curious to know if it's an issue on the Storm as well).

    Your experience was a bit different from mine. I never had the Gmail - new mail option listed under Sound Profiles>Ring Tone/Alerts>Other, which is, I believe, the crux of the issue here. It just doesn't show up. However, I did not do the wipe and/or reinstall process you suggest.

    I hate doing the wipe handheld routine. It's such a tedious thing, especially after taking such careful pains to set up the phone the way I want it to work. So I'm not willing to go that route just for this app at the moment, but I will try installing it again right over the current installation and see if the Gmail - new mail appears in Sound Profiles, and will report back here.

    Strange, because with 2.0.06, as I mentioned previously, I used it on my 8900 Javelin and my 8130 Pearl with absolutely no problems, it's one of my favourite and most reliable apps on those phones, to be quite honest.

    Anyway, we'll keep each other (and anyone else who's interested) posted via this thread.

    Curious, which carrier do you use? I'm on Telus (Canada).

    Thanks so much again, Larry, you are awesome.

    Andy
    Last edited by andy957; 07-17-09 at 08:09 AM.
    07-17-09 07:56 AM
  10. larrymcj's Avatar
    @andy957:

    I assure you if you do a complete wipe and then install Gmail FIRST you'll see the Sound Profile entry. Also, I've seen many similar comments about this regarding the Storm (there are some over on the Google Mobile Help Forum) so that also points to OS 4.7.

    I hate doing the wipe as well, but after so many times I have it down to about a 30-minute evolution, and that's with a lot of apps to install, delete, hide, etc. For me it was just worth it as I can't live without the Gmail App :-)

    I use Verizon Wireless here. BTW, thanks for your kind words :-)
    07-17-09 08:03 AM
  11. andy957's Avatar
    @andy957:

    I assure you if you do a complete wipe and then install Gmail FIRST you'll see the Sound Profile entry. Also, I've seen many similar comments about this regarding the Storm (there are some over on the Google Mobile Help Forum) so that also points to OS 4.7.

    I hate doing the wipe as well, but after so many times I have it down to about a 30-minute evolution, and that's with a lot of apps to install, delete, hide, etc. For me it was just worth it as I can't live without the Gmail App :-)

    I use Verizon Wireless here. BTW, thanks for your kind words :-)
    Understood, Larry. I just don't want to have to do it, you'll have to drag me away kicking and screaming first. :-)

    Thanks. I just posted a comment in your thread on the Google board (I had started one of my own there yesterday too).

    Best
    Andy
    Last edited by andy957; 07-17-09 at 08:12 AM.
    07-17-09 08:08 AM
  12. larrymcj's Avatar
    Yes...please send the url and I'll post to it, too. The more the better...eventually those things actually do get responded to by Google employees...but it's usually later, rather than sooner.
    07-17-09 08:17 AM
  13. andy957's Avatar
    Yes...please send the url and I'll post to it, too. The more the better...eventually those things actually do get responded to by Google employees...but it's usually later, rather than sooner.
    Larry, refresh your browser, I added the link to my post just above.
    07-17-09 08:19 AM
LINK TO POST COPIED TO CLIPBOARD