1. mittejung's Avatar
    Hi everyone, i'm a new member of our forum, and also a absolutely new user of BB Bold 9000. Now i have a problem with the Facebook application of my mobile. When i try to log-in, it always show me this message:

    "Could not connect because a data service is not available. Please try again later. If this continues, contact your service provider for support".

    I'm using OS ver 5.0.0.592 and facebook appl ver 1.6.0.22. When i use normal Browser to access my fbook acoount, there is no problem. So i dont know what's wrong with this appl? what should i do? anyone can help me please. Thanks so much..........
    08-23-10 04:50 PM
  2. dhaliwal06's Avatar
    Check if your data services are on.
    Options->Mobile Network->Data Services

    Make sure beside Data Services it says On.

    Goodluck.
    08-23-10 05:37 PM
  3. mittejung's Avatar
    hi, i turned it on already, and surfing with the Browser without problem. so i think it could be other reasons...
    08-23-10 05:42 PM
  4. historianheidi's Avatar
    Try that first.

    When my internet based apps stop working like that,but my phone says the data service is on, I do a battery pull (take the battery out and then put it back in again) . This effectively resets the phone and I find that I can connect again.

    I haven't used that particular Facebook App though, so I don't know if that would help. I tend to check Facebook (and Twitter) on my phone via Snaptu, which I've found to be very reliable.
    08-23-10 05:48 PM
  5. bblover82's Avatar
    This is a very common issue with that version of the facebook application. I'd try to install the newer version of the application. Currently, you are running facebook application version 1.6.0.22. The newer version was released a little over a week ago. The newest version is 1.8.0.49. It can be found by going to facebook.com on your blackberry browser, or can be found in blackberry app world.
    08-24-10 02:08 AM
  6. mittejung's Avatar
    hi, actually i tried ver 1.8 first, but it didn't work too. It showed me an error message (Service 100), that's why i google a lot and find that many people have the same problem like me. They downgrade to older version like 1.5 and 1.6, and some of them are lucky, for me in the rest of that. so someone pro could tell me exactly the solution for this? i like fbook very much..(
    08-24-10 02:55 AM
LINK TO POST COPIED TO CLIPBOARD