1. Slvrbck's Avatar
    Hi all,
    For the first time in about 6 months, I had a fairly majour error happen with my Berry.

    Here is what happened:
    I have quickpull (free) run a soft reset on my Berry every night at just after midnight.
    As I say, every night for 6 months, this has worked perfectly.
    This morning however, when I woke up, my Berry was hanging on the Vodafone screen that pops up during a restart.
    Thinking nothing off it, I did a battery pull and this time the phone restarted as usual.
    When it got to the home screen, a bunch of errors popped up stating "Unexpected Java Exeption" (this may not be the exact wording as it was 6am).
    I clicked pased those and got to the home screen.

    Now, this is where it really gets interesting.
    I have been running a custom theme for about a week (my own creation) that has the calendar in "Today" format and 5 "Zen" icons running allong the bottom.
    The "Zen" icons are fixed icons for certain apps.

    After clicking past the errors, 2 of the 5 icons where blank and clicking on them did nothing.
    In what seemed to be an unrelated error, I had a Facebook notification showing, but couldn't find the facebook app in it's usual place (or any place for that matter).

    When I changed themes, facebook was still missing.

    All is fixed now but it took a mater reset of my Berry followed by a backup restore.

    Anyone have any ideas what the **** happened?
    07-16-09 03:57 AM
  2. fatboy97's Avatar
    Unread emails??? Check a link in my signature about the 3rd party theme issue, which it sounds like you may know about, but since you did not say you know about it... take a look. Don't think I'm ripping on you for using a 3rd party theme, even one you created yourself... I have my own personal theme I use all the time as well.

    And also, my 2 cents on this quickpull app... I've seen too many people have issues with this app... you have to be at least the 5th or 6th person in the last month that I've read about using this and then having some strange issue... they might be unrelated... but I can do a simple Alt+Right Shift+Del once every couple days and do the same thing... it's still not as good as a FULL BATTERY PULL!!! You still need to do one of these every couple weeks or so.
    07-16-09 06:05 AM
  3. Slvrbck's Avatar
    Cheers for the reply fatboy,
    I guessed (as with most things in life) that my 3rd party theme may have more glitches that an "official" theme but I hadn't read anything about it.
    Checking out your link now.

    For not really knowing the benifits of a full battery pull, I hadn't done one in ages (would do one every day with the Storm).

    Thanks very much for the feedback.
    07-16-09 07:07 AM
  4. Slvrbck's Avatar
    In addition:

    I think I have just encountered the EXACT problem that you describe in your thread.

    I had upgraded the active theme recently.
    I did have unread items (facebook)
    It is a 3rd party theme (made by me)
    And the problem was after a restart.

    Thanks very much for your help.
    It's just such a pain in the bum that I had to create a custom theme to get a "today" view of my calendar!
    07-16-09 07:12 AM
  5. fatboy97's Avatar
    I like my Today theme as well... so everything is ok now???
    07-16-09 07:26 AM
  6. Slvrbck's Avatar
    Yes, because I hadn't seen your thread before this morning, I solved the issues by doing a "Wipe Handset" and then restored from a backup.

    That fixed the problem.
    I am 99.9% sure that I had the same error that you describe in your thread only I didn't have an unread e-mail, it was an unread Facebook alert.

    When I get back from work I am going to re-install my custom theme, send myself a facebook alert and reboot my Berry, see if I can force the fault to happen again just to confirm.

    I saw that some people think the issue is fixed in the Beta 5 OS so I may have a read up and see if it's worth upgrading.
    07-16-09 07:35 AM
  7. fatboy97's Avatar
    Yes, because I hadn't seen your thread before this morning, I solved the issues by doing a "Wipe Handset" and then restored from a backup.

    That fixed the problem.
    I am 99.9% sure that I had the same error that you describe in your thread only I didn't have an unread e-mail, it was an unread Facebook alert.

    When I get back from work I am going to re-install my custom theme, send myself a facebook alert and reboot my Berry, see if I can force the fault to happen again just to confirm.

    I saw that some people think the issue is fixed in the Beta 5 OS so I may have a read up and see if it's worth upgrading.
    Yes, some have said it is fixed in OS 5.0... I'll be waiting for a stable and official OS 5.0 before I upgrade.
    07-16-09 08:55 AM
  8. c_86's Avatar
    yea this has happened to me a couple times... its like it deletes certain icons (my email ones) yet they are still visible on the screen but dont do anything... its like there are no service books, but yet they are there...

    the only way for me to fix it was a JL_Cmder wipe along with a complete reload of the OS and such...
    07-16-09 09:05 AM
  9. Slvrbck's Avatar
    I haven't had to go as far as a full OS re-install yet.

    For now I am going to stick with the OS I have but uninstall Quickpull.

    It isn't a Quickpull issue, but it looks like I need to be able to control when my device reboots (and more specifficly, that I don't have any unread items).

    O well, bring on a stable 5.0 leak (I would wish for a Vodaphone UK release but fat chance of that any time soon).
    07-16-09 09:24 AM
LINK TO POST COPIED TO CLIPBOARD