1. israel941's Avatar
    I use a Blackberry 8320 and have been trying to sync my google calender up with my handset and it is just becoming a pain. I have 2 entries for just about everything right now. I thought it was because I had manually entered them on my curve and also online so I deleted everything on my blackberry and started the sync again, but they are back! Only one shows on google's end. I'm sure some settings just need to be changed but I don't know what or where... help?
    04-18-09 04:10 AM
  2. tylerr's Avatar
    I have tried google sync a few times now, and I end up deleting it. Has a lot of problems imo. When it comes to appointments, I cant risk them getting deleted, not syncing, or any other problems that I had with google sync.
    04-18-09 12:32 PM
  3. John Yester's Avatar
    1) Delete all CICAL service books. These are the calendar service books for each email address. BIS adds them by default but you don't need them, unless your on BES but that is another story.....

    2) Open google Sync application. Choose options then hit menu. Choose reset Calendar sync. It will ask if you want to remove all entries off device.

    3) Once reset choose to re sync with you calendars.

    This is the way mine is setup. But when I connect my device to my pc I only snyc contact info. As I have google sync setup on my PC that connect to google. So anything I add to my outlook calendar gets added to my google calendar and then added to my device.


    Works well I use 4 calendars that are all linked, at first I had problems but not anymore since setting mine up this way.
    04-18-09 01:29 PM
  4. israel941's Avatar
    okay, so I did exactly what you said. I deleted all the cical service books and i reset the calendar sync in google sync. i noticed this did not delete anything in my calendar, so I did it again. still no luck. so i tried changing some things on my google calendar online and those also did not update after a sync. i dont know what in the world i'm doing wrong...
    04-28-09 03:04 AM
  5. israel941's Avatar
    So no new advice, so I wanted to try one more thing.

    Is there a way to completely wipe EVERY calender entry on my handheld? I'll just re-sync w/ google after that, if possible...

    Posted from my CrackBerry at wapforums.crackberry.com
    05-26-09 02:12 AM
  6. cashmoney805's Avatar
    So no new advice, so I wanted to try one more thing.

    Is there a way to completely wipe EVERY calender entry on my handheld? I'll just re-sync w/ google after that, if possible...

    Posted from my CrackBerry at wapforums.crackberry.com
    Yes there is a way, but I can't remember exactly how to do it. You def need to do it through DM though. Just do a quick search, I saw a thread on here the other day dealing with it.
    05-26-09 02:18 AM
  7. John Yester's Avatar
    1. Google sync will sync to what ever your devices default calendar is. And if you change it in default services then it will sync there as well causing duplicates. So if you check your database sizes when this happens. Options > Status> menu - data base sizes. You will see multiple calendars with entries. Assuming those are duplicates.


    2. To erase all the calendar entries from the device. Go to calendar then options. On that screen type rset. Follow the prompts.

    3. Go in to default services and choose what calendar you want to use.

    4. Go into google sync, choose reset in options. Then re sync.



    See if that works for ya.
    05-26-09 07:47 AM
  8. dallasdchi's Avatar
    1. Google sync will sync to what ever your devices default calendar is. And if you change it in default services then it will sync there as well causing duplicates. So if you check your database sizes when this happens. Options > Status> menu - data base sizes. You will see multiple calendars with entries. Assuming those are duplicates.


    2. To erase all the calendar entries from the device. Go to calendar then options. On that screen type rset. Follow the prompts.

    3. Go in to default services and choose what calendar you want to use.

    4. Go into google sync, choose reset in options. Then re sync.



    See if that works for ya.
    Worked like a charm. Thanks!
    05-27-09 08:58 AM
  9. GynormousMellon's Avatar
    Had the same duplication problems as stated by the OP. I followed exactly what yester18 said in both posts....PROBLEM SOLVED!!!!!!

    Thanks for the advise. I know this is an older posting but it still worked.
    04-09-10 10:56 AM
  10. teamfourllc's Avatar
    Just worked for me too. Thanks!
    05-16-10 09:07 AM
  11. Bitter End's Avatar
    I had the same problem this morning and these posts fixed it!
    05-16-10 01:36 PM
LINK TO POST COPIED TO CLIPBOARD