1. guitarskater11's Avatar
    Apps that i have recently downloaded aren't opening. Does anyone know how to fix this? I click it and it just sits there, nothing happens. But Facebook and things like that open. I have tried downloading and opening Viigo, Color ID, and WeatherEye. And not too long ago my weather channel app stopped working, which is the reason i first downloaded WeatherEye.
    04-20-10 05:47 PM
  2. Motorcycle Mama's Avatar
    What steps have you taken to troubleshoot this?

    Have you done a battery pull?
    What OS version is on the device?
    Have you tried deleting and reinstalling the apps?
    What network carrier are you on?
    04-20-10 07:39 PM
  3. guitarskater11's Avatar
    Yes i have done a battery pull, its the newest version, i have tried deleting and reinstalling, and verizon
    04-21-10 02:14 PM
  4. MrObvious's Avatar
    Eww. Which OS is it exactly?
    04-21-10 02:18 PM
  5. guitarskater11's Avatar
    5.0 I think
    04-21-10 03:31 PM
  6. guitarskater11's Avatar
    I fixed it. I just did another battery pull and it was fine. Thanks.
    04-21-10 04:14 PM