1. 3osha's Avatar
    Hi everyone!
    I recently upgraded my gmaps to v3.2 n the latitude is hanging a lot!
    Any idea on how I can downgrade to the previous versions?
    Thanks a mill!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-09 07:59 PM
  2. fatboy97's Avatar
    If you can find the old version, just delete v3.2 and install the old one... IF!!!

    If not, delete v3.2, perform a battery pull (leave your device on, pull the battery for 20 seconds, put it back in and wait for device to boot up), then install it again.
    10-28-09 08:20 PM
  3. 3osha's Avatar
    If you can find the old version, just delete v3.2 and install the old one... IF!!!

    If not, delete v3.2, perform a battery pull (leave your device on, pull the battery for 20 seconds, put it back in and wait for device to boot up), then install it again.
    Where can I find the old version? Looked everywhere!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-09 08:49 PM
  4. fatboy97's Avatar
    That is why I said "IF!!!"... Unless you made a backup copy by using Backup 3rd Party Apps procedure in my signature below, or can find a copy on Google's website, I'm guessing your should do the "If not" part of my comment... personally, I don't have any issues since I downloaded right after they released it a few days ago.
    10-28-09 08:54 PM
  5. 3osha's Avatar
    That is why I said "IF!!!"... Unless you made a backup copy by using Backup 3rd Party Apps procedure in my signature below, or can find a copy on Google's website, I'm guessing your should do the "If not" part of my comment... personally, I don't have any issues since I downloaded right after they released it a few days ago.
    I didn't make a backup. And I tried uninstalling n downloading again. Still won't work like the last version! Re booted many times too! Thanks anyways

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-09 08:57 PM
  6. BuddyL's Avatar
    I'm also not having a problem with mine. I would also suggest doing a delete and reload. If not, I would suggest going to a site like Berry Review and do a search for Google Maps and find an old version listed and see if the link will work.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-09 08:59 PM
  7. 3osha's Avatar
    I'm also not having a problem with mine. I would also suggest doing a delete and reload. If not, I would suggest going to a site like Berry Review and do a search for Google Maps and find an old version listed and see if the link will work.

    Posted from my CrackBerry at wapforums.crackberry.com
    I did delete n reload twice! N berry review sends me to the gmaps homepage where I can download the current version!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-09 09:04 PM
  8. fatboy97's Avatar
    I would suggest Wiping your device... but it is a lot of work... at least a half hour, not counting the time to get all your apps up and running again... you might consider this after you've been using your device a while.

    I prefer CrackMem... just need to download and install your current OS on your PC, select it in CrackMem, click the Wipe button and it will wipe your device and reload your OS... of course this is all after you've done a backup using DM and 3rd part apps using the thread in my signature... then after it wipes your device you need to reload all your data and apps, then activate all your apps... you might want to delete GoogleMaps before this of course.

    GoogleMaps does work on the 8900... in any of the OS 4.6 version that I know of... I hope you are not using OS 5.0.
    10-28-09 09:11 PM
  9. BuddyL's Avatar
    Good point. Are you using 5.0?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-09 09:42 PM
  10. 3osha's Avatar
    No I'm using 4.6
    I check google forums, they don't have the previous version either! :S

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-09 09:46 PM
  11. BuddyL's Avatar
    I tried to go through Berry Review as well and it just had the new links. I did it that way when I wanted to get go back from the voice app that google maps had. Other than waiting a week until 5.0 is released I don't know what to tell you. Sorry.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-28-09 10:01 PM
  12. dag99's Avatar
    Latitude is not working as well in 3.2 as earlier versions. Doesn't seem to update frequently.

    Is there any way to force an update?
    10-29-09 12:22 PM
  13. vsinc's Avatar
    Seems like a lot of people (including me) have problem with Latitude not updating in the new 3.2 version. Mine did not update for 2 days. I have found that pressing "0" (centering on your current location) updates Latitude position as well.

    Yesterday I needed to "downgrade" a phone to Google Maps version 3.0.2 so I decided to update my post for the benefit of others. Here's the official but hard to find url to the version that has Latitude working good for me and supports the external GPS device:

    http://m.google.com/maps/download/ma...anic&ver=3.0.2
    Last edited by vsinc; 03-09-10 at 10:16 AM. Reason: added link to download Google Maps version 3.0.2
    10-29-09 01:30 PM
LINK TO POST COPIED TO CLIPBOARD