1. April Archambeau's Avatar
    The curve last week was my new BB, first one ever, used for 2 days then got the tour. So I FINALLY got it activated last night after alot of BS. Went to turn it on, fine.

    Went to make a test call, and ummm yea, I could hear through the ear piece but it was at the home screen. And after it was frozen for a minute gave me some long error with phone app at the end of it. Something was wrong with the phone app?

    So I did 3 battery pulls and has been working fine since although I havent messed with it at all, no calls or anything after those initial 5 or 6 calls

    Anyone had this problem? Is this common? Someone told me to load the new OS from Verizon for this phone.
    07-16-09 01:27 PM
  2. rantingryan's Avatar
    Could of just been a freak thing....nothing is perfect. If you dont experience it again, I wouldnt be too worried.

    No application errors for me in my few days of using the Tour now
    07-16-09 01:29 PM
  3. April Archambeau's Avatar
    Oh ok, just wanted to see if it was a common thing, from being on here and talking to some tech guys at Sprint, its common for battery pulls, a good bit of them, as long as they fix the problem, I am not too worried.
    07-16-09 01:32 PM
  4. rantingryan's Avatar
    Oh ok, just wanted to see if it was a common thing, from being on here and talking to some tech guys at Sprint, its common for battery pulls, a good bit of them, as long as they fix the problem, I am not too worried.
    Yeah battery pulls are the defacto first thing to do if the device is acting up. There is a app called QuickPull that simulates pulling the battery out without you actually having to do it...sort of a "reset" button.

    I'm not sure if it's compatible with the Tour's OS yet however
    07-16-09 01:35 PM
LINK TO POST COPIED TO CLIPBOARD