03-27-10 09:59 AM
58 123
tools
  1. mefeldstein's Avatar
    Tried this for the bold and it didn't work.
    04-28-09 02:39 PM
  2. knotkwiteright's Avatar
    I'm having an issue with the app... When I first signed up for it back in Dec they did not support my phone (8310), so I selected the 8800 bc it was the closest phone they did support. I got the link, dl the app, and was running it without issues. However, I returned to the site this week to see if they now had an 83xx-specific version, and saw that they did so I switched to that one... Now, about 75% of the time I try to access it, it just stays on the initial loading screen and pretty much freezes up my phone. Batt pulls fix it about 50% of the time but other times it just refuses to work for a day or so.

    Anyone else having this issue? I've already tried re-installing to no avail.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-07-09 01:05 PM
  3. knotkwiteright's Avatar
    I just figured out a way to get this working on the Curve 8900. It was actually so simple I wanted to kick myself. This was done on Tmobile but should work without issue for AT&T users.

    First thing I did was sign up at the myciti site using my info and selecting the 8320. I received the txt and clicked the link. I then received the error so many here have also gotten.

    Blackberry Curve 8300 is currently unsupported phone or whatever it is.

    I realized that the 8300 was listed as a supported phone on the AT&T options and that my Curve 8900 was being recognized as a 8300. That was actually a good thing. First I tried to setup my phone number and set AT&T as my network, but needless to say, fail! So I changed back to tmobile and tried a different route.

    Next I looked at the link i received in the text and saw that carrier was last part. In my case the link ended in carrier=tmobile. I copied the link, pasted it into the browser and changed carrier= to att. App downloaded without an issue. I now have the citibank mobile app installed and running. Good Times. I don't see why this wouldn't work on a bold also, as long as it is recognized as a 8300.

    Tried this with an AT&T 8900 and it actually doesn't read it as an 8300, instead it comes up as a "Generic BlackBerry device", so needless to say it wouldn't let me d/l the app. Has anyone actually gotten this running on an AT&T 8900 yet?

    Posted from my CrackBerry at wapforums.crackberry.com
    06-10-09 12:09 PM
  4. nyfynest's Avatar
    i cant seem to get it to work either on my tmobile 8900 ...... any help ?? im so upset i left bank of america for citi and i cant even get a damn mobile app or mobile web site for citibank mean while boa had....
    06-11-09 12:45 PM
  5. BBJACKiE's Avatar
    Does this work on the storm?

    Posted from my CrackBerry at wapforums.crackberry.com
    06-13-09 04:24 AM
  6. ZJP's Avatar
    I got this app working on my Bold.

    Just selected the 8300 and set up an access code and it works flawlessly. Great app.
    06-30-09 10:16 AM
  7. Saleen4971's Avatar
    Chase an excellent wap site with a lot of functionality.

    yeah thats nice. i woudl still prefer an application for it.
    06-30-09 11:38 AM
  8. w_bovine's Avatar
    I got this app working on my Bold.

    Just selected the 8300 and set up an access code and it works flawlessly. Great app.
    Wow...it worked for me too. It certainly didn't before...I tried a few times in the past with my Bold, selecting the 8300 on the setup page. Something changed...maybe the app was updated or it deems my current OS acceptable.
    06-30-09 08:44 PM
  9. yeahman's Avatar
    Works for me too, finally. Not as feature-rich as I thought it would be but better than nothing.
    06-30-09 09:02 PM
  10. JRomulus's Avatar
    Wow...it worked for me too. It certainly didn't before...I tried a few times in the past with my Bold, selecting the 8300 on the setup page. Something changed...maybe the app was updated or it deems my current OS acceptable.
    Yes, same deal. It works. Not as completely as it did on my last non-RIM phone, but at least it works on Bold now. Wonder what they did that allows it to work.
    07-01-09 09:20 PM
  11. yeahman's Avatar
    Yes, same deal. It works. Not as completely as it did on my last non-RIM phone, but at least it works on Bold now. Wonder what they did that allows it to work.
    Obama's a berryhead. He made sure some of that bailout money was being used for BB app development. Wait till you see the GM app. It's big, unreliable, and drains power like no tomorrow.
    07-02-09 12:57 AM
  12. neicy17's Avatar
    So I finally am able to get on to the site with an activation code. The site is a bit "barbaric" and "archaic", but I thought...at least I can finally use it.

    Well, decided to try www.myciti.com, from my browser window..Guess WHAT...IT works. Very similar to the site, and 20X better than the citimobile app I've been trying to get access to for months.
    So I deleted the dysfunctional citimobile app from my bold, and will be using the browser to go to myciti.com. I guess I never thought about doing that. Hope this helps you.
    07-03-09 09:02 AM
  13. yeahman's Avatar
    So I finally am able to get on to the site with an activation code. The site is a bit "barbaric" and "archaic", but I thought...at least I can finally use it.

    Well, decided to try www.myciti.com, from my browser window..Guess WHAT...IT works. Very similar to the site, and 20X better than the citimobile app I've been trying to get access to for months.
    So I deleted the dysfunctional citimobile app from my bold, and will be using the browser to go to myciti.com. I guess I never thought about doing that. Hope this helps you.
    You're like the Christopher Columbus of Citibank mobile online banking.
    07-03-09 11:47 AM
  14. w_bovine's Avatar
    So I finally am able to get on to the site with an activation code. The site is a bit "barbaric" and "archaic", but I thought...at least I can finally use it.

    Well, decided to try www.myciti.com, from my browser window..Guess WHAT...IT works. Very similar to the site, and 20X better than the citimobile app I've been trying to get access to for months.
    So I deleted the dysfunctional citimobile app from my bold, and will be using the browser to go to myciti.com. I guess I never thought about doing that. Hope this helps you.
    Egad...nice find. You'd think perhaps they'd actually make people aware of this?! Yeah...works nicely. You are quite the intrepid explorer, neicy!
    07-03-09 02:08 PM
  15. bitchxko's Avatar
    I was so excited to try it and it doesn't work it just says unknown manufacturer generic device is currently an unsupported phone. please visit our website for a current list of supported phones> why does this happen i really need this app because when i go to citi.com it doesn't log in it wont let me press the login button after I'm done putting my user name and password what am i doing wrong?
    08-07-09 01:27 PM
  16. bitchxko's Avatar
    which os are you using because my 4.6 doesn't work...
    08-07-09 01:34 PM
  17. neicy17's Avatar
    I was so excited to try it and it doesn't work it just says unknown manufacturer generic device is currently an unsupported phone. please visit our website for a current list of supported phones> why does this happen i really need this app because when i go to citi.com it doesn't log in it wont let me press the login button after I'm done putting my user name and password what am i doing wrong?
    Trying to sign up on their site. What works is www.myciti.com. Pretty simple..no need to sign up on their site, just put that url in your phone's browser, and guess what, it takes me to citibank mobile. Who knew? I don't think Citibank does handing out those ******** instructions that they have on their site.
    08-08-09 02:51 AM
  18. neicy17's Avatar
    which os are you using because my 4.6 doesn't work...
    What works is www.myciti.com. Try it and see if you can get it from there.
    08-08-09 02:52 AM
  19. calllka's Avatar
    I have Verizon Tour, and can't get to mobile version of the site, I try citi.com and myciti.com with and without "www". Also tried to download the app, says "Generic Blackberry" is no go. Anybody have luck getting to mobile site or app working from Tour? Thank you.
    10-13-09 01:11 PM
  20. RogueRider's Avatar
    I have Verizon Tour, and can't get to mobile version of the site, I try citi.com and myciti.com with and without "www". Also tried to download the app, says "Generic Blackberry" is no go. Anybody have luck getting to mobile site or app working from Tour? Thank you.
    Its working on my tour. I logged into citicards to access my cc account on my laptop. Under the Account Profile menu I found Manage Mobile Services.
    Follow the directions to download the Firethorn application.
    11-04-09 11:14 PM
  21. RogueRider's Avatar
    Too many unecessary gifs at myciti.com. It takes too long to load.
    11-04-09 11:20 PM
  22. calllka's Avatar
    I have a checking account and use myciti.com to login from laptop. Nothing about firethorn there. Guess its only for cc.
    11-04-09 11:37 PM
  23. GaryMF's Avatar
    Any update on using Citibank on the Tour? either the app or Myciti.com?
    03-05-10 10:00 PM
  24. calllka's Avatar
    still doesn't work, how pathetic. honestly, how much dev time is needed to allow access to citi.com using tour, given they already grant access to a number of other blackberries.
    03-05-10 10:14 PM
  25. w_bovine's Avatar
    They don't have a version for the Bold 9700 either, but I was able to load the .cod using BBSAK from my Bold 9000 (don't remember how exactly I got it to work however) and it works fine. And yes, it's patently absurd that they don't have the app readily available for more BB models.
    03-05-10 10:21 PM
58 123
LINK TO POST COPIED TO CLIPBOARD