1. OMFGitzJOE's Avatar
    Hey, I literally just got finished getting my BB 8520 to OS 5.0 and i've just been downloading all my stuff again and found that I am unable to do so because - and I quote - "Sorry, your device does not meet the system requirements that are needed to support the Blackberry World App".

    It will be worth pointing out that I didn't download the OS directly from the Provider (Vodafone UK), I downloaded it from a US Provider and deleted the Vendor.xml file so I am presuming it may have something to do with this, if so how can I get around it and if that is not possible is there another alternative apart from the pretty poor "Application Centre" on the Home Page? Thanks.
    Last edited by OMFGitzJOE; 06-01-10 at 09:12 AM.
    06-01-10 08:19 AM
  2. diegonei's Avatar
    Feels like the service books are gone.

    Email Wizard > Login > Menu > Service Books > Resernd Service Books

    or

    google "vodafone uk blackberry" and click "BlackBerry Internet Service" > Login > Help > Resend service books.

    I assume you have BlackBerry Internet Service (BIS), which allow BlackBerry specific apps to connect and provided you with Push Email.
    06-01-10 08:42 AM
  3. OMFGitzJOE's Avatar
    Feels like the service books are gone.

    Email Wizard > Login > Menu > Service Books > Resernd Service Books

    or

    google "vodafone uk blackberry" and click "BlackBerry Internet Service" > Login > Help > Resend service books.

    I assume you have BlackBerry Internet Service (BIS), which allow BlackBerry specific apps to connect and provided you with Push Email.
    Worked perfectly, thank you very much for your help.
    06-01-10 09:15 AM
LINK TO POST COPIED TO CLIPBOARD