1. farawaygirl's Avatar
    My dad uses a Curve 8520 and today I tried to help him download the App World 'cos I only just realised that he didn't have one.

    When I finished downloading the App World from browser using WIFI, a pop up appeared, saying, "Invalid signature in response from BlackBerry App World. BlackBerry App World must now exit."

    My brother who uses 8520 told me he faces the same issue.

    On the other hand, my sister and I, using Curve 8900 and Bold 9700, do not face this problem. We have our App World preinstalled in our phones. Is it due to the service provider? 'cos my sis and I share the same service provider while my dad and bro use a different service provider.

    &I have no idea why the phone required my dad's 8520 to switch on WIFI to download the App World when clearly he has a data plan.

    How do I help my dad access his App World?
    Last edited by farawaygirl; 05-28-10 at 12:50 AM.
    05-28-10 12:47 AM
  2. sickboy719's Avatar
    05-28-10 12:53 AM
  3. farawaygirl's Avatar
    Tried. They mentioned something about APN being uncompatible.
    05-28-10 01:00 AM
  4. sickboy719's Avatar
    Right after posting that, I got that error for the first time ever. Turning off my wfi seemed to fix it right away.

    Try shutting wifi off and then a battery pull maybe.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-28-10 01:20 AM
  5. jackbox's Avatar
    The first time you access App World WiFi must be turned off. If WiFi is on and BIS is using WiFi you will get the invalid signature message. Turn off WiFi and run App World again. Then after that you can turn WiFi back on. RIM should warn people about this condition.
    05-28-10 03:34 AM
  6. farawaygirl's Avatar
    Tried all of the above. Doesn't work... Maybe it's 'cos my dad's using Version 5.00 software or something? O.o
    05-28-10 04:40 AM
  7. kwkid's Avatar
    Tried all of the above. Doesn't work... Maybe it's 'cos my dad's using Version 5.00 software or something? O.o
    Completely uninstall App World, disconnect from WifI, using the Data Services, not WiFi, download App World, run App World while still disconnected from WiFi.
    05-29-10 12:31 PM
LINK TO POST COPIED TO CLIPBOARD