1. Matyko's Avatar
    For some reason I can't install the BlackBerry App World software on my BB 8800 (OS v4.5.0.69/Platform 2.7.0.72) - always get the error message saying "Sorry, your device does not meet the system requirements that are needed to support BlackBerry App World.". Even when trying to install it via the Desktop Manager or directly going on-line with the BB browser.

    Similarly, when visiting with my BB browser the site mobile.blackberry.com the page does not recognize my device as a BB.

    Can anyone help in solving this mystery?
    09-01-09 06:02 AM
  2. KrayziePhil's Avatar
    The same thing happens to me. Why can't I download it?
    09-03-09 11:48 AM
  3. Matyko's Avatar
    After posting my question I have spotted somewhere that the App World it is not available in my country. BlackBerry App World is available in the United States, Canada, the United Kingdom, Ireland, Italy, France, Spain, Germany, Austria, Portugal, Netherlands, Belgium, Luxembourg, Argentina, Brazil, Chile, Mexico and Venezuela.
    09-08-09 04:06 AM
LINK TO POST COPIED TO CLIPBOARD