1. geo_me's Avatar
    So, I have a BB 8900 which I unlocked from Vodafone, then I restored service books so I can use it without a data plan and updated the software to version 5.0 bundle 1682. Now, I have a browser icon, but it won't open browser - I've tried everything: battery pull, re-restoring service books, it hasn't worked. Also, my App World icon does not appear, even though Desktop Manager says it's installed - I un-installed and re-installed it multiple times. It seems as if Blackberry Enterprise isn't working properly... So, what can I do? Thanks
    02-29-12 10:51 AM
  2. omoinme's Avatar
    Just purchase a data plan once d service is up,remove d battery and replace it. just wait for 10 mins all wil come up
    03-10-12 11:44 PM
  3. huggins12345's Avatar
    how about you re-install the software for the phone ?
    03-11-12 04:34 PM
  4. geo_me's Avatar
    I did reinstall the software, I even used multiple versions. Same result. It says I have no Browser Configuration Service Book Entries, even though I have loaded Service Books and Opera Mini is fully functional.
    03-12-12 03:59 PM