1. ibcop's Avatar
    Currently using a 9930 on Verizon and 7.0.0.374. I am having issues using BeWeather with the current location. I can add locations via city/state or zip code without any issues.

    If I try to add using "Current Location" I get the pop up of "A GPS/Cell location has been added (they misspelled "addded"). This location will detect your current locations on every update." The I get the "Locating Failed" when trying to load/update the location. I've tried it inside, outside, 15 miles away, etc. It just won't load.

    If I make the switch under options/general settings to GPS only, I get the same "A GPS/cell location" banner, then it will update. The screen will show "Now" in the bottom right corner, but no data is present (the screen is black).

    If I make the switch to "GPS w/Cell Location fallback", i get the same issue as the first way.

    I have deleted the program and re-installed three times. Battery pull after each install. Again, normal zip codes work just not the current location.

    I sent an email to BellShare many days ago but no further response from them other than the automated "we got your email".

    Any ideas? Thanks in advance.
    Last edited by ibcop; 12-06-11 at 07:13 PM.
    12-06-11 06:06 PM
  2. ibcop's Avatar
    Anyone having issues? I still can't get it to update.
    01-10-12 06:14 PM
  3. Azensun's Avatar
    Risking an 'arrest' by responding to ibcop (c'mon, it's funny!!), here is a question for you and my thoughts on what might be happening.
    I use the paid version of berryweather and have had no issues when it comes to giving me the weather based on my location. Have you tried clicking the "nearest weather stations" option within the app just to see what it returns? My GUESS is that the GPS can't get a fix on the locations you're at or you're moving too fast for the fix to gain hold. The worst I've had is a slight (2-3 second delay) while it finds me, but no issues other than that.
    Maybe someone smarter will weigh in on this, but at least it's something. If I get a chance in the next few days, I'll play around with my version for you and see if I can duplicate your problems.
    01-10-12 08:14 PM
  4. cherimoya's Avatar
    i hve same issue as op.
    01-10-12 10:48 PM
  5. ibcop's Avatar
    Risking an 'arrest' by responding to ibcop (c'mon, it's funny!!), here is a question for you and my thoughts on what might be happening.
    I use the paid version of berryweather and have had no issues when it comes to giving me the weather based on my location. Have you tried clicking the "nearest weather stations" option within the app just to see what it returns? My GUESS is that the GPS can't get a fix on the locations you're at or you're moving too fast for the fix to gain hold. The worst I've had is a slight (2-3 second delay) while it finds me, but no issues other than that.
    Maybe someone smarter will weigh in on this, but at least it's something. If I get a chance in the next few days, I'll play around with my version for you and see if I can duplicate your problems.
    I can load locations by entering zip or city - and they will update and function correctly. The problems I have is I get the "failed" if I try to set the current location. I have tried all settings that I could find. It does the same thing on the 9650 and 9930.
    01-11-12 09:32 AM
  6. crackberry-9900's Avatar
    I initially having this issue, but recently it's working perfectly.. Not sure why
    01-11-12 04:30 PM
  7. Klotar's Avatar
    Sometimes, I have to switch between Auto/BIS/DirectTCP to get it to find you and to refresh on it's own. I don't have it installed at the moment to confirm, but although you think Auto should cover all the bases, I think switching it to Direct TCP (or maybe TCP-IP, w/e) solved it for me.
    01-11-12 04:33 PM
  8. Azensun's Avatar
    I was able to duplicate your problem, i b, and based on my findings, I don't think BeWeather is 100% at fault. I purposely got to a location where I had to drop back to Edge (no 4G/HSPA and no wi-fi). I tried to get BW to add the location-and received the confirmation pop-up (complete with the extra 'd' in 'added'. I also got the failure after that. I then went to my GPS app and sure enough, the GPS was NOT able to find me. I then went to another location where I have a strong 4G signal and a very strong wi-fi and repeated the process. No issues. BW added the location and gave me the weather at that spot. So, I really think it's the GPS on the phones not being able to find the location.
    01-11-12 04:41 PM
  9. dagerlach's Avatar
    Anybody figure out the problem with BeWeather? I get No Data for all my locations. I am in WiFi, 4G, with good GPS coverage.
    03-10-12 05:37 PM
LINK TO POST COPIED TO CLIPBOARD