1. etlahrs's Avatar
    I have had BeWeather for about a year now with no problems. I went to look at the weather for today and got an error message.

    "Failed checking license class java.lang.Exception License revoked by server"

    I checked in the About section and the License says "valid".

    Has anyone seen this issue before? Or know what I need to do to fix it? The only thing different on my phone between yesterday when I used it and today is the new Blackberry Bridge.

    Thanks.
    02-22-12 07:17 AM
  2. etlahrs's Avatar
    Update:

    I just opened the app again and got a message saying that my license had been tranferred to another device, which I didn't do. So i tried to re-enter my license key, which it accepted and is now working properly.

    Not sure if anyone from Bellshare is on these forums, but if so I hope you have some insight as to what may have happened.
    02-22-12 08:31 AM
  3. Innerchild's Avatar
    Yes, I just had the exact same thing happen today. I reentered my license and it works now for only my Home location.

    BUT, when I scroll to my other stored locations, I still get that error message on each one. Hopefully just a server glitch on their end.

    UPDATE: About 10 minutes after I posted this, all locations came back. Seems to be OK now. Glad they got on it right away!
    02-22-12 03:44 PM
  4. etlahrs's Avatar
    It happened again this morning. It states that my license has been transferred to another device and I need to Register or Buy. I will put my registration back in, but this is not good if it is going to happen on a daily basis.
    02-23-12 08:47 AM
  5. anon(2254645)'s Avatar
    It's been happening to me the last 2-3 days whenever I reboot the phone on my 9650.
    02-23-12 09:16 AM
  6. etlahrs's Avatar
    I sent am email to Bellshare on their website in the contact us section yesterday, hoping to hear something soon. Will post any reply that I receive.
    02-23-12 09:18 AM
  7. dgldgl's Avatar
    same here. been happening for a few days. reentered license key, looked fine, but now getting same issue. Bellshare, what's up???
    02-23-12 10:39 AM
  8. anon(2254645)'s Avatar
    I think it's an Appworld issue, since for me it's only happening on my 9650, which has BeWeather purchased from Appworld. On my 9930, I'm using Berryweather, which I purchased from Mobihand. If it were Bellshare's issue, wouldn't they both be acting up (the 9930 app is fine)?
    02-23-12 11:19 AM
  9. etlahrs's Avatar
    I think it's an Appworld issue, since for me it's only happening on my 9650, which has BeWeather purchased from Appworld. On my 9930, I'm using Berryweather, which I purchased from Mobihand. If it were Bellshare's issue, wouldn't they both be acting up (the 9930 app is fine)?
    Unless I am mistaken, once the app is downloaded, Appworld doesn't do anything for the app. You could remove Appworld from your phone and the app will still work. It could be that Bellshare uses a different license server for BeWeather (Appworld) vs BerryWeather (Mobihand). Again, this is just speculation based on your experience of having the problem on one device compared to another with the only difference being the place of purchase.

    Anyone else notice this? My BeWeather was purchased through Appworld as well.
    02-23-12 11:28 AM
  10. ecksdog's Avatar
    I sent am email to Bellshare on their website in the contact us section yesterday, hoping to hear something soon. Will post any reply that I receive.
    Don't hold breath waiting or you will die. I've been there.
    02-24-12 02:26 PM
  11. Shilohjerry's Avatar
    I got the same error messages today. I pulled the battery and it seems okay now. I'd guess the problem is not in our BB's but in the info we receive from BerryWeather.
    Last edited by Shilohjerry; 02-24-12 at 02:47 PM.
    02-24-12 02:45 PM
  12. keyhole's Avatar
    I've had the uncaught exception error on the BeWeather App (compliments of RIM) appear occasionally when I have to do a battery pull. I then go into the app and the wheels just spin stating "updating" and never update. I pulled the battery again and all went fine. Then again on a battery pull about a week later it did the same exact thing. This time I uninstalled and the re-installed the app and everything went well for another couple weeks. Now, it is happening again and I have to pull the battery to finally get the app to work properly. No answers from Bellshare. Oh well, guess I have to live with it but I certainly won't recommend the app now even though I liked it...
    05-07-12 10:40 AM
LINK TO POST COPIED TO CLIPBOARD