1. zzzrd's Avatar
    Device: Blackberry 8520
    Carrier: Vodafone
    Country / Language: UK English
    OS: v4.6.1.272
    kernel v3.8.5.50a

    Hi,
    (I'm a newbee so please excuse me if this has been answered somewhere b4)

    I have a BB 8520 on Vodafone.
    First off I would like to say how amazing i think modile google is. The interface and functionality is fantastic.
    Only have one problem, and that is when running google maps v3.2.1
    I recently downloaded mobile google apps along with maps. Everything works fine but when trying to run google maps, the progress bar starts to turn grey, indicating the load up, but gets one third of the way through it and reverts back to the mobile google home screen.
    I have tried unistalling maps and re-installing but no joy?

    My location updates at the bottom of the screen accurately and quickly, so I cant understand why the app wont load up properly?
    Is there a setting which I have not configured? I know the BB 8520 does not have GPS but I was of the belief the app would still load up?

    Any help you can offer would be grately appreciated
    12-09-09 05:30 PM
  2. zzzrd's Avatar
    56 views and not one response.
    Thanks !
    12-12-09 08:51 AM
  3. jackbox's Avatar
    On my 8520 Google Maps worked perfectly in both OS 4.6 and the OS 5.0 leak I am running. I would suggest uninstalling the Google App and then resetting your BB. Then just go to "m.google.com/maps" using the native BB browser and install Google Maps standalone. If you don't have an external GPS connected via Bluetooth it uses Cell Tower data to get pretty darn close to your actual location.
    12-12-09 09:40 AM
  4. jackbox's Avatar
    Here is a screenshot I just took showing it running on an 8520. I always install the Standalone Google Apps I want and don't mess around with their all in one junk.
    12-12-09 09:43 AM
  5. zzzrd's Avatar
    Found the solution -- and it was quite a journey to find it.
    Fix is:
    Need to reset your firewall prompts. Anytime those prompts come
    up
    when you load a new application always check yes, otherwise the app
    won't work.


    Directions:
    * Options >> Advanced Options >> Applications >> highlight Google
    Maps, hit menu, select Edit Permissions >> hit menu again, select
    "Reset Firewall Prompts"


    * Do a hard reboot (pull the battery after shutting down)


    Now run Google Maps again and select "yes" to allow access...

    I'm quite disappointed that nobody on this site was able to help, after all this is meant to be a specialised help community. Nevertheless thanks to the two replies I did get.

    Thanks to John Clark of Blackberry Forums for the answer.
    aps works great now.
    12-12-09 07:06 PM
  6. pieris87's Avatar
    i tried it and is not working... please tell me what i do wrong?
    01-16-10 03:20 PM
  7. jofabs's Avatar
    guys just want to ask how i can download google maps on my bb8520.

    tried to access this but failed "m.google.com/maps"
    01-17-10 05:11 AM
LINK TO POST COPIED TO CLIPBOARD