1. SunnyDay2's Avatar
    I have been trying to use fb on my BB curve, I have downloaded it from BB site. It installed fine, re-booted the phone, clicked on download folder, FB was there, clicked again, went to sign in and got the message saying 'could not connect because a data service is not available'
    I posted this same problem on another forum where I was told to delete fb and reinstall it. This I did, but hey **, same problem

    My wifi is working fine, but this is really bugging me.
    I'd be grateful for a little insight please
    Thanks
    06-27-10 01:35 PM
  2. diegonei's Avatar
    Isn't Facebook one of those apps you need BIS for and won't work over Wi-Fi?
    06-27-10 01:40 PM
  3. rcnathan's Avatar
    I believe so, because its a BIS pushed service, I think.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-27-10 01:49 PM
  4. SunnyDay2's Avatar
    Erm.... well, if I go to the browser on my bb and put in facebook website, I am able to log on, but if I try to log on via the fb application I downloaded from my BB, I get the
    'could not connect because a data service is not available'
    message.
    As I mentioned I am on wifi (in home wifi)
    06-27-10 02:02 PM
  5. Kellina's Avatar
    Through the browser is just the regular facebook mobile site. I believe what is being said is that the app, which is made by RIM, requires BIS (blackberry data plan).

    Posted from my CrackBerry at wapforums.crackberry.com
    06-27-10 02:22 PM
  6. SunnyDay2's Avatar
    Through the browser is just the regular facebook mobile site. I believe what is being said is that the app, which is made by RIM, requires BIS (blackberry data plan).

    Posted from my CrackBerry at wapforums.crackberry.com
    Ah ok thank you and how does one go about getting the data plan?
    ETA: Its ok I have found the information
    Last edited by SunnyDay2; 06-27-10 at 02:43 PM.
    06-27-10 02:39 PM
  7. TonyLibations's Avatar
    I don't know about the BIS or BB data plan. What I do know is that FB has been doing some updating and it's been causing the app to act kinda screwy. I also understand that RIM has the 1.8 version in beta testing and will hopefully be available soon. Maybe then all will be better. The app is kind of a pain anyway. If you can access the mobile site for now then you can do more then 1.7 will let you do anway.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-28-10 02:15 AM
  8. Lost Heaven's Avatar
    i have the same porblem
    and intrested to know more about it
    06-28-10 03:53 AM
  9. AgentWax's Avatar
    I had this problem when I first got my 8520. I had purchased the BB Data Plan and my internet worked fine as well as a few apps. But I noticed that my weather apps wouldn't work (saying something about insufficient data package) and I was also unable to setup my personal email account (it was only giving me the option of Enterprise). And most importantly, my FB app said it needed a data plan (even though I had one already). So I called up T Mobile and it turned out that there were 2 services required for my true data connection. 1 is on the T Mobile side and another on the RIM side. Turned out that only the T Mobile side was activated. So they just went ahead and activated the RIM side as well. After reboot, I was able to set up my personal email, run all my apps and finally utilize the FB app. So it may be as simple as calling up your provider and seeing if u are having the same problem. Hope this helped.
    06-30-10 02:33 AM
  10. kinggoodway's Avatar
    Check your internet options click on facebook icon and go to internet connections tab

    Posted from my CrackBerry at wapforums.crackberry.com
    06-30-10 07:14 AM
LINK TO POST COPIED TO CLIPBOARD