1. nickylew's Avatar
    Hello. I got my bb yesterday after having WM phones for >5 years. I would appreciate any help with my minor issue here, to make me feel as though I've made the right decision!

    When I am NOT in a wifi area, I get the following error message when I try to open the BB app world:

    Upgrade your service to a plan that includes browsing and discover a world of possibilities at Blackberry App World. Contact your service provider for more details.

    The browser and all other apps work absolutely perfectly when not in a wifi area, its just the app world. When I am connected via wifi, it opens and works fine. I am on T-mobile (in UK), and have both WnW and also the BB internet on my account.

    Any idea why this may be happening? I have reinstalled, removed battery, spoken to (and been to!) t-mobile, and can't seem to get this sorted. Ive also read a few bits to do with others having similar problems, but there seems to be no fix anywhere.

    Thanks.
    Last edited by nickylew; 05-13-09 at 10:32 AM.
    05-13-09 10:22 AM
  2. bassichonda96's Avatar
    Set all permissions to Allow and see what happens?
    05-13-09 10:26 AM
  3. nickylew's Avatar
    I somehow stumbled on that menu myself earlier today, and set them to allow - still no change.
    Last edited by nickylew; 05-13-09 at 10:30 AM.
    05-13-09 10:27 AM
  4. husnimd's Avatar
    Hmm..atleast you guys have a chance to log into App World. In india it is still not available yet.... T_T
    05-13-09 08:04 PM
  5. USP45's Avatar
    Not sure what happened but the same thing happened to my wife after a couple months.

    Eventually it was fixed with a call to the provider (in our case TMobile). The person on the line eventually fixed with:

    "... deactivated and reactivated the BlackBerry system under the phone number"
    08-12-09 10:16 PM
LINK TO POST COPIED TO CLIPBOARD