1. Swamp55's Avatar
    I recently downloaded version 1.1 of the Dictionary and Thesaurus app from Dictionary.com for my Storm2 from the BlackBerry App World site.

    The app installed with no problems and initially worked as expected. However, now a few days later, whenever I attempt to hear the audio pronunciation of a word, the app crashes with this error message:

    "A fatal error occurred. Please re-start the application. (class java.lang.RuntimeException) pushModalScreen called by a non-event thread."

    I tried re-booting the phone with no resolution of the problem. I also deleted and reinstalled the app -- again with no resolution of the problem.

    Has anybody else run into this problem? Any ideas how to resolve this issue? (I have an e-mail into the Dictionary.com tech support, but I thought I might actually get an answer here faster.)

    P.S. I am running the .607 OS from Verizon.
    04-24-10 05:48 PM
  2. RCCCDM's Avatar
    Yes im having the same problem running same os .607
    04-24-10 08:32 PM
  3. migdier's Avatar
    I tried getting that app, but can't download it for Storm2. How'd you get it?
    04-24-10 11:42 PM
  4. 65heloguy's Avatar
    I noticed the same problem today as well. Reinstalled the program and still crashes. Hopefully this will be resolved soon.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-24-10 11:47 PM
  5. sh.hazeri's Avatar
    Hi, I got the same issue on my 9700 Bold with Dictionary app ! any update or solution for this ?
    04-25-10 12:10 AM
  6. dynamododge's Avatar
    Me too mine is OS 320 if anyone has a fix let us know. Please.
    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    04-25-10 05:40 PM
  7. Swamp55's Avatar
    Still experiencing the same problem. No improvement. And, no response yet to my e-mail sent to Dictionary.com tech support. Of course, I have NEVER received a response to an e-mail I've sent to their tech support. So, that's par for the course...
    04-26-10 11:43 PM
  8. cmcichon's Avatar
    I just noticed this issue starting on Friday. I have .607 installed, and at first I thought it had been due to a conflict with another installed app (if that's even possible, I'm a newbie, so i wouldn't know for sure) but seeing as that there are others with the issue, maybe its not that.

    But why would it happen weeks after I have installed it???
    04-27-10 10:44 AM
  9. Swamp55's Avatar
    I just tested the app again, and...

    ...hooray, the pronunciation feature is working again!

    I'd like to know what was done to fix the problem. But, regardless, I'm happy to have the feature working again.
    04-30-10 01:09 AM
LINK TO POST COPIED TO CLIPBOARD