1. carson73's Avatar
    Just upgraded to a new Bold 9700. My apps that I had on my curve 8520 worked great on the EDGE network. Now that I'm using the Bold with 3G, they don't reconize the 3G network.

    2 apps especially are 660 news & Flixster. They'll only work when I'm on a WiFi connection.

    I'm on Fido in Canada, I've checked with my carrier to ensure my data plan is on a Blackberry plan to re-assure myself. I do have 3G connection as it clearly shows a 3G in the top right corner.

    Its just 'some' apps that are like this.

    Any help, answers or solutions to this???

    Thanks!
    09-10-10 10:26 PM
  2. WolfmanRobby's Avatar
    I'm not familiar with those 2 apps specifically. But, I do know some apps have a connections settings menu where you can tell it what type of connection to use...
    Sometimes you'll see things like (This list I'm reading off of UberTwitter's settings...)
    -Auto Network
    -Device Default
    -BIS
    -Direct TCP
    -BES
    -WAP
    -Use WiFi if available.

    Check for a menu like that and make sure it's not set to "WAP" or "WiFi Only."
    09-10-10 10:33 PM
  3. carson73's Avatar
    Ya I tried that. Options were Automatic/Mobile Network Only/Wifi Only.

    Only seems to work on Wifi. Like I said, 3G works great everywhere else, except on some apps I get 'no internet connection' message unless my WiFi is on. Worked great on my curve but my Bold. Hmmm mm
    09-11-10 12:43 AM
  4. Rootbrian's Avatar
    Most of the apps I had on my pearl when I got my 9700 from telus, worked fine on 3G after being on CDMA for the longest time.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-11-10 10:35 AM
  5. WolfmanRobby's Avatar
    I would say to check with the developer of the programs.

    Sorry I can't offer more.
    09-11-10 11:09 AM
  6. kaleeswaran's Avatar
    Hi,

    I have the same issue for my Blackberry app. It is not working on 3g but workinng only Wifi. Did you get the solution for your issue? Kindly share the solution with me it would be great appreciated.
    10-24-12 05:28 PM
  7. Rootbrian's Avatar
    Maybe it's just the app. Try removing it and then reinstall it after a reboot even if not prompted to do so.
    10-24-12 05:34 PM
LINK TO POST COPIED TO CLIPBOARD