1. koroshiyax's Avatar
    To CB folks,

    Does anyone know if there is an application that will force your Blackberry to switch to 2G only when connecting to a specific Cell tower, whereas it would then reverts back to 3G/HPSA + 2G when connecting to other towers?

    Ideally, it would work similarly to the WiFi Manager app, which activities or de-activates wifi based on Cell tower connectivity.

    I've been trying to find such an app with no success, in my ever-ending quest to conserve battery on my 9900. I don't see a point using 3G/HPSA when at home, since I'm constantly on wifi + the 3G/HPSA signal in my condo is horrible.

    Thanks.
    05-03-12 12:42 PM
  2. boldkeyboardholic's Avatar
    To CB folks,

    Does anyone know if there is an application that will force your Blackberry to switch to 2G only when connecting to a specific Cell tower, whereas it would then reverts back to 3G/HPSA + 2G when connecting to other towers?

    Ideally, it would work similarly to the WiFi Manager app, which activities or de-activates wifi based on Cell tower connectivity.

    I've been trying to find such an app with no success, in my ever-ending quest to conserve battery on my 9900. I don't see a point using 3G/HPSA when at home, since I'm constantly on wifi + the 3G/HPSA signal in my condo is horrible.

    Thanks.
    I did use 2G with .296 until I updated the OS to 5xxes with the result of it didn't reduces the "idle drain" anymore. Terrible times with 7% idle! Bevor 3% with Edge, 5% 3G and 2% Wifi (wifi + 2G ~2,5% and wifi + 3G ~4%)

    With 7.1 (190 and 205 and another one) it did got a lilttle bit better up to 5% idle (no change when 2G or 3G only)

    I wiped probably 10x my 9900 but nothing did help. So I just set up to 2G+3G.


    but !!!!!!!!!!!


    with .342 + tested (the at least third time) apps and app combination I got it right and found two apps which caused all my problems + .342 is also adding long battery life too.

    Now I have 1% up to 2% idle drain using 3G + wifi + bt on (without actual wifi connection but active bt to my playbook! - if I'm using the Playbook of course it increased but usally even heavy usage of the bt connection/data connection means not more then 5% drain per hour!)

    Since two and a half weeks now I have very good battery life and really I couldn't believe it myself!!!

    For example today I didn't use the 9900 much as I was very busy with work on my desktop and didn't use the 9900 to write or read emails or had time to use the browser and put most of my calls on land line/with land line.

    6am to 6pm I still had 80%, on normal days I still have 60+% instead of 20% or less (and or recharging on afternoon)

    Of course when I use it it will drain faster but especially the very high idle drain was that thing which worried and bothered me most.

    On the first 3 days I actually let play hours of vid just to get the battery really down as I was expecting a wrong calculation of battery status.

    After 6 hours the battery was down to 25%, from 80%. That was on the first days day (and it was already way to late )


    What I wanted to say: apps or bad app combination/bad luck with that and the os version are much more important for the battery life.
    Last edited by boldkeyboardholic; 05-03-12 at 02:06 PM.
    05-03-12 02:04 PM
  3. koroshiyax's Avatar
    I did use 2G with .296 until I updated the OS to 5xxes with the result of it didn't reduces the "idle drain" anymore. Terrible times with 7% idle! Bevor 3% with Edge, 5% 3G and 2% Wifi (wifi + 2G ~2,5% and wifi + 3G ~4%)

    With 7.1 (190 and 205 and another one) it did got a lilttle bit better up to 5% idle (no change when 2G or 3G only)

    I wiped probably 10x my 9900 but nothing did help. So I just set up to 2G+3G.


    but !!!!!!!!!!!


    with .342 + tested (the at least third time) apps and app combination I got it right and found two apps which caused all my problems + .342 is also adding long battery life too.

    Now I have 1% up to 2% idle drain using 3G + wifi + bt on (without actual wifi connection but active bt to my playbook! - if I'm using the Playbook of course it increased but usally even heavy usage of the bt connection/data connection means not more then 5% drain per hour!)

    Since two and a half weeks now I have very good battery life and really I couldn't believe it myself!!!

    For example today I didn't use the 9900 much as I was very busy with work on my desktop and didn't use the 9900 to write or read emails or had time to use the browser and put most of my calls on land line/with land line.

    6am to 6pm I still had 80%, on normal days I still have 60+% instead of 20% or less (and or recharging on afternoon)

    Of course when I use it it will drain faster but especially the very high idle drain was that thing which worried and bothered me most.

    On the first 3 days I actually let play hours of vid just to get the battery really down as I was expecting a wrong calculation of battery status.

    After 6 hours the battery was down to 25%, from 80%. That was on the first days day (and it was already way to late )


    What I wanted to say: apps or bad app combination/bad luck with that and the os version are much more important for the battery life.
    I'm also on .342, the problem with mine is that it switches between 2G and 3G sometimes, and loses radio signal, which adds to the battery lost.

    By the way, which two apps were the culprits of your leak?

    Thanks.
    05-03-12 04:07 PM
  4. boldkeyboardholic's Avatar
    I have weeker (it was never be as strong as with the 9000 for example) wifi connection.

    2G/3G is ok.

    It was an App Handelsblatt and Fixmo tools. (now deinstalled, 8 paid for it in September )

    I did tested both apps a lot before but somehow on other OS versions the apps were working fine.

    Both were installed on .296 too

    I think I was unlucky with the 7.0 5xx I upgraded as well as the 7.1 190/205 - for example I wiped the device on .585 (or was it .590?) and had the chance to wait three days before I installed apps again! but on this OS version the drain was very heavy in idle + both apps didn't do "addional drain" (at least I didn't saw changes, was worse before and after...)


    BTW how many processes are running on your 9900?

    I had up to 77 processes running in average, at the moment it runs 55 in average.

    (data analyzer details where you see the battery % usage etc.)

    Edit:
    How long are you on .342?

    I forgot/mixed it, the first day with .342 I had extreme good battery life! but, I had 5 hours 99% and then it stared to get lower. On 40% it lost ~27% in one hour.

    This happend also on the next day, that the device shows me a wrong info.

    on the third day I deinstalled apps. (I did not wiped the device this time, just installed the OS)

    Then I deleted apps, about 5 apps in about 2 days. The hugh difference were both mentioned apps on the forth day after ..342 (I got that above a little bit mixed up)


    Right now it feels like having a complete other device, a better one! (even so I miss a few fixmo tools funktions )
    Last edited by boldkeyboardholic; 05-03-12 at 05:16 PM.
    05-03-12 05:09 PM
LINK TO POST COPIED TO CLIPBOARD