02-13-12 06:46 PM
48 12
tools
  1. HankHowdy's Avatar
    As you can see between my two screen shoots I have lost a ton of memory in minutes.

    What can cause this?

    Like I said all the builds I have been on have been this way.

    BlackBerry Bold® 9930 using Tapatalk 1.4.5.1
    11-27-11 04:12 PM
  2. Phill_UK's Avatar
    I don't know Hank... I never use the Application Management app for memory monitoring. I use MeterBerry because I'm more interested in how much memory I'm losing, and not how much I'm using.
    11-27-11 04:14 PM
  3. HankHowdy's Avatar
    I don't know Hank... I never use the Application Management app for memory monitoring. I use MeterBerry because I'm more interested in how much memory I'm losing, and not how much I'm using.

    I remember how much I had before, that's how I always know how much I'm using.

    BlackBerry Bold® 9930 using Tapatalk 1.4.5.1
    11-27-11 04:18 PM
  4. HankHowdy's Avatar
    The browsers memory still hasn't returned after all this time.

    I have cleared the cache.

    So now what?


    BlackBerry Bold® 9930 using Tapatalk 1.4.5.1
    11-27-11 04:21 PM
  5. kjjb0204's Avatar
    26 hours in after downgrading back to .540 from the 7.1 leak, with heavy usage today... and only 0.4MB memory loss.



    Click to view quoted image

    Ugh, why does mine say 512 for total app memory and yours is 768?
    11-27-11 04:23 PM
  6. Phill_UK's Avatar
    Ugh, why does mine say 512 for total app memory and yours is 768?
    Go into the options menu and manually change it to correctly show 768MB
    11-27-11 04:25 PM
  7. kjjb0204's Avatar
    Ah, didn't see that. Thanks!
    11-27-11 04:28 PM
  8. HankHowdy's Avatar
    Do have a deflected phone?

    BlackBerry Bold® 9930 using Tapatalk 1.4.5.1
    11-27-11 04:50 PM
  9. jordan559's Avatar
    Do have a deflected phone?

    BlackBerry Bold« 9930 using Tapatalk 1.4.5.1
    Hank I also hve a 9930 and its the same as urs. I had the original OS and now the latest release frm Verizon and it still the same. The only way I get the memory all back is after a battery pull. Once I use the browser it doesn't come back if I do a cahce clear I get some of it but not all. It stays @ 44mb used.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-27-11 06:08 PM
  10. HankHowdy's Avatar
    Hank I also hve a 9930 and its the same as urs. I had the original OS and now the latest release frm Verizon and it still the same. The only way I get the memory all back is after a battery pull. Once I use the browser it doesn't come back if I do a cahce clear I get some of it but not all. It stays @ 44mb used.

    Posted from my CrackBerry at wapforums.crackberry.com

    See, we have same problem.

    What about the system memory?

    BlackBerry Bold® 9930 using Tapatalk 1.4.5.1
    11-27-11 07:23 PM
  11. emirozmen's Avatar
    Clear your browser cache when you're done, and as Atakan said above, enable memory cleaning when idle.
    What happens exactly does it go thorugh a process when the device is idle? Does the device freeze when doing this?
    11-28-11 07:19 AM
  12. Phill_UK's Avatar
    What happens exactly does it go thorugh a process when the device is idle? Does the device freeze when doing this?
    It takes about 10 seconds, and if you set it to happen when the device is idle... you'll never know if it freezes

    Memory Cleaner doesn't touch the Browser anyway, it only clears sensitive data from certain modules.
    11-28-11 07:28 AM
  13. HankHowdy's Avatar
    It takes about 10 seconds, and if you set it to happen when the device is idle... you'll never know if it freezes



    Memory Cleaner doesn't touch the Browser anyway, it only clears sensitive data from certain modules.

    Is it possible that the memory app is not very good at displaying what is going on with a 9930 phone compared to 9900?

    No matter what I do I never ever get the browsers memory back or most of the system memory either.

    Phill look at my thread titled Totally Not Ok.

    BlackBerry Bold® 9930 using Tapatalk 1.4.5.1
    11-28-11 09:10 AM
  14. runxZ's Avatar
    What about ram memory? Is it normal to loose 100mb in two days?

    No matter what build I use or what apps I have installed.

    BlackBerry Bold« 9930 using Tapatalk 1.4.5.1
    I too have the same problem, I am using a 9900. I have just settled for a battery pull every two days.
    11-28-11 11:04 AM
  15. ahmed.atiya1's Avatar
    I updated to .540 two days ago to see if the situation would be resolved, sadly, it is not.

    1) The App storage memory keeps dwindling over the course of the day. The only apps im running are the stock msn, gtalk, facebook, twitter, social feeds, bbm, messages, and the browser app. In the application management, under the "application storage" tab, my "others" category keeps climbing Today, it has gone from 43.3 after a hard reset in the morning to 75.6 now. Does anyone know where exactly the facebook, twitter, and social feeds apps store people's updates, display pics, etc.? I have a ton of stuff on my social feeds that I use all the time including fb, twitter, rss feeds, etc. Maybe all those pictures and updates are using that memory? :S Does everyone else really not experience this problem???

    2) As for the browser's RAM usage, I have the exact same problem with a 9900. After loading pages on the browser, its RAM usage NEVER goes back to normal until a hard reset. It usually hovers around 50 to 100mb, but it doesn't concern me, because the phone has a lot of RAM left. What does concern me is the app storage decreasing, because it really bogs down the phone, and Im forced to a do a hard reset daily

    Anyone else have ANY idea what's going on?
    11-29-11 07:03 PM
  16. ahmed.atiya1's Avatar
    Now down to 123.5mb app storage left with 86.3mb of "other." The phone's getting really laggy now, I'll probably have to do another hard reset in a bit. Sigh...
    11-29-11 09:20 PM
  17. ahmed.atiya1's Avatar
    I tried not restarting my phone, hoping that the problem may somehow correct itself overnight, but it hasn't. The phone is now getting really laggy, app storage is down to 115.8mb I really don't know what to do about this. I'm considering selling the phone now. I love everything about this thing, but I just can't put up with the need to do a hard restart, especially since it can't even go a full day without lagging anymore
    11-30-11 06:16 AM
  18. kjjb0204's Avatar
    I like performing a reset every day or so just to keep it fresh. Now that it takes under 2 minutes to reboot, it doesn't bother me in the slightest. Many people have apps installed to do it for them in the middle of the night. What's the big deal with a restart?
    11-30-11 11:36 AM
  19. ahmed.atiya1's Avatar
    I like performing a reset every day or so just to keep it fresh. Now that it takes under 2 minutes to reboot, it doesn't bother me in the slightest. Many people have apps installed to do it for them in the middle of the night. What's the big deal with a restart?
    I have 2 concerns:

    1) After a reset, I lose all BBM contact updates, etc.

    2) The phone no longer lasts even a day before it requires a reset. I have 165.8mb of free storage memory after a reset, and by 6pm or so, it's down to less than 100 on most days. The biggest issue, however, is the lag! Is there really no solution to this? Has everyone just turned a blind eye to the issue?

    Honestly, I wouldn't even mind resetting it once/day, if it lasts a whole day without getting slow and laggy

    My gf's 9780 RARELY ever gets restarted, she has 7 app updates that have been sitting there for over 4 months and her app storage memory is at a constant 205mb or so free everytime i check. She also uses fb, social feeds, bbm, etc.

    I tried starting my phone in safe mode now, just in case the issue is related to a certain app. I've only launched msn, gtalk, social feeds, bbm, facebook, and twitter (all RIM apps) in hopes that the memory doesn't decrease by the end of the day. I really hope that this is the case. I use the phone heavily, and not being able to get through even 1 day without getting laggy and requiring a restart is a huge let down
    11-30-11 12:23 PM
  20. ahmed.atiya1's Avatar
    I think I've resolved the issue

    I wiped the phone and did a clean reinstall of .540 last night and manually put back only my trusted apps. The phone has been on since 7:30am (5.5 hours) with heavy usage and has only lost about .3mb of app storage with no lag at all so far Hopefully this lasts. I'll be really happy if it turns out to be one of my other apps that was causing the issue
    12-01-11 11:57 AM
  21. kjjb0204's Avatar
    How's the memory depletion looking after two days (almost)? Curious if you discovered an offending app....
    12-02-11 04:05 PM
  22. ahmed.atiya1's Avatar
    How's the memory depletion looking after two days (almost)? Curious if you discovered an offending app....
    Absolutely perfect! 2 days without a restart and tons of usage with virtually 0mb of storage memory lost (well, maybe 0.1? :P) also, as for the browser, I've noticed that while the RAM isn't returned when it's closed, the browser's RAM is decreased when the phone runs out of RAM, so this is probably just the software design I'll compile a list of all the apps I had installed before and the ones I have installed now tomorrow so that we can attempt to find the offending app
    12-03-11 12:54 AM
  23. ahmed.atiya1's Avatar
    UPDATE!

    So, I decided to close Facebook for a while to focus on schoolwork, and literally as soon as I logged out from my BB's FB app, the phone is running perfectly, and app storage is back to normal! I tried logging back in and the phone becomes laggy in a short period of time (a few minutes). Logging out resolves all issues again! Remember, I'm not even talking about deleting the app, I'm only LOGGING OUT OF FACEBOOK. Note that I have twitter, social feeds, windows live, google talk, bbm, as well as browser/home/phone still running on the phone.

    I'm astonished at how amazing this phone is without Facebook. I remember why i fell in love with this phone when I first got it. Why does RIM not resolve this HUGE memory leak associated with Facebook?

    Lastly, is anyone else with storage (app) memory leak issues able to reproduce this by simply logging out of Facebook on their phone?
    02-13-12 06:46 PM
48 12
LINK TO POST COPIED TO CLIPBOARD