1. DGI_BB's Avatar
    Hi

    I tried to upgrade to the new OS on my 9520 today, but now I can't get anywhere
    Everytime I start the phone I get App Error 523 or App Error 200. I can't connect to the phone from the PC, so I don't know how I shall wipe the phone to start from scratch?

    I need help ASAP because I need my phone to work.
    Please help
    06-15-10 02:24 AM
  2. rafiks's Avatar
    search the site for help on how to revive a bricked phone.

    HTH
    06-15-10 03:27 AM
  3. DGI_BB's Avatar
    search the site for help on how to revive a bricked phone.

    HTH
    I have tried, but nothing seems to work. Please help
    Everything I do, the PC can't seem to connect to the BB. Tried with and without battery.
    The BB loads fine, but when it tries to start the OS, it comes up with a white screen with the message App Error 523.

    Is the only way, to just trash the phone:s?
    Last edited by DGI_BB; 06-15-10 at 05:53 AM.
    06-15-10 05:09 AM
  4. ST79's Avatar
    Download BBSAK and see whether it detects the device or not. You can use BBSAK to wipe the device and reload the os. Make sure you have the 9520 OS...
    06-15-10 07:06 AM
  5. DGI_BB's Avatar
    Download BBSAK and see whether it detects the device or not. You can use BBSAK to wipe the device and reload the os. Make sure you have the 9520 OS...
    Thanks
    Patience is a must here

    This is also something I tried:

    --------------------------------------------------------
    App Error 523 solved aswell.

    I recently picked up the Bold but, gave my old 8310 Curve to a friend. Before giving it to him, I updated the OS from 4.2 to 4.5. There were a few themes that were on the device from 4.2 which would not show a preview however, he tried to set the theme to Scribble from the old OS 4.2. That's where the APP ERROR 523 came from. This is how I solved the problem.

    First I connected the device to my computer via the USB cable while the device displayed the error. Then I double clicked on my Blackberry Desktop Manager to bring up the program. After a few minutes, I clicked on NONE near the bottom left corner. It brought up a menu to select the source of the connection and it displayed USD PIN: XXXXXXXX. I chose this as the connection source and clicked ok. It will not show as it being connected tho however. But, if you click NONE again, it will show that the source is selected properly. Now, click on Application Loader option on the desktop. Before you click Start, click the ball on the device to reset then quickly hit START on the Application Loader/Desktop Manager. Somehow, it managed to connect to the device sucessfully. If one of the processes seem to take more than 3 minutes to connect (total of 4 tasks) then repeat the above process. The Manager will go through the normal thing of checking for updates but, once that's done, it will bring you to the page where you can add or remove items. I removed all the old 4.2 OS themes and click FINISH. The device was able to reboot successfully and reverted to the default theme.

    I hope that helps some of you. Good Luck.
    06-15-10 08:55 AM
LINK TO POST COPIED TO CLIPBOARD