09-16-13 09:56 AM
90 1234
tools
  1. bill-ns's Avatar
    I've manage to create the bar file (using bluestack to recover apk and PlayBook .apk to .bar converter) :
    com.rsa.securidapp_v1.0.8.0.bar

    Once sideloaded (using DDPB Installer or better), you need to download the token convertor from RSA ftp://ftp.rsasecurity.com/pub/agents...nverter261.zip

    Once unzipped, copy your token file (in my case was a sdtid file) in the same directory. Open a command prompt and browse to that directory.
    Type the following command : TokenConverter.exe yourtokenfile.sdtid -android

    You'll get an url looking like this one :
    Code:
    http://127.0.0.1/securid/ctf?ctfData=0000001111122224766767873733333
    Launch secureid on your Z10, press menu in the Android Player (bottom right), import token and there paste the url you generated and voilà !

    Tried and successfully connected to work this morning.

    Note: The sdtid file is probably by the hands of someone from your it. You can't extract it from you secureid app on BB OS 7 and below.

    Hope this help.


    Coooly... just noticed this... why that version of the .apk? The latest version on Google Play is 1.2.
    Bill
    02-21-13 09:10 AM
  2. Coooly's Avatar
    Yep, it's that one I've used. (File generated by apk2bar is oddly named. Don't know why)
    02-23-13 04:43 AM
  3. usman_hafeez's Avatar
    Hi coooly, first of all thanks for creating and sharing the Bar file and the steps. I installed the Token in my Z10 and did all the tricks what you mentioned to get rid of that "turn on your Wifi...." message but it is not going away can you please help me to solve this issue.
    02-23-13 06:04 AM
  4. Coooly's Avatar
    Is your blackberry activated against a BES 10 by any chance ? Could take a screen short (push both volume button) and post it here ? Curious about this message.
    02-23-13 12:01 PM
  5. usman_hafeez's Avatar
    Hi Coooly, first of all just to tell you that "activate message issue....." went away automatically last night when i opened RSA app on my mobile. I don't know how And yes my my BB is activated against BES 10 but i guess it has nothing to do with it coz i removed my SIM and wiped data and configured my BB without any SIM in it, still it was giving the same error. I gave up by then and inserted SIM. But later when i ran the RSA app, it ran fine
    02-24-13 12:38 AM
  6. chak_attack's Avatar
    The method posted here works great on my z10 and playbook.

    One thing to note, RSA cannot side load after whatsapp was sideloaded. I had to delete whatsapp , then sideload rsa and then sideload back whatsapp. Everything is working great now. Thanks to coooly for posting everything

    also, if you send to key to your gmail, you won't have to type in like 30 digits as the token....
    03-04-13 11:54 AM
  7. bill-ns's Avatar
    The method posted here works great on my z10 and playbook.

    One thing to note, RSA cannot side load after whatsapp was sideloaded. I had to delete whatsapp , then sideload rsa and then sideload back whatsapp. Everything is working great now. Thanks to coooly for posting everything

    also, if you send to key to your gmail, you won't have to type in like 30 digits as the token....
    I'd be surprised if this was the case... I've got many sideloaded apps on my PB and didn't have this issue. I can't imagine the WhatsApp sideload would be any different. On the last Z10 (4 now) I put SecureID on I had to reboot in order to get past the wifi error. What was the error you were seeing?

    Yes, sending the key to gmail would work... like I mentioned in a past post in this thread, any email configured on the personal partition would work. Unfortunately for me, these are all new/unconfigured devices, so I just get someone to dictate the URL to me as I type. lol

    Bill
    03-04-13 12:07 PM
  8. chak_attack's Avatar
    I'd be surprised if this was the case... I've got many sideloaded apps on my PB and didn't have this issue. I can't imagine the WhatsApp sideload would be any different. On the last Z10 (4 now) I put SecureID on I had to reboot in order to get past the wifi error. What was the error you were seeing?

    Yes, sending the key to gmail would work... like I mentioned in a past post in this thread, any email configured on the personal partition would work. Unfortunately for me, these are all new/unconfigured devices, so I just get someone to dictate the URL to me as I type. lol

    Bill
    I've tried rebooting and everything......... rsa just didn't want to load... so i removed whatsapp sideload and then rsa immediately was able to be sideloaded... i am not saying it'll happen to others, but thats my experience... There was really no error from DDPB, it still says OK but app never gets on the device, the only difference I see is the status where it is saying requesting... sending... 50%.... and it never goes beyond that number.

    Yeah, I typed it in my pb.........wasn't fun...... lol
    03-04-13 02:24 PM
  9. chak_attack's Avatar
    It was me who said that. What I did was that I removed my home wifi, and the iphone hotspot wifi that i had saved on the Z10 earlier

    Settings->Network Connections->wifi-> Saved

    Then it brought up the list. I tapped on each and deleted them.

    After that i didnt get the error message anymore.
    On another z10, i had this problem, did the same thing, needed a reboot of the device. Then no more errors!
    03-04-13 02:31 PM
  10. Thunderbuck's Avatar
    Unfortunately, the download link is broken
    03-07-13 05:28 PM
  11. mentalcase's Avatar
    I'm also having an issues with the Wifi message. I've deleted any hotspots and restarted twice, but the message will not go away. Looks like I'll be carrying around 2 devices for a while.

    I wonder if it has to do with the AT&T Wifi that is permanently saved since I have a branded device. Either way it is disappointing.
    03-26-13 07:54 PM
  12. abdalla889's Avatar
    I tried all of this, still cant get the WIFI Message to go away..

    of those of you that tried, can you please list your steps?

    I have the URL link, I deleted my saved WIFI profiles.

    not sure what else yall did
    03-28-13 11:57 AM
  13. bill-ns's Avatar
    I tried all of this, still cant get the WIFI Message to go away..

    of those of you that tried, can you please list your steps?

    I have the URL link, I deleted my saved WIFI profiles.

    not sure what else yall did
    I believe the steps have already been mentioned a couple times in this thread. Is this a BES10 attached device?
    You need a working wifi connection for the apps initial run. Either a personal wifi, or a wifi profile pushed out from the BES10 that is specifically provisioned to allow access from the personal side of balance. Because the RSA app is side loaded, it is a personal app.

    So...
    -have a working personal wifi connection, or provisioned personal app enabled work wifi connection.
    -might as well reboot
    -side load RSA app
    -sure... reboot it again.
    -browse a web page from the personal browser... why not.
    -start the RSA app.
    from there, you'll need to type in the token url... or email it to a personally configured email address, then you can cut and paste.

    Is the version you have 1.2?
    in BDS make sure "Work Network Usage for Personal Apps" is not set to deny.
    In Balance on your BB, make sure "Allow Personal Apps to Use Work Networks" is set to On.

    Other than that, I really don't know what to tell you. It definitely works... I've done about a dozen installations now.
    Good luck
    Bill
    Coooly likes this.
    03-28-13 12:17 PM
  14. mentalcase's Avatar
    I believe the steps have already been mentioned a couple times in this thread. Is this a BES10 attached device?
    You need a working wifi connection for the apps initial run. Either a personal wifi, or a wifi profile pushed out from the BES10 that is specifically provisioned to allow access from the personal side of balance. Because the RSA app is side loaded, it is a personal app.

    So...
    -have a working personal wifi connection, or provisioned personal app enabled work wifi connection.
    -might as well reboot
    -side load RSA app
    -sure... reboot it again.
    -browse a web page from the personal browser... why not.
    -start the RSA app.
    from there, you'll need to type in the token url... or email it to a personally configured email address, then you can cut and paste.

    Is the version you have 1.2?
    in BDS make sure "Work Network Usage for Personal Apps" is not set to deny.
    In Balance on your BB, make sure "Allow Personal Apps to Use Work Networks" is set to On.

    Other than that, I really don't know what to tell you. It definitely works... I've done about a dozen installations now.
    Good luck
    Bill
    Awesome. Upgrading to version 1.2 and enabling wifi worked like a charm.

    Luckily my company has a website that allows me to generate token files any time I need them. Now it's time to share this with my coworkers.

    Thanks!
    03-30-13 01:34 AM
  15. byonush's Avatar
    Has anyone gotten this to work on a Z10 from verizon? I did sideload the RSA SecurID 1.2 onto the phone. Ran the convert on the sdtid file. Copied the url and sent to my gmail account. When opening app I get Process system.apps has stopped unexpectedly. When I click on import and paste or enter url manually I get Token Import Failed. Token not intended for this device. Contact your administrator.

    Any help would be appreciated.
    04-01-13 09:30 AM
  16. gjcavana's Avatar
    Has anyone gotten this to work on a Z10 from verizon? I did sideload the RSA SecurID 1.2 onto the phone. Ran the convert on the sdtid file. Copied the url and sent to my gmail account. When opening app I get Process system.apps has stopped unexpectedly. When I click on import and paste or enter url manually I get Token Import Failed. Token not intended for this device. Contact your administrator.

    Any help would be appreciated.
    I had the exact same issue you described. From reading other threads it sounds like the problem is the OS version on Verison Z10s. I also have those symptoms on all Android ported apps including ones like Kindle from BB World. I was finally able to get it to work buy uninstalling and re-installing several times as well as turning Developer mode on and off. Finally after installing one time it gave me the prompt to import the token. Once I had that I quickly copied the URL from my email and pasted it and it worked. I then got the error you mentioned the next time or two I opened the app but eventually went away after a reboot or two. Hope this helps until Verison puts out a fix.
    04-02-13 08:02 AM
  17. pcondello's Avatar
    This is the response I got from the product manager at RSA (nathan.furze@rsa.com):

    Thanks for your inquiry re: a software token for BlackBerry 10. BlackBerry and RSA have entered into a joint development agreement to deliver a RSA SecurID Software Token application for the BlackBerry 10 platform. The App is already under development and it will reach general availability in the Summer timeframe.

    I have contact info for this app and many others in my thread:

    http://forums.crackberry.com/blackbe...ng-out-781831/
    04-02-13 09:27 PM
  18. higherdestiny's Avatar
    To get this working on my phone, I did the following:

    1) Sideloaded the app. Launched, got the wifi error.
    2) Closed the app.
    3) Connected to personal wifi (or another device's personal hotspot).
    4) Rebooted device.
    5) Made sure device had connected to wifi upon reboot.
    6) Launched RSA app again.... took a while to initiate... worked.

    If the above steps fail, try deleting all saved wifi networks before step 3. But it should work.
    04-03-13 07:37 PM
  19. sbowlestx's Avatar
    I text the url and it works because text messages are personal.

    Damn... apparently I should have subscribed to this thread...

    Couple things... The .bar cannot be pushed out via the BES10 server. Currently only local QNX files (not QNX\Android) and BB World files can be pushed.

    Because the sideloaded file resides in the Personal partition of a BES10 connected phone, there are a few caveats.
    If you're conencted to a work wifi network(one that's pushed via a BES10 wifi profile), that network must be available to Personal partition apps. You can make this change on the BB10 device or via the security profile on the BES10. This is just a one time thing that the app needs network connectivity.

    To provision (import) the token, unfortunately I had to manually transcribe the very long url into the phone.
    We use RSA Authentication manager 7.1. I installed the Android 1.x profile and created a token file. The token file then needs to be converted by RSA's Android Token Convertor. That converts the token file to a url.
    The Android app shows a hardware id that is used to create the token in the first place... It's no longer the BB PIN.

    The reason I couldn't email the url to the device and copy/paste it is that you can't copy paste from work partition to personal partition. So if the BB10 device has a non-corporate email address (hotmail, gmail..) then email the url to that address and copy/paste to the RSA app.... otherwise you're manually typing in the address.

    Sorry, not going to submit my .bar, but there is an online site that should work just fine to create the .bar.

    Think that's it... so far I've got it working on 3 Z10's and a playbook. Not sure why RSA doesn't just push it out to App World. The app works fine... see no reason for the hold up.

    Bill
    04-03-13 07:55 PM
  20. lacell2's Avatar
    Worked great on my BB10
    04-04-13 10:50 AM
  21. mr_sticky's Avatar
    I had the issue with it asking to connect to Wifi as well. Tried suggestions to delete wireless profiles above to no avail. A simple device reboot fixed it on two Z10's I was setting this up on and got the wifi prompt.

    Also I was able to copy and paste the token URL from a draft email I threw in outlook temporarily. No typing 50 random digits..
    04-10-13 08:18 AM
  22. ekrimmer's Avatar
    I've been attempting this tonight. Following all the tips above I get the app running (although it initially crashes) but it stalls on a screen indicating a token must be imported but there are not controls to allow that to be done. OS version is 10.0.9.2743; Software release 10.0.9.422.
    04-11-13 11:19 PM
  23. lacell2's Avatar
    this thread worked great for my Z10 .. My friend just recieved his BlackberryZ10 with updated Software release 10.0.10.166 side bar the RSA tool but will not open on device it keeps saying to connect to WI-Fi connection and then closes. My software version 10.0.10.88 i suggest no updates until RSA is officially released.
    04-12-13 11:00 AM
  24. 1magine's Avatar
    So I got it working. I needed to set all security permissions and rename the token to get it working, but it's working well.

    The problem is how to distribute and load tokens onto dozens of users devices. This works for me as a tester for my firm, but there is no way in he-- I'm reccomending any BB10 device until RSA is available.

    Honestly - I just don't get BBRY. They had OS10 in development for years. They handed out devoloper units a year ago. How do you launch a device aimed to keep BES and other corporate users on the platform and not have HAE or RSA ready to go? It's like launching into the consumer space without applications like Instagram and Skype.
    04-17-13 05:43 PM
  25. 1magine's Avatar
    I've been attempting this tonight. Following all the tips above I get the app running (although it initially crashes) but it stalls on a screen indicating a token must be imported but there are not controls to allow that to be done. OS version is 10.0.9.2743; Software release 10.0.9.422.
    Swipe done from top to reveal settings bar. Like many android ports.
    pkcoms likes this.
    04-17-13 05:45 PM
90 1234

Similar Threads

  1. What apps are confirmed to be coming to BB10?
    By audijeep in forum BlackBerry 10 Apps
    Replies: 23
    Last Post: 02-03-13, 07:04 AM
  2. Does anyone have any idea when Plazmic will be compatible?
    By Ethrem in forum BlackBerry Tour 9630
    Replies: 12
    Last Post: 07-23-09, 07:11 PM
  3. Anyone having issues on ATT?
    By richard371 in forum General BlackBerry News, Discussion & Rumors
    Replies: 34
    Last Post: 02-13-09, 05:57 AM
  4. Anyone have any idea when Tmobile will release OS 4.5?
    By slumpbuster in forum BlackBerry Curve Series
    Replies: 4
    Last Post: 10-15-08, 12:23 AM
  5. Does anyone have NHL on Viigo?
    By nikos in forum General BlackBerry News, Discussion & Rumors
    Replies: 8
    Last Post: 09-21-08, 06:10 AM
LINK TO POST COPIED TO CLIPBOARD