1. heatherkj's Avatar
    I am so frustrated.

    About a week ago, I was going out of the country and wanted to stop receiving e-mails from a few of my accounts (didn't want to be charged for them). So, I deleted my extra e-mail accounts with the intention of just setting them back up when I got back home.

    I did that, and when setting up Gmail, I allowed it to "sync contacts" with my BB Tour. BIG MISTAKE, apparently.

    Now, all of my contacts are messed up. Judging from my searches, it sounds like I'm relatively lucky in that no information was deleted or misplaced. When I go into my contacts, everything still appears to be normal. However, when someone calls or texts me, their name is no longer synced with their number--only their number shows up, and half the time I have no idea who the heck it is. Also, if I'm trying to compose a text message or e-mail of my own, I can't just type in the person's name and have it come up like it used to.

    I tried to unsync everything to see if that would fix it, but to no avail. I also tried to delete Gmail and set it up all over again, but that did not fix it, either.

    When I go into a contact and try to edit the contact, it says at the top "Synchronize Using: Gmail." I just want to get rid of this, I do not want it syncing with Gmail! What a waste!

    Does anyone have a fix for this? My contacts list is essentially useless right now and I HATE it.
    06-17-10 04:23 PM
  2. MrObvious's Avatar
    Are the contacts a okay in Gmail? If not I would fix it there, uncheck the synchronization settings in your BIS setup for it, and then just use Google Sync.
    06-17-10 07:07 PM
  3. Amy wineBerry's Avatar
    I had seriously thought I was having that issue because of one of my applications--Add to Contact--so I deleted it, did a battery pull, and then everything was back to normal. However, your mentioning the gmail contact sync makes me think that could have been the problem for me as well. Granted, I'm still syncing with gmail and everything seems to be fine right now.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-17-10 07:32 PM
  4. tazzclass's Avatar
    I just had this vey same happen. When I did a battery pull my contacts were gone. Had to use DM and use restore to put things back. Verizon ha no answers.
    06-17-10 07:50 PM
  5. paintdrinkingpete's Avatar
    I've given out this tip many times, and to be honest, I'm not sure why Google doesn't just recommend this from the onset...

    If you want to know the answer as to "why?" I do this or recommend you should, my only answer is because it has always worked perfectly for me, and I've heard way too many stories such as the OP's to even try to do it any other way.

    - DO NOT enable the option to sync contacts when setting up your GMail account under email settings

    - DO install the Google Sync app, and that sync your contacts for you. It has a small footprint, runs in the background and initiates syncs automatically, and has always worked perfectly for me. Added bonus: it syncs your Google calendar as well, if that floats your boat.
    06-17-10 08:00 PM
  6. heatherkj's Avatar
    Thanks, Pete. That seemed to fix my most pressing issues (not being able to search contacts, and having names not connected with phone numbers when I receive calls/text messages).

    Now, there seem to be a bunch of "blank" entries at the top of my address book that I can't get rid of, but I suppose I can deal with that.

    Stupid Google!

    Thanks again for the fix...
    06-25-10 02:40 PM
LINK TO POST COPIED TO CLIPBOARD