1. eehan87's Avatar
    Just got my first berry, was an iPhone user, I felt like a bit of a change...

    Having a few troubles with Facebook and Gmail applications accessing the internet...

    I can connect to my local wifi and browse websites etc etc, yet whenever I go to login to a website (currently only facebook and gmail, yet ebuddy logs in sucessfully) It gives me an error;

    Facebook Error: Could not connect because a data service is not available. Please try again later. If this continues, contact your service provider for support.

    Gmail Error: This program requires a working data connection. Please check your signal strength and connection settings and then restart the application.

    Any help will be greatly appreciated.

    Software version 4.6.1.286 Platform 4.2.0.122
    03-12-10 09:06 PM
  2. pats2nd's Avatar
    Since you just got it I would wait a little while before trying again because sometimes it takes the carrier a little while to send all of your info for data.
    03-12-10 11:23 PM
  3. CJ1991's Avatar
    I agree with pats2nd...and also try retinstalling the apps just for good measure good luck!

    Posted from my CrackBerry at wapforums.crackberry.com
    03-12-10 11:58 PM
  4. eehan87's Avatar
    I rang and spoke with my carrier (optus) and because this plan was not originally a blackberry plan, they had to bolt on a usage thing for me, which is an extra $20 a month, not worried about that...

    It's been 24 hours and still nothing working... Perhaps there may be something in the settings ?
    03-13-10 09:42 PM
  5. diegonei's Avatar
    So you called the carrier and they got you into the BlackBerry data plan right? Check with them what is your BIS login and password.

    If you don't have any, get to google, find your carrier's BIS page create an account, and get your PIN/IMEI there. Then set your emails and resend the service books.

    That should see all apps going as they are supposed to.
    03-14-10 09:03 AM
  6. anon3148529's Avatar
    Go into your browser to OPTIONS) GENERAL PROPERTIES) and make sure the default browser is set to HOTSPOT when your in your Wi-Fi area, and set to INTERNET. (If you have a T-Mobile BlackBerry then set it to T-Mobile)

    If your having problems getting onto your Wi-Fi, then this is how you do it
    -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-

    1. Go to the SETUP folder. And find "SET UP Wi-Fi". Then click it.
    2. Click "SCAN FOR NETWORKS"
    3. When you have found your Wi-Fi, it will say, the router supports protected setup most likely. Just click back.
    4. Enter your password. (WEP Key)
    5. Then click "SAVE".
    6. Enter a name for the Wi-Fi to show up on your BlackBerry as and click "NEXT".
    7. Click "FINISH" and your done.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-14-10 10:36 AM
  7. anon3148529's Avatar
    Sorry I meant to say to set it to "INTERNET" when you were not in a Wi-Fi hotspot.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-14-10 10:38 AM
  8. kind_hand's Avatar
    I have the same problem, my Internet is working fine with all application except the facebook and i tried it on wifi and BIS, any help?
    03-23-10 06:30 AM
  9. kind_hand's Avatar
    the problem solved

    I installed facebook app version 1.6 after installing the version 1.7 and that worked fine for me I have Curve 8520

    facebook version 1.6 found here
    //mobileapps.blackberry.com/devicesoftware/entry.do?code=facebook16
    03-23-10 08:18 AM
  10. DarwinMD's Avatar
    hi, im also using bb 8520.. just got it 2 days ago...

    i cant download my facebook 1.6. ive already installed fb 1.7, when i tried to download fb 1.6 it says, that the device does not meet the system requirements etc

    im using the hotspot browser.. wifi works just fine. thank you in advance!
    04-16-10 09:09 AM
LINK TO POST COPIED TO CLIPBOARD