08-07-09 06:14 PM
58 123
tools
  1. uncleman's Avatar
    FYI for those experiencing Slacker/Pandora problems, which should be everyone who uses these apps with the 151 radio. Basically, it's a known issue with 151 and has been fixed with the next OS, 164. Until that OS is leaked, 151 (including hybrids with the 151 radio) will not work with streaming unless you swap out the radio. I'm using a 151 hybrid with the 132 radio and having no more issues.

    This info is from a software developer at Pandora (MarcPandora here on CB) with whom I've exchanged emails. His latest info is from another thread and is as follows:

    "From the RIM public bug tracker, this appears to be a known bug with .151. For those with a developer center login, check out https://www.blackberry.com/jira/browse/JAVAAPI-144 for more information. Basically, any app that calls Connector.open(url) will throw an out of memory error after about 85 or so calls. Comments from RIM engineers indicates that it has been fixed as of .164. So in the meantime, it's probably best to avoid using .151."
    07-16-09 12:50 PM
  2. blaisedinsd's Avatar
    Good to know.

    I have it intermittently...but then again Pandora has always occasionally given me errors. Still works well enough to keep Pandora and .151 for me.

    The newest version of Pandora sounds really great.
    07-16-09 12:59 PM
  3. 1967LS2's Avatar
    thanks for the input....I knew it had something to do with .151 cause it only started happening with the new leak. What hybrid are you using? Do you like it? I'm really really liking .151 but this is the only issue I am having with it thus far.
    07-16-09 01:00 PM
  4. uncleman's Avatar
    thanks for the input....I knew it had something to do with .151 cause it only started happening with the new leak. What hybrid are you using? Do you like it? I'm really really liking .151 but this is the only issue I am having with it thus far.
    I'm using lyricidal's 6v3 hybrid and I like it so far. Not sure how much better than straight 151 it is b/c I never had straight 151. lol

    If I were you, I'd sick with 151 or move to a 151 hybrid, but make sure to swap out your radio for another version (not 148 though, b/c that is supposed to suck).

    Here is a link to lyricidal's hybrid: http://forums.crackberry.com/f132/95...hybrid-263404/
    07-16-09 01:04 PM
  5. 1967LS2's Avatar
    Nice! Thanks for the link. Does this hybrid have the new transitions between application screens and stuff? Also my memory management has been phenomenal on straight .151 how is it on this hybrid? Also do you think I could just take an older radio code and swap it in the straight .151? If so how do you do that? Thanks for your help and guidance...
    07-16-09 01:20 PM
  6. uncleman's Avatar
    My memory isn't great but I think it's b/c I'm running a theme that 151 doesn't like plus I have over 30 3rd party apps. I'm gonna take the theme off and see if that helps but I don't really want to drop it cuz I loves it!!

    Yes, the hybrid has the transitions. But you could also keep the straight 151 and just swap out the radio. Easiest way I think is to download lyricidal's shrink-a-os, put it in your OS folder (should be something like C:\Program Files\Common Files\Research In Motion\Shared\Loader Files\9530-v4.7.0.151_P4.0.0.186) and run it. It's a cool little program that allows you to easily remove a bunch of the junk that's in the packaged OS (foreign languages, stock backgrounds, etc) and it also allows you to swap out the radio.

    Download shrink from here: BlackBerry Apps/Hybrids by lyricidal

    You need to get a .rar extractor to extract the program and then put it in the folder I mentioned above. Then open the program and at the top hit the browse button and find the OS folder I pasted above and click ok. Then check off any junk you don't need on your BB. Then click the box on the right re 151 transitions. Then open the radio swap drop down menu and choose .132. Next click SHRINK MY OS! and it'll tell you how many MBs your java files are pre-shrink and then post-shrink. Lastly, load the newly shrunk and swapped OS onto your BB. Most people suggest using Loader.exe (there's a button to launch it within shrink-a-os).

    Hope this helps. Any questions, post back, PM me, or email me.
    Last edited by uncleman; 07-16-09 at 10:16 PM.
    07-16-09 02:08 PM
  7. lbrenes#CB's Avatar
    Thanks so much for these instructions, which I followed. Do you know if there is a way in the phone to check if the radio was successfully changed? Thanks.

    My memory isn't great but I think it's b/c I'm running a theme that 151 doesn't like plus I have over 30 3rd party apps. I'm gonna take the theme off and see if that helps but I don't really want to drop it cuz I loves it!!

    Yes, the hybrid has the transitions. But you could also keep the straight 151 and just swap out the radio. Easiest way I think is to download lyricidal's shrink-a-os, put it in your OS folder (should be something like C:\Program Files\Common Files\Research In Motion\Shared\Loader Files\9530-v4.7.0.151_P4.0.0.186) and run it. It's a cool little program that allows you to easily remove a bunch of the junk that's in the packaged OS (foreign languages, stock backgrounds, etc) and it also allows you to swap out the radio.


    You need to get a .rar extractor to extract the program and then put it in the folder I mentioned above. Then open the program and check the box at the top that says "shrink-a-os is in my current OS folder....." Then check off any junk you don't need on your BB. Then click the box on the right re 151 transitions. Then open the radio swap drop down menu and choose .132. Next click SHRINK MY OS! and it'll tell you how many MBs your java files are pre-shrink and then post-shrink. Lastly, load the newly shrunk and swapped OS onto your BB. Most people suggest using Loader.exe (there's a button to launch it within shrink-a-os).

    Hope this helps. Any questions, post back, PM me, or email me.
    07-16-09 03:17 PM
  8. uncleman's Avatar
    Go to options>about and you'll see OS 151 with platform 162.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 03:26 PM
  9. lbrenes#CB's Avatar
    I did not installed the hybrid, I kept 151 and just swaped the radio! so how can I know?

    Go to options>about and you'll see OS 151 with platform 162.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 03:28 PM
  10. goathog02's Avatar
    For what its worth, I have been listening to Slacker all day w/no issues. The cure? Cache my favorite stations locally.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 03:30 PM
  11. uncleman's Avatar
    I did not installed the hybrid, I kept 151 and just swaped the radio! so how can I know?
    Same exact way.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 03:41 PM
  12. uncleman's Avatar
    For what its worth, I have been listening to Slacker all day w/no issues. The cure? Cache my favorite stations locally.

    Posted from my CrackBerry at wapforums.crackberry.com
    That's bc ur no longer streaming. But its a great idea for a work-around.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 03:42 PM
  13. lbrenes#CB's Avatar
    This is what I see

    "v4.7.0.151 (Platform 4.0.0.186)

    Same exact way.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 03:43 PM
  14. uncleman's Avatar
    This is what I see

    "v4.7.0.151 (Platform 4.0.0.186)
    You still have the 151 radio. Try it again, following the instructions exactly.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 03:48 PM
  15. lbrenes#CB's Avatar
    I did, would you be willing to call me over the phone?

    You still have the 151 radio. Try it again, following the instructions exactly.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 03:53 PM
  16. uncleman's Avatar
    I did, would you be willing to call me over the phone?
    Can't now. Possibly tonight. PM me ur number.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 03:55 PM
  17. MrWireless31's Avatar
    what exactly does the radio control? Just the actual PHONE? Or does it have anything to do with memory or battery? I am curious because both memory an battery have been improved in my opinion on .151 and find it silly to just swap the radio out if that will cause me to lose the better memory/battery?
    07-16-09 05:29 PM
  18. 1967LS2's Avatar
    Thanks for the instructions. I will try to swap out the radio later. Hopefully it solves the Pandora/Slacker memory issues and also the MMS issues in .151
    07-16-09 05:41 PM
  19. clef's Avatar
    Good to know.

    I have it intermittently...but then again Pandora has always occasionally given me errors. Still works well enough to keep Pandora and .151 for me.

    The newest version of Pandora sounds really great.
    Same for me I love pandora. I even forgot my pod the other day and didn't mind since I had pandora with me

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 08:09 PM
  20. lbrenes#CB's Avatar
    Well I dont know what am I doing wrong. I did use shrink an OS, Selected a different radio, clicked on the Swap Radio button, it said my radio was succesfully changed, then clicked on App Loader, went thru the whole upload process with the phone, never got any error messages of any kind, at the end of the process it told me the phone was successfully upgraded.

    I go to Options then Advanced and it still lists 186 as the plattform, meaning nothing got updated.... grrrrrr. I have done this process 3 or 4 times and nothing ever changes.


    Can't now. Possibly tonight. PM me ur number.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-16-09 09:40 PM
  21. uncleman's Avatar
    Ok, I don't have my current OS here at home but I hopped on my PC and tried it out with an old OS. You're right, it's not working right.

    Here's what you need to do:

    On the top line of shrink-a-os, click the browse button and browse to C:\Program Files\Common Files\Research In Motion\Shared\Loader Files\9530-v4.7.0.148_P4.0.0.181\ and hit ok. I didn't have to do this previously....I would just put a check below that, but for some reason it's not working right.

    Anyway, NOW hit swap my radio and it'll start working (you shouldn't have to worry about shrinking b/c you already did that earlier...hence the message you probably got about having 60-some MB before and 30-some MB after). You'll know swap is working b/c at the very bottom of the shrink window, there'll be a message saying "downloading .132 radio to be swapped!" and the green status bar will be moving back and forth. It takes a little while (maybe 45 seconds or a minute) and you'll get a message that says it's been swapped.

    Now....to make absolutely certain that it's been swapped, navigate to that same folder above and then double click on the CDMA folder. You should now have a file called rim0x04001404.sfi that is 14,314KB and a file called backup.sfi.

    Now plug in your BB and run loader.exe and you'll be good.

    I SINCERELY apologize for the incorrect information previously. I've been away from my PC all afternoon and didn't have it in front of me to confirm everything. Sorry again. Please let me know if there are any more issues.

    Dave

    EDIT -- ps, I also edited the instructions in the original post to include the need to browse to the OS folder.
    Last edited by uncleman; 07-16-09 at 10:18 PM.
    07-16-09 10:02 PM
  22. lbrenes#CB's Avatar
    Uncleman, I am greatfull for you help, no apology needed.

    Still no luck, I followed your advice to the dot and still nothing. Would you be willing to call me? nine eight nine eight three nine three one four eight.

    The problem is, I can only sync this phone here with the PC at my office, so tonight it would not be an option, it has to be during the day, bussiness hours.

    I hope you can help me. Thanks.

    Ok, I don't have my current OS here at home but I hopped on my PC and tried it out with an old OS. You're right, it's not working right.

    Here's what you need to do:

    On the top line of shrink-a-os, click the browse button and browse to C:\Program Files\Common Files\Research In Motion\Shared\Loader Files\9530-v4.7.0.148_P4.0.0.181\ and hit ok. I didn't have to do this previously....I would just put a check below that, but for some reason it's not working right.

    Anyway, NOW hit swap my radio and it'll start working (you shouldn't have to worry about shrinking b/c you already did that earlier...hence the message you probably got about having 60-some MB before and 30-some MB after). You'll know swap is working b/c at the very bottom of the shrink window, there'll be a message saying "downloading .132 radio to be swapped!" and the green status bar will be moving back and forth. It takes a little while (maybe 45 seconds or a minute) and you'll get a message that says it's been swapped.

    Now....to make absolutely certain that it's been swapped, navigate to that same folder above and then double click on the CDMA folder. You should now have a file called rim0x04001404.sfi that is 14,314KB and a file called backup.sfi.

    Now plug in your BB and run loader.exe and you'll be good.

    I SINCERELY apologize for the incorrect information previously. I've been away from my PC all afternoon and didn't have it in front of me to confirm everything. Sorry again. Please let me know if there are any more issues.

    Dave

    EDIT -- ps, I also edited the instructions in the original post to include the need to browse to the OS folder.
    07-17-09 01:52 PM
  23. rcmike's Avatar
    I managed to get it to work by running it as administrator. I do have another problem now though. My screen looks like this.

    Any ideas?
    07-17-09 08:07 PM
  24. claustin's Avatar
    damn i like .151's radio other than the pandora issues. So the .132 is considered best out there then i take it?
    07-17-09 08:14 PM
  25. lbrenes#CB's Avatar
    The same thing happened to me!! no matter what theme you change to the icons and pretty much all images are gone!! I had to downgrade to 148 and then upgrade to 151 again.

    It seems to happen wih any radio file excep is own 151 version.

    I was able o downgrade o 148 and then install 151 again. Phone is back to normal, with the same stream issues. The more I think about it now, I think I am going to downgrade to 148 and stay there until these bugs are fixed.

    I sure liked the speed, battery and memory performance of 151, but you can only use the phone so much doing stream (pandora, slacker, yahoo oneSearch, etc) before the phone craps on you and you are forced to reboot. With 148 you had to reboot once a day pretty much too, in order to recover memory, but at least you could use the phone as hard as you wanted, the only limitation was the battery. One reboot a day either way... might as well stay with 148.

    My 2 cents.


    I managed to get it to work by running it as administrator. I do have another problem now though. My screen looks like this.
    Any ideas?
    07-17-09 08:27 PM
58 123
LINK TO POST COPIED TO CLIPBOARD