1. GpCaptMandrake's Avatar
    I have been having poor battery performance since updating to 151. I noticed that the transmit/receive arrows had been flickering frequently and put it down to the way in which 151 communicates with the system.

    Yesterday morning I had a fully charged battery and went for a drive in a rural area. By 3:00, with no use at all and in a magnetic holster I was down to 50%. Quite a drop, but it may have been "sniffing" in a spotty service area. So when I got home I charged it back up. Curious to see if the rate of consumption was the same, I left it in the holster overnight not charging. Meterberry is still showing a 3-4% per hour drop and I was at 57% by morning. Every time I looked at the phone, the arrows were flickering.

    So the first thing I tried in a process of elimination was to turn off Berryweather's auto updates. I had previously set both weather and alerts to 30 minutes. I noticed that the flickering arrows stopped right away. I put it back in the holster at 6:00 this morning. Checking it now at 8:00, I have had 0% battery loss.

    I know some folks had complained about battery life too which I had initially attributed to the brighter colors and faster system. If you have Berryweather, try turning off your alerts and see if it improves dramatically.

    Edit: As soon as I posted this I saw the new beta for Berryweather. I'm DL'ing that to see if it helps with this problem.
    Last edited by GpCaptMandrake; 07-13-09 at 07:27 AM.
    07-13-09 07:20 AM
  2. princessfortheday's Avatar
    I had this problem with BerryWeather before the switch to .151, and basically just open it and manually update it, and then exit it out of it when I am done. That has saved a ton of time on my battery.

    On a side note, I am having excellent battery life thus far on .151- hope I am not jinxing it!
    07-13-09 07:54 AM
  3. Testingchip's Avatar
    Same issue. I just downloaded the beta. Fingers crossed.
    07-13-09 08:50 AM
  4. howarmat's Avatar
    i noticed roughly the same battery loss and thought about disabling berryweather to. Glad to see an update. Will try that and see what happens. I would like to get back to the 2-2.5% an hour i was at prior to 151
    07-13-09 10:30 AM
  5. nulldog's Avatar
    I find it is incredible that people actually expect app developers / authors to
    cater and alter their code to work with leaked OS versions.

    Reality is that if you have a legit, official OS existing apps sholud not be an issue.
    07-13-09 12:05 PM
  6. howarmat's Avatar
    Not 1 person here asked for them to be altering code for 151. that being said, 151 is official and not leaked so your point is totally invalid really
    07-13-09 12:14 PM
  7. nulldog's Avatar
    Not 1 person here asked for them to be altering code for 151. that being said, 151 is official and not leaked so your point is totally invalid really
    Whatever... I was not trying to make a point... thanks for the input
    07-13-09 12:48 PM
  8. robinson.sweet's Avatar
    Okay, I dont have berryweather installed on my storm, but for the past 2 weeks or so, my battery life has taken a nose-dive! I have it fully charged by 6am. By 2pm, my battery life is near-dead, to the point of my icon showing RED! I've never had any such issues with my battery life until recently. I'm barely even using my BB during the day, as I'm in my office, and using my office phone. So whats is going on here? I'm beyond frustrated. I've had the phone for only 3 months!
    07-13-09 01:52 PM
  9. howarmat's Avatar
    Okay, I dont have berryweather installed on my storm, but for the past 2 weeks or so, my battery life has taken a nose-dive! I have it fully charged by 6am. By 2pm, my battery life is near-dead, to the point of my icon showing RED! I've never had any such issues with my battery life until recently. I'm barely even using my BB during the day, as I'm in my office, and using my office phone. So whats is going on here? I'm beyond frustrated. I've had the phone for only 3 months!
    what apps do you have installed?
    07-13-09 01:58 PM
  10. GpCaptMandrake's Avatar
    A follow up on this issue.

    Battery life since I turned off Berryweather's auto updates has been outstanding. I'm on 22 hours since 100% and I'm at 59% with moderate usage.

    I did update to the most recent beta so I'm going to turn it back on now and see what happens.
    07-14-09 10:16 AM
  11. Bob61's Avatar
    I am running newest BerryWeather beta and .151 - my experience with BW updates on - battery at 100% at 3PM, this morning 7AM was at 76%. That's only 24% drop in 16 hours of use.

    That includes using the phone during the day for a couple of calls, texting and other general and light phone usage. Still not too bad.
    07-14-09 10:33 AM
  12. GpCaptMandrake's Avatar
    Yeah I have a feeling that the most recent beta addressed the updater problem.
    07-14-09 11:25 AM
  13. cmpdblue's Avatar
    Yeah I have a feeling that the most recent beta addressed the updater problem.
    Just out of curiosity, what interval do you have your BerryWeather set at ? I have mine at 1 hour for both weather and alerts. My battery life had been respectable - lasts most of the day with moderate usage. If the update does better than that I'm definitely interested
    07-14-09 12:30 PM
LINK TO POST COPIED TO CLIPBOARD