1. Danielem's Avatar
    I have a Bold 2 9700.
    I'd like to keep "English" as os language and ONLY "Italian" as input language.
    I'd like to remove English and English US from input language.
    This cannot be done with DM or Shrink A OS.
    I tried to remove all *en_US* files from java folders but didn't work....
    It doesn't work even if i delete *dynamic_ling_data_english*.
    The reason i'm trying to to this is that if i choose English as os language and Italian as input language, sometimes input language switch itself to English US.

    I don't know if i can do that but i hope someone will help me
    07-17-10 10:43 AM
  2. Phill_UK's Avatar
    I don't understand what your problem is here

    This can be done easily through DM by just removing the unwanted files from your java folder.

    I always do the same when installing an OS, and just leave myself 'English' (which you cannot remove) and 'English UK' as OS languages, and ONLY 'English UK' as Input language.

    Just scroll down the list of files and delete all of the language cods, except for the _en.cod and _it.cod files.
    Also delete all of the dynamic_ling_data_ files, except for the domain_names, italian_45k_2 and italian_ltr files.
    After you've connected to DM to remove these files from your device, this should leave you with ONLY Italian as input language.

    Hope this helps
    07-18-10 05:17 AM
  3. Danielem's Avatar
    Now i have:

    - English
    - English (United States)
    - Italian

    Input Language:
    - Italian
    - English (United States)

    I want to remove the "English (United States)" from input languages and os languages.
    I removed files you told me, can you tell me now how to remove them from my phone without reinstall all os?
    What shoud i do after i start DM?
    07-18-10 06:35 AM
  4. Phill_UK's Avatar
    Do you have checkboxes next to the English US language options?

    If so, then uncheck these and continue with the update process.

    I'm not 100% sure but I believe if you are only removing language options, then DM won't carry out a full OS install.

    I would make a backup of your data and 3rd party apps, just in case it does.
    07-18-10 04:25 PM
  5. Danielem's Avatar
    I haven't any "English US" to uncheck
    BTW, the issue is that, randomly, if i set "English" as OS language and "Italian" as input language, sometimes "Italian" switch to "English".
    Is there any way to prevent automatically input language switching?
    And no, it's not me that i press ALT+Enter Key Quick selection is disabled.
    07-19-10 11:59 AM
  6. Phill_UK's Avatar
    I understand exactly what you're trying to do Danielem, and why... but I have no idea why you're having so much trouble trying to achieve it

    If you've deleted all the English US cod files, then that language shouldn't even be showing up as an option to use.

    You're not using a US built phone are you?

    I'm going to have to pass this one over to someone else to hopefully help you, as I'm all out of ideas here

    Good luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-19-10 01:20 PM
  7. syb0rg's Avatar
    IIRC : go to c:\program files\common files\research in motion\apploader and run the apploader and you should get a lot more in depth menu choice for lingo support. just make sure you have the matching OS on your computer when you do it.
    07-19-10 02:13 PM
  8. giorgosh's Avatar
    I got the same issue with OS 7.1. There are 2 English (1 us and 1 ok) and i would like to remove one of those! Any suggestions??
    03-05-12 02:43 AM