1. cvchase's Avatar
    I have received a number of SMS messages over the last several days that show up in the Hub yet message is not visible when in Messages. Can see previous conversation with sender, not new messages.

    This started around November 15, 2017.

    Thoughts?
    11-19-17 10:47 AM
  2. diesel0110's Avatar
    I'm experiencing the same thing on my KEYone. Seems to have started in the beginning on the month. I've tried restarting the phone and nothing has changed. Please let me know if you've found a solution.
    11-21-17 10:31 AM
  3. diesel0110's Avatar
    I just found this android central thread from August 2017

    https://forums.androidcentral.com/bl...ssage-app.html
    11-21-17 10:54 AM
  4. RK_BB's Avatar
    That's what happens when BlackBerry takes the 'cheap' approach instead of making Hub an SMS client or develop their own SMS app.

    Integrated Hub apps will always have issues for the simple reason that apps keep developing with obviously no regard to Hub and in the process may break the integration.

    As long as SMS will be handled by an integrated app (stock app or not) we will keep posting these types of issues here....
    Last edited by RK_BB; 12-20-18 at 10:26 AM.
    ZahidShad likes this.
    11-21-17 11:46 AM
  5. neillt's Avatar
    I read the thread in your link - did textra solve the problem?

    I've been experiencing this issue for a couple of months now at least - but the frequency seems to have increased lately.
    12-01-17 11:09 PM
  6. diesel0110's Avatar
    I read the thread in your link - did textra solve the problem?

    I've been experiencing this issue for a couple of months now at least - but the frequency seems to have increased lately.
    So I've downloaded Pulse instead, but I did notice that as soon as I did, the missing messages in the stock Android app seemed to have updated and appeared (in app and not just in the hub). However, I've decided to continue using the Pulse app because I did not want to risk missing text messages because of the oversight.
    Mecca EL likes this.
    12-03-17 12:22 AM
  7. Salil Bisht's Avatar
    I noticed this same issue a week after purchase of my keyone. I have been in contact with Blackberry tech support and the only short term fix is to disable then enable both hub and messages. but after a few days the problem will continue. I don't think a resolution will be anytime soon.
    12-09-17 12:39 PM
  8. diesel0110's Avatar
    Wish sucks. I've continued to just use another sms app alternative.
    12-09-17 11:15 PM
  9. blackberry4life79's Avatar
    I noticed this same issue a week after purchase of my keyone. I have been in contact with Blackberry tech support and the only short term fix is to disable then enable both hub and messages. but after a few days the problem will continue. I don't think a resolution will be anytime soon.
    Very typical of BlackBerry. When will all you people finally get a real phone.

    Posted via CB10
    12-10-17 08:06 PM
  10. Dave Liao's Avatar
    I've noticed this on a Priv, and now on a KEYone. It happened to me on a KEYone as recently as a week ago. Oy.

    I'm tempted to load Textra to force a refresh of my messages.

    I'm REALLY tempted to just ask people to message me ANY way besides texting.
    02-18-18 02:54 PM
  11. bb10adopter111's Avatar
    Text messenger still works great on my BB10 phone. Another good reason to double carry. Sometimes I think I'd enjoy my KEYone more if I removed the SIM and used it for WiFi only.

    Posted with my trusty Z10
    02-18-18 03:32 PM
  12. bbjohnm's Avatar
    Text messenger still works great on my BB10 phone. Another good reason to double carry. Sometimes I think I'd enjoy my KEYone more if I removed the SIM and used it for WiFi only.

    Posted with my trusty Z10
    Ya, loved my Z10 too. Just gave it up for a BB Motion, and miss native apps and functionality. Really don't like all the app based crap on Android, and hate Apple products with a passion. Too bad the rest of the world couldn't see it was a great platform.

    This will likely be my last BB product. After supporting them for 10 years, I've had enough disappointment. I'll choose something different next time, but guess I'm stuck with Android for now.

    I'm experiencing SMS problems with the Motion, so that's why I ended up on this thread. The Hub is a big disappointment after coming from the Z10.
    02-18-18 06:57 PM
  13. psychofox13's Avatar
    By disabling HUB, I don't have this issue, haha. It seems to cluttered and "out of focus", imo. For e-mails and calendaring, I love Outlook. I honestly don't know what else HUB could be good for that isn't handled better by separate apps.
    02-21-18 01:36 PM
  14. Johnnygargano's Avatar
    I'm experiencing the same thing on my KEYone. Seems to have started in the beginning on the month. I've tried restarting the phone and nothing has changed. Please let me know if you've found a solution.
    Disable the HUB. SMS will then work. So stupid but whatever, it works. It would be nice if this didn't even happen.
    09-21-18 05:08 PM
  15. diesel0110's Avatar
    Disable the HUB. SMS will then work. So stupid but whatever, it works. It would be nice if this didn't even happen.
    Having to do so sucks as I love and really depend on the hub. Since upgrading to a KEYtwo I haven't experience that issue with the stock sms app so I'm hoping I stay in the clear.
    10-12-18 09:00 PM
  16. TERDIE's Avatar
    Happening here on my Blackberry Motion as well. I'm getting extremely fed up.
    10-31-18 01:26 PM
  17. SteenBeyer's Avatar
    Install Pulse SMS from your Google Play Store and allow it to become your standard app for text messages. Solves the problem.
    11-29-18 11:41 AM
  18. dalej88's Avatar
    Same thing happening to me on a Key 2LE. The trick from android forum above fixed issue. FB messenger is more trouble than it is worth on my last 2 Blackberry's IMO
    12-20-18 09:56 AM
  19. 100bigdaddy's Avatar
    I was having a multitude of problems with texts not appearing in "Messages" but appeared on the BlackBerry Hub on my Keyone.
    My battery was draining fast too (I thought it was unrelated)
    Updates from Google Play took forever.
    I tried all suggestions. Restart, hard restart, deleting, etc.

    Reluctantly I did a factory reset.

    Factory reset fixed everything!!

    It took some time and patience. Very very important - read up on all the precautions for back up one needs to make. I did lose my "Notes" but managed to keep everything else intact.
    01-04-19 05:07 PM

Similar Threads

  1. Droid apps not working
    By 0lad1m3j1 in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 11-20-17, 03:00 PM
  2. Hub on android
    By Radim B in forum BlackBerry KEYone
    Replies: 2
    Last Post: 11-19-17, 04:55 PM
  3. Replies: 6
    Last Post: 11-19-17, 10:16 AM
  4. PP Black and PP White prices in Germany
    By johnsliderbb in forum BlackBerry Passport
    Replies: 2
    Last Post: 11-19-17, 07:36 AM
  5. Why my Dtek60 camera not showing 120 fps in 720p
    By afzar ali in forum BlackBerry DTEK60
    Replies: 0
    Last Post: 11-19-17, 03:52 AM
LINK TO POST COPIED TO CLIPBOARD