1. pdz13's Avatar
    Hi All,

    I seem to have a difficulty with data services while I go abroad (Poland to Germany for example) on my KeyOne Black Edition. I have it for a month now and had used Blackberry Content Transfer app to switch from Q10 (both Q10 and transfer app worked flawlessly).

    My troubleshooting steps so far was to re-check and make sure the mobile data services and data roaming are enabled (multiple times), contact the service provider to ensure data services and roaming are enabled on their side (they were enabled for a few years now, but always good to check), manually configuring APN as per service provider instructions, resetting network settings and resetting APN settings to default.

    My best theory so far was that perhaps Q10 had slightly different settings for the same provider, but once I reset all relevant settings I assumed KeyOne would create new APN for its needs.

    Nonetheless nothing have worked and I am out of ideas, apart from backing up all data/contacts etc. I have and a factory reset to start from scratch (with no BB Content Transfer app this time).

    Before I do spend time on that I figured it'd be good to check with you for any fresh ideas, which I would really appreciate.

    I hope there is an easy solution here. Thanks in advance for having a look.
    01-15-18 02:29 PM
  2. psychofox13's Avatar
    I can't help you on the roaming data side. If I travel anywhere outside of my country, I need a new SIM card. For the data stuff, that wouldn't cause this issue. All content transfer does is transfer pictures, contacts, and other personal files. It cannot transfer settings from a non-android to an android.

    The only option I can think of is to create a new APN from scratch with the necessary information. Or, maybe your version of the KeyOne doesn't support the radio bands that are used in Germany.

    Or maybe it's a limitation of the SIM card you have.
    01-15-18 03:04 PM
  3. stevec66's Avatar
    I recently returned from UK, Holland & Germany with my N American K1 phone useing same sim card no issues at all, maybe to do with cell package you have with your Telco provider
    01-16-18 12:20 PM
  4. FF22's Avatar
    I recently returned from UK, Holland & Germany with my N American K1 phone useing same sim card no issues at all, maybe to do with cell package you have with your Telco provider
    Who is your carrier? US, Canada or Mexico?
    01-16-18 05:09 PM
  5. stevec66's Avatar
    Telus in Canada, I purchased their Combo package which gave me 750MB, 100 minutes phone and 300 texts, which was plenty I was concerned about the 750 data plan, but everywhere I travelled has free wifi which I used extensively, came home with 300MB data not used I was away for 15 days, on business.
    01-16-18 05:42 PM
  6. FF22's Avatar
    Hi All,

    I seem to have a difficulty with data services while I go abroad (Poland to Germany for example) on my KeyOne Black Edition. I have it for a month now and had used Blackberry Content Transfer app to switch from Q10 (both Q10 and transfer app worked flawlessly).

    My troubleshooting steps so far was to re-check and make sure the mobile data services and data roaming are enabled (multiple times), contact the service provider to ensure data services and roaming are enabled on their side (they were enabled for a few years now, but always good to check), manually configuring APN as per service provider instructions, resetting network settings and resetting APN settings to default.

    My best theory so far was that perhaps Q10 had slightly different settings for the same provider, but once I reset all relevant settings I assumed KeyOne would create new APN for its needs.

    Nonetheless nothing have worked and I am out of ideas, apart from backing up all data/contacts etc. I have and a factory reset to start from scratch (with no BB Content Transfer app this time).

    Before I do spend time on that I figured it'd be good to check with you for any fresh ideas, which I would really appreciate.

    I hope there is an easy solution here. Thanks in advance for having a look.
    I don't know if the discussion in this thread is related:

    https://forums.crackberry.com/blackb...l#post13118234
    01-16-18 10:15 PM
  7. pdz13's Avatar
    Hi All,

    Thanks a lot for your answers. It is solved now and it is rather...:
    it seems that in Poland default APN for my service provider is set up for ipv6, while in Germany it needs to be set for ipv4. Despite having "data roaming" set for ipv4 in the profile, the data services did not work - after second contact with provider's support we have created a new APN profile with "old-school" all-ipv4 settings, for both in-country and roaming services.

    Strange thing is that in the official guidelines for KeyOne on my provider's website there is no word about that and all settings provided there are obviously ipv6...

    Having said that, it is good to finally have the data roaming up and running and note to self - always look for the second opinion...

    Again, thanks
    FF22 likes this.
    01-17-18 02:58 AM
  8. WT44's Avatar
    Hi All,

    Thanks a lot for your answers. It is solved now and it is rather...:
    it seems that in Poland default APN for my service provider is set up for ipv6, while in Germany it needs to be set for ipv4. Despite having "data roaming" set for ipv4 in the profile, the data services did not work - after second contact with provider's support we have created a new APN profile with "old-school" all-ipv4 settings, for both in-country and roaming services.

    Strange thing is that in the official guidelines for KeyOne on my provider's website there is no word about that and all settings provided there are obviously ipv6...

    Having said that, it is good to finally have the data roaming up and running and note to self - always look for the second opinion...

    Again, thanks
    Where do you find default APN/ipv4/6 and where do you create a new APN profile?
    FF22 likes this.
    01-17-18 02:04 PM
  9. psychofox13's Avatar
    Where do you find default APN/ipv4/6 and where do you create a new APN profile?
    Settings > under "Wireless & Networks" select "More" > Cellular Networks > Access Point Names. To view one, tap the name. To select one, tap the bubble. To make one, tap the + in the upper right-hand corner.
    WT44 likes this.
    01-18-18 12:38 AM
  10. FF22's Avatar
    Settings > under "Wireless & Networks" select "More" > Cellular Networks > Access Point Names. To view one, tap the name. To select one, tap the bubble. To make one, tap the + in the upper right-hand corner.
    As might be expected, on the "Verizon" cdma model, there is NO PLUS + sign. There is a 3-dot menu which only provides one option: "Reset to Default"

    The setting is already:

    Verizon Internet
    VZWINTERNET

    Rather than tamper, there is a circle already filled in for that option.
    psychofox13 likes this.
    01-18-18 09:54 AM
  11. psychofox13's Avatar
    As might be expected, on the "Verizon" cdma model, there is NO PLUS + sign. There is a 3-dot menu which only provides one option: "Reset to Default"

    The setting is already:

    Verizon Internet
    VZWINTERNET

    Rather than tamper, there is a circle already filled in for that option.
    Ah, yeah. I guess if it's carrier locked, you can't change these settings. :P
    01-19-18 10:16 AM
  12. FF22's Avatar
    Ah, yeah. I guess if it's carrier locked, you can't change these settings. :P
    Actually, the "Verizon" (in quotes since Verizon never did sell the KeyOne) KeyOne is NOT locked.

    You can use sim cards from other carriers, including US carriers (limitations apply) and overseas carriers without permission from Verizon.

    Verizon BB's and probably other phones that they sell have not been locked for years.

    Maybe that APN option would change with a different sim card???

    When I first got my "Verizon" KeyOne I had a T-mobile sim card in it and it worked. This was before I moved the Verizon sim from the Priv to the KeyOne.
    01-19-18 10:34 AM
  13. psychofox13's Avatar
    Actually, the "Verizon" (in quotes since Verizon never did sell the KeyOne) KeyOne is NOT locked.

    You can use sim cards from other carriers, including US carriers (limitations apply) and overseas carriers without permission from Verizon.

    Verizon BB's and probably other phones that they sell have not been locked for years.

    Maybe that APN option would change with a different sim card???

    When I first got my "Verizon" KeyOne I had a T-mobile sim card in it and it worked. This was before I moved the Verizon sim from the Priv to the KeyOne.
    My CDMA unlocked allowed me to add/change my APN settings. Maybe it does depend on the SIM card. I was using that phone with an AT&T SIM.
    FF22 likes this.
    01-19-18 10:37 AM

Similar Threads

  1. KeyOne behaving as if no Battery present.
    By Samuel Thorne in forum BlackBerry Mobile Support
    Replies: 3
    Last Post: 04-13-18, 09:45 AM
  2. Replies: 35
    Last Post: 01-17-18, 08:49 AM
  3. Replies: 1
    Last Post: 01-14-18, 11:52 AM
  4. swipe emoji while typing, gone?
    By dgsPRIV in forum BlackBerry KEYone
    Replies: 4
    Last Post: 01-14-18, 09:58 AM
  5. Replies: 0
    Last Post: 01-13-18, 04:11 AM
LINK TO POST COPIED TO CLIPBOARD