05-17-19 04:06 AM
27 12
tools
  1. Elijah Charles's Avatar
    Has anyone been able to pay using contactless android pay? I just get the prompt telling me to try again and the EPOS rejecting it.

    Worked very well on my PRIV.

    Thanks
    knightfall likes this.
    05-20-17 01:01 AM
  2. Rowe6's Avatar
    Yes, I have exactly the same problem. Android Pay wont show in Tap & Pay
    05-21-17 04:43 PM
  3. EmilyLiu's Avatar
    Mine works fine in the UK
    05-25-17 06:10 AM
  4. lucas5551's Avatar
    Mine works fine in the UK
    I've got the same issue, I tried three NFC payments apps and none of them worked while trying to make contactless payment. Each app was in the "tap and pay" tab selected as the default one, still it didn't work. I wonder if Blackberry doesn't block it somehow...?
    knightfall likes this.
    05-26-17 06:05 PM
  5. knightfall's Avatar
    Has anyone been able to pay using contactless android pay? I just get the prompt telling me to try again and the EPOS rejecting it.

    Worked very well on my PRIV.

    Thanks
    I'm having trouble too with Android Pay on my KEYone. Are you located in Canada?
    06-05-17 10:37 AM
  6. MoraBoy's Avatar
    I just tried mine for the first time and it did not work. I got the same message each time (I tried 3 times). The phone did vibrate with each contact with the terminal..

    Hopefully it is a SW issue and not HW so we can get a fix soon..
    06-05-17 02:59 PM
  7. Dazzla's Avatar
    I've just set mine up and tried it in McDonald's. It constantly buzzed next to the terminal but no payment went through. I've used android pay plenty of times before as well as Apple pay. I'll try removing the card and re-adding it.
    06-06-17 06:21 AM
  8. EvEr34's Avatar
    Same issue. Phone makes obvious contact with the terminal but tells me to try again. Amex pay does not work either and used to work fine on PRIV. not sure what the issue could be but hope its fixed soon.
    06-06-17 02:37 PM
  9. knightfall's Avatar
    Something is certainly up with the KEYone, at least in Canada. Some people in the UK and US are reporting their devices to work fine with Android Pay.

    My issues are the same as OP and others. Neither of my cards (credit and debit) work when I go to tap the debit machine. Android Pay opens up on my phone after a quick vibrate, but the debit machine says, "Tap not accepted. Insert chip."

    I'm thinking there is an issue regarding NFC in Canada.
    06-07-17 02:29 PM
  10. Remrose's Avatar
    I had that issue until today. But did change SIM card yesterday from Rogers Suretap Mobile Pay one to the new one Rogers shipped with my KeyOne. Also deleted and reinstalled app (card info was still there after reinstall). Today, debit taps work perfectly.
    06-09-17 02:01 PM
  11. EvEr34's Avatar
    I also finally got a new Sim card and everything now works!!!
    06-18-17 09:00 AM
  12. app_Developer's Avatar
    I had that issue until today. But did change SIM card yesterday from Rogers Suretap Mobile Pay one to the new one Rogers shipped with my KeyOne. Also deleted and reinstalled app (card info was still there after reinstall). Today, debit taps work perfectly.
    It's hard to say without looking at logs from these transactions, but you don't want to be using your carrier's payment enabled SIM.

    Android Pay uses HCE and so you might get better results with a normal SIM.

    Yes, the software should be able to deal with the situation where you have carrier payment SIM, but BB may not have tested that scenario well.

    My advice to people having trouble is to try a new normal, not payment enabled, SIM
    06-18-17 09:55 AM
  13. kahster's Avatar
    I'm in the US, and whenever I try to use Android Pay, the Keyone vibrates, the card appears on the screen, but instead of a check mark it doesn't complete. NFC is on and the card has been validated by AMEX, so I'm at a loss as to why it won't work. I came to the Keyone from a Galaxy S7 Edge, where Android Pay worked perfectly. I wonder if it's possible that there is some DTEK setting that is preventing it from working.
    06-23-17 02:58 PM
  14. klimkong's Avatar
    I had this issue with a KEYone on Rogers. I had been using an old Rogers' SureTap SIM which I think had some prebuilt security back when Rogers/Telus/etc. introduced SureTap. I swapped it out to a new SIM and Android Pay started working
    07-04-17 11:12 AM
  15. curve8310's Avatar
    I tried android pay and no luck. I'm with bell and have the bell nfc sim. had the same sim on my passport. Will get a new non nfc sim and try again.
    07-04-17 07:59 PM
  16. supertom's Avatar
    hmm. I just tried it for the first time today at subway sandwiches and it worked perfect on the first try. Check mark, chime and everything. I live in San Diego, CA and am on the T-Mobile network.
    07-05-17 02:42 AM
  17. Rowe6's Avatar
    still not working for me in UK and had since day 1 of release
    07-05-17 10:56 AM
  18. sag7392's Avatar
    Android Pay was not working on the VZW version of the KEYone the last time I tried it. And this was with using the same SIM from my Pixel XL and a new SIM. Thankfully I have the Huawei Watch 2, in which Android Pay works just fine.
    07-05-17 01:31 PM
  19. curve8310's Avatar
    so I finally got android pay to work. just got a new non nfc sim and everything is good.
    so if anyone having problem try that.
    I'm in Canada bell network
    07-06-17 06:21 AM
  20. app_Developer's Avatar
    so I finally got android pay to work. just got a new non nfc sim and everything is good.
    so if anyone having problem try that.
    I'm in Canada bell network
    Yeah, like I said earlier, you should be using a normal SIM with Android Pay, not an NFC enabled or payment enabled SIM from your carrier.
    07-06-17 06:34 AM
  21. jeffsantos's Avatar
    Yeah, like I said earlier, you should be using a normal SIM with Android Pay, not an NFC enabled or payment enabled SIM from your carrier.
    So do you think VZW reps would know this difference?

    Posted via CB10
    07-06-17 10:09 AM
  22. app_Developer's Avatar
    So do you think VZW reps would know this difference?
    They should, but there are a lot of things reps should know that they sometimes don't.

    BlackBerry should also test this scenario and give the proper error message to the user.
    07-06-17 10:25 AM
  23. wormycoolness's Avatar
    I'll add my experience to the thread. I have a Blackberry K1 from Rogers (Canadian cell provider). I was using a Suretap sim from 2013. The sales assoicate at the store called that sim, "VERY OLD". I tried using the Android Pay (with the new LTE multi SIM from Rogers) at my local Tim Hortons (Canadian Coffee shop). I got a checkmark (a first) on the app, but the card reader gave an error message as it did before. One thing I noticed was that my 4G/LTE signal was a bit low. I am going to try again at a street level Tim Hortons to see if I get the same result.


    EDIT: I tried again and it worked! I wish more retailers supported this handy way of paying!! Always make sure you have full signal before trying to pay. I suspect this way my problem.
    Last edited by wormycoolness; 07-07-17 at 06:11 PM.
    07-06-17 07:32 PM
  24. dnocera's Avatar
    Ok on K1 Verizon CDMA version USA. I may have found an combination fix that may work to fix two problems. SD card error and Android Pay error. I switched the SIM card to a Verizon ---> NON <--- NFC SIM. ( No. DFILLSIM4FF-A) Then changed permissions to Android pay to work with storage and camera. (off by default) And now Android Pay does work! And no SD card error as of yet today. I'll keep you posted... (Still on version AAL093)

    EDIT: Still no errors two weeks later....
    Last edited by dnocera; 08-13-17 at 03:13 AM.
    sag7392 likes this.
    08-01-17 10:18 PM
  25. supertom's Avatar
    I'll add my experience to the thread. I have a Blackberry K1 from Rogers (Canadian cell provider). I was using a Suretap sim from 2013. The sales assoicate at the store called that sim, "VERY OLD". I tried using the Android Pay (with the new LTE multi SIM from Rogers) at my local Tim Hortons (Canadian Coffee shop). I got a checkmark (a first) on the app, but the card reader gave an error message as it did before. One thing I noticed was that my 4G/LTE signal was a bit low. I am going to try again at a street level Tim Hortons to see if I get the same result.


    EDIT: I tried again and it worked! I wish more retailers supported this handy way of paying!! Always make sure you have full signal before trying to pay. I suspect this way my problem.
    The only time I got the check mark and the terminal saying "please try another card" error was when the business didn't set it up properly. Other than that, it works great at every other establishment that accepts it!
    08-02-17 12:32 PM
27 12

Similar Threads

  1. Replies: 20
    Last Post: 05-17-18, 06:03 AM
  2. Android phones with RGB LED?
    By Drenegade in forum General BlackBerry Discussion
    Replies: 13
    Last Post: 08-22-17, 11:50 PM
  3. Help - Q10 will not power on.
    By C-S-R in forum BlackBerry Q10
    Replies: 7
    Last Post: 06-02-17, 06:00 AM
  4. TSN not updating
    By Emaderton3 in forum BlackBerry 10 Apps
    Replies: 5
    Last Post: 05-25-17, 08:27 PM
  5. Cases that do not fit
    By Laserdrome in forum BlackBerry KEYone
    Replies: 2
    Last Post: 05-20-17, 02:16 AM
LINK TO POST COPIED TO CLIPBOARD