Built for Business - Learn more about BlackBerry KEY2
  1. nataleehillman's Avatar
    I don't have a land line and live alone, so please advise why this just started happening? It says dialing but does not dial. There is no dial tone. Text and email are fine, and I can receive calls, but cannot make any calls.
    Last edited by nataleehillman; 11-20-17 at 01:14 PM.
    11-20-17 01:03 PM
  2. Neville A Daniels's Avatar
    Most important question obviously check with your service provider that your phone bill is actually been paid there's no blockage at their end
    11-20-17 01:09 PM
  3. nataleehillman's Avatar
    My account is up to date. I checked that first. Also rebooted phone.
    11-20-17 01:19 PM
  4. Neville A Daniels's Avatar
    Go to system apps then select show system then go to each phone app and clear the cache files only
    11-20-17 01:26 PM
  5. nataleehillman's Avatar
    Hi Neville. I don't see to select "show system." Everything else is working fine. It just won't dial. I've had it for a while now.
    11-20-17 02:57 PM
  6. FF22's Avatar
    My account is up to date. I checked that first. Also rebooted phone.
    When you say you rebooted, what does that mean?

    Try holding the power button for a full 32 seconds ignoring screen and vibrations in between.
    11-20-17 03:12 PM
  7. nataleehillman's Avatar
    I meant that I powered it down. However, did not hold power button for 32 seconds. That did the trick!! Thank you so much for your assistance. 32 seconds, eh? Not 30. Thanks again!!
    11-20-17 03:18 PM
  8. FF22's Avatar
    I meant that I powered it down. However, did not hold power button for 32 seconds. That did the trick!! Thank you so much for your assistance. 32 seconds, eh? Not 30. Thanks again!!
    That was the advice for the Priv. Some argue it is not necessary for the KeyOne but I've seen advice both ways. And yes, it was 32 seconds (or more)!

    If it happens again, you can try 12 seconds first.

    Glad it worked.
    11-20-17 07:42 PM

Similar Threads

  1. Google play service not working
    By july3192 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 11-24-17, 12:28 AM
  2. E-Mails do not open (Hub)
    By wildsau666 in forum BlackBerry Motion
    Replies: 7
    Last Post: 11-22-17, 02:01 PM
  3. Contact bdays not shown on calendar
    By MB64 in forum BlackBerry 10 OS
    Replies: 10
    Last Post: 11-21-17, 08:41 PM
  4. keyONE using 2.5 gb RAM
    By Caesar Miramontes in forum Ask a Question
    Replies: 5
    Last Post: 11-20-17, 10:00 PM
  5. Take CrackBerry's BlackBerry KEYone and BlackBerry Motion Owner Super Survey!
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 11-20-17, 09:10 AM
LINK TO POST COPIED TO CLIPBOARD