1. rocker_man1's Avatar
    As of this morning my speaker for incoming calls stopped working. I have sent a service request to BlackBerry Mobile. Anyone else dealt with their support yet? I hope this is quick and painless. I need my phone to work as a phone.
    08-14-17 09:07 PM
  2. Dunt Dunt Dunt's Avatar
    A few others have... goes both ways, depending I think on their inventory and number of service request ahead of yours. Think right now they are slammed by screen lift "fixes" and replacements.

    How did you contact them?
    https://forums.crackberry.com/blackb...ctory-1113727/
    08-15-17 08:02 AM
  3. farmwersteve's Avatar
    my earpiece does not work for any phone calls, in or out

    they can hear me fine, but I'd don't hear a thing, including the outgoing ringing

    but speakerphone and Bluetooth are perfect
    08-17-17 09:16 PM
  4. farmwersteve's Avatar
    I called Blackberry Mobile warranty department and they gave me an email telling me how to do a diagnostic test on the key one

    Dial *#2886# - select MANU - click on the Audio option - put the phone to your ear and you should hear a voice.*

    so, I have an ever so slight faint noise.

    I have not done the factory reset yet, as I need this device for more than just phone and don't have time to get it all setup again
    08-20-17 09:58 AM
  5. FF22's Avatar
    I called Blackberry Mobile warranty department and they gave me an email telling me how to do a diagnostic test on the key one

    Dial *#2886# - select MANU - click on the Audio option - put the phone to your ear and you should hear a voice.*

    so, I have an ever so slight faint noise.

    I have not done the factory reset yet, as I need this device for more than just phone and don't have time to get it all setup again
    Well, it spoke, I guess Chinese. BUT CAUTION - now DTEK reports the OS is compromised. A 32 second restart does not fix it!!!!

    Oh, and before I ran the above test, Dtek did not find the OS had any problems.
    08-20-17 10:46 AM
  6. farmwersteve's Avatar
    I just got the same Dtek issue now too. strange it just happened now, days after testing with this method

    I have not done a restart yet
    FF22 likes this.
    08-20-17 10:49 AM
  7. icetealight's Avatar
    Hi, i am looking around for a while now. I got the same issue. I have updated the phone and now the ear speaker is very quiet. This means: when i am in a very quiet room and close my other ear, i can hear a very very quiet ring tone (not distorted or anything) - just like when it is set to minimal volume. But it actually is set to max. Volume.

    When i aktivate the loud speaker - it works.
    When i plug in headphones - it works.
    When i connect to bluetooth - iw works

    It is really is only the earspeaker .... Can it be that this update is simply buggy? Or do i have to get a new one?

    Since setting up a phone is the one task i absolutely hate to do, i hope you can give me a 2-step fix, that i can be calling myy dudes again :P

    Thanls for the help!
    08-27-17 09:03 AM
  8. FF22's Avatar
    Hi, i am looking around for a while now. I got the same issue. I have updated the phone and now the ear speaker is very quiet. This means: when i am in a very quiet room and close my other ear, i can hear a very very quiet ring tone (not distorted or anything) - just like when it is set to minimal volume. But it actually is set to max. Volume.

    When i aktivate the loud speaker - it works.
    When i plug in headphones - it works.
    When i connect to bluetooth - iw works

    It is really is only the earspeaker .... Can it be that this update is simply buggy? Or do i have to get a new one?

    Since setting up a phone is the one task i absolutely hate to do, i hope you can give me a 2-step fix, that i can be calling myy dudes again :P

    Thanls for the help!
    Have you done a restart/reboot?

    Press and hold the Power On button for a bit over 32 seconds ignoring any vibrations or screen images.

    See if you can download and use Blackberry Virtual Expert - it contains speaker tests. If not available in the playstore, you might find it online at some apk mirror sites.

    Good luck.
    08-27-17 10:15 AM
  9. icetealight's Avatar
    -delete-
    08-27-17 10:31 AM
  10. icetealight's Avatar
    Have you done a restart/reboot?

    Press and hold the Power On button for a bit over 32 seconds ignoring any vibrations or screen images.

    See if you can download and use Blackberry Virtual Expert - it contains speaker tests. If not available in the playstore, you might find it online at some apk mirror sites.

    Good luck.
    Hi, thanks for the help.

    1: did hold it 32 seconds (resulted in 4 vibration / and launch screens - did not see any special "loading" though) - did not change anything

    2: i did run the speaker test with the same result as above. All test carried out worked perfectly except the earspeaker - which was again whisperingly quite (did hear is thought)
    08-27-17 10:31 AM
  11. FF22's Avatar
    Hi, thanks for the help.

    1: did hold it 32 seconds (resulted in 4 vibration / and launch screens - did not see any special "loading" though) - did not change anything

    2: i did run the speaker test with the same result as above. All test carried out worked perfectly except the earspeaker - which was again whisperingly quite (did hear is thought)
    No, there would not be any special loading. Supposedly, the 32 second HOLD is the most dramatic. There are other methods that do bring up loading screens or Safe Mode. I guess you could try Safe Mode to make sure some app is not the cause.


    If might be hardware in which case you will want to follow up with warranty contacts.

    -----------

    Safe Mode:

    The next step is placing your device into safe mode.

    When used, Safe Mode will disable any third party apps or games you have installed. As a result of this, should your device not exhibit the issue while in Safe Mode it’s safe to assume the issue is specific to an app or game you have installed.

    **Safe Mode may also remove apps and/or widgets from your various home screens when you go back to Normal.** You may have to restore your icon/widget layouts.

    Press and hold the power key
    Tap and hold Power off (that is Press/Hold the Power Off prompt line) when it appears
    When prompted, tap OK to reboot to Safe Mode

    To get out of Safe Mode, press and hold the power key followed by tapping Reboot.

    After testing, should your device not exhibit any issues, the next step is to remove recently installed applications one by one until the issue is resolved.

    If that fails you might investigate reloading the OS using an Autoloader:

    https://forums.crackberry.com/blackb...aders-1065667/
    08-27-17 10:55 AM
  12. darasok's Avatar
    Hi all,
    I read many posts similar to this one and tried apps updates, reboots, etc... nothing worked.
    Then... I shaked a bit my phone and pressed a bit hard on the top of the phone and.... magic... all works fine now.
    I guess something got disconnected around the earpiece.
    Back to normal now....
    Love BB Keyone.
    Thanks to all.
    08-17-19 11:06 PM

Similar Threads

  1. Keyone unable to work on LTE/4G
    By RCAC in forum Ask a Question
    Replies: 11
    Last Post: 11-15-17, 07:06 PM
  2. Stop muted messages from whatsapp from showing up in the Hub
    By JenIt in forum BlackBerry Mobile Support
    Replies: 1
    Last Post: 08-14-17, 02:31 PM
  3. Truecaller does not work with jio Sim. Keyone
    By Ritu-bhagat in forum BlackBerry KEYone
    Replies: 2
    Last Post: 08-14-17, 02:03 PM
  4. Keyboard is not working properly
    By frdwrck in forum BlackBerry Passport
    Replies: 3
    Last Post: 08-14-17, 01:12 PM
  5. why bbm nit working in my z10
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-14-17, 03:47 AM
LINK TO POST COPIED TO CLIPBOARD