1. Phat_J's Avatar
    Hi everyone,I'm hoping to find a solution to this issue. It's more of an Android issue rather than a BlackBerry issue, so hopefully I'm posting in the correct section.

    I want a proper "Do Not Disturb" option which sends callers to voicemail.

    I've tried various settings of "Priority only," "Alarms only," and "Total silence" and I've changed the allowed calls option to "none" and "starred contacts only" (for which I have no contacts set to starred), and I've turned the repeat caller feature off, but calls STILL come through.

    I don't want calls when I'm driving, at the gym, sleeping, or otherwise occupied. The only thing that works is turning my phone onto airplane mode, and I'd have to turn back on wifi and bluetooth, and I cannot use a data connection.

    There must be a setting or some other way to send all calls to voicemail, still allow SMS, MMS, and data connections through.

    Device is a Blackberry KeyOne running Android Oreo 8.1.0. I've tried the same settings above on a Key2, same results.

    Any help is appreciated, thanks!
    elsniperx likes this.
    01-12-19 10:03 PM
  2. Amaroni's Avatar
    Hi everyone,I'm hoping to find a solution to this issue. It's more of an Android issue rather than a BlackBerry issue, so hopefully I'm posting in the correct section.

    I want a proper "Do Not Disturb" option which sends callers to voicemail.

    I've tried various settings of "Priority only," "Alarms only," and "Total silence" and I've changed the allowed calls option to "none" and "starred contacts only" (for which I have no contacts set to starred), and I've turned the repeat caller feature off, but calls STILL come through.

    I don't want calls when I'm driving, at the gym, sleeping, or otherwise occupied. The only thing that works is turning my phone onto airplane mode, and I'd have to turn back on wifi and bluetooth, and I cannot use a data connection.

    There must be a setting or some other way to send all calls to voicemail, still allow SMS, MMS, and data connections through.

    Device is a Blackberry KeyOne running Android Oreo 8.1.0. I've tried the same settings above on a Key2, same results.

    Any help is appreciated, thanks!
    Just a quick question, you say you have changed the allowed calls options to none AND starred contacts. ? I believe it can be only one or the other. If I am correct set the allowed calls to none and see if that fixes the issue .....
    01-12-19 11:15 PM
  3. Phat_J's Avatar
    Hi, I did not combine them, I tried one way, then the other. Setting the calls to none did not fix it
    01-12-19 11:25 PM
  4. Amaroni's Avatar
    I am really sorry for asking such a potentially stupid question. I know you set the priorities but did you activate the do not disturb? I can't think of any other reason this should happen especially on 2 devices. I have tried on the Keyone / Motion and Evolve and once activated no calls , or notifications come through.....
    01-13-19 01:58 AM
  5. Phat_J's Avatar
    Yes I have enabled the setting. I've attached some screenshots of my settings and the feature switched on. I've tried "Total silence" as well, no difference.

    I also tested with a completely different phone, an LG model with an earlier version of Android and it behaves the same.

    This must be an android-wide issue, but I find it odd that I can't find anyone else online with this same problem. I'd ask friends but they all use that dreaded other fruit phone.
    Attached Thumbnails "Do Not Disturb" for phone calls not working properly? Blackberry KeyOne, Android Oreo 8.1.0-screenshot_20190113-154014.jpg   "Do Not Disturb" for phone calls not working properly? Blackberry KeyOne, Android Oreo 8.1.0-screenshot_20190113-153945.jpg  
    01-13-19 04:45 PM
  6. Amaroni's Avatar
    yes definitely activated ....deactivate reminders and events and set messages to none . these are the settings on my device when I use the do not disturb function. lets try that and see what happens ....
    01-14-19 12:25 AM
  7. Amaroni's Avatar
    final thought , unless someone more knowledgeable chimes in ( and there are plenty who are more knowledgeable) my last suggestion would be a factory reset. You may wish to contact Blackberry Mobile support first before my last resort option....
    01-14-19 02:55 AM
  8. Phat_J's Avatar
    Thank you. I've been looking at some other options, one being Tasker, but that has quite a learning curve. Maybe there's an app that will enable call forwarding to voicemail in one touch, or I could program tasker to execute call forwarding when I turn on Do Not Disturb. If I can find the time to figure all that out, I'll update here.
    01-14-19 04:04 PM
  9. Phat_J's Avatar
    So I did solve it to an extent. I installed Tasker, and made a profile to activate call forwarding to my voicemail when my car bluetooth is connected, and another task to turn off forwarding when my car bluetooth disconnects. This seems to do the job. Thanks for the help anyways
    01-18-19 04:51 PM
  10. Amaroni's Avatar
    So I did solve it to an extent. I installed Tasker, and made a profile to activate call forwarding to my voicemail when my car bluetooth is connected, and another task to turn off forwarding when my car bluetooth disconnects. This seems to do the job. Thanks for the help anyways
    Good to know and thank you for letting us know as it might help someone else as well 😀
    01-19-19 05:38 AM
  11. The Kel's Avatar
    So the Keyone function doesn't work? You have to install an app?
    02-06-19 05:27 AM

Similar Threads

  1. Keyone battery life reduction
    By cavingjan in forum BlackBerry KEYone
    Replies: 2
    Last Post: 01-14-19, 01:39 AM
  2. I have an error message ImsDaemon is not working. Help
    By jswan27 in forum Ask a Question
    Replies: 1
    Last Post: 01-14-19, 12:35 AM
  3. WhatsApp on Blackberry Passport.
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-12-19, 08:47 PM
  4. key2 for under 700 aud
    By AhabSnake in forum BlackBerry KEY2
    Replies: 1
    Last Post: 01-12-19, 08:32 PM
  5. You can get a lifetime subscription to Zoog VPN for just $35!
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 01-12-19, 11:40 AM
LINK TO POST COPIED TO CLIPBOARD