12-16-16 07:25 AM
101 1234 ...
tools
  1. BB-JAM215's Avatar
    When link had issues in the past one solution was to turn off the windows automatic search for error solutions online. Once that was turned off it allowed BlackBerry software to get through.
    I was going to give this a quick try, but you can no longer simply turn this item off from the Security & Maintenance Control Panel.
    09-23-16 06:59 PM
  2. Jon Speed's Avatar
    I have now tried all of these options.
    I have removed everything blackberry using iObit uninstaller.
    - logged into regedit and added the disabled line of command so that "windows automatic search for error solutions online" is "off"
    - restarted computer
    - re-installed blackberry blend and link
    all to no avail... I even tried completely disableing all windows firewalls and anti-virus and anti-malwares temporarily just to see if it would run.
    nope
    nada
    FUBAR'd...
    09-23-16 10:32 PM
  3. Jon Speed's Avatar
    I was going to give this a quick try, but you can no longer simply turn this item off from the Security & Maintenance Control Panel.
    This is how I did it...
    basically comand prompt >>> regedit >>> follow the folders to the file you need to edit >>> add a line by clicking edit, then new, then you name it "Disabled", then you click on the line you just created and change default to "1" I thought it would be super complicated but it wasn't really. below is a more detailed link to how it's done.

    Disable Error Reporting In Windows 10 Home - Super User
    09-23-16 10:39 PM
  4. BB-JAM215's Avatar
    I saw that too, but I'd already done enough mucking around that I might have regretted on my PC for one day.

    Bottom line:
    Windows 10 Update 1607 Broke Blackberry Link
    Blackberry Link will never be updated

    One more reason to think about moving on.
    09-23-16 11:08 PM
  5. Jon Speed's Avatar
    I saw that too, but I'd already done enough mucking around that I might have regretted on my PC for one day.


    Bottom line:
    Windows 10 Update 1607 Broke Blackberry Link
    Blackberry Link will never be updated

    One more reason to think about moving on.
    I agree however a oppose to the sentiment I feel I've seen recently. I think I'll go with one of the Android BB's
    09-24-16 12:46 AM
  6. Biggles's Avatar
    At least I still have my old WinXP laptop. Link still runs on that, AFAICS; I haven't been able to connect my Classic yet, as it's in having a screen repair, I'll give it a try this afternoon.
    09-24-16 04:27 AM
  7. Biggles's Avatar
    Interesting. I uninstalled BB Link and reinstalled, and it all works again OK.

    There seem to be two kinds of problem, judging from this forum: some cannot start Link at all, or it crashes; others, like me, could start Link but it wouldn't recognise my BB device.

    Many of those that have the former problem seem to have iTunes, which I don't.
    09-26-16 05:28 AM
  8. brockwayent's Avatar
    I had tried uninstalling & reinstalling blackberry 10 desktop software (link + drivers only) multiple times without any luck. It always crashed. After reading these forums (and specifically this thread http://forums.crackberry.com/blackbe...33/index2.html , I tried 2 new things which currently has blackberry link running again:
    1. uninstalled iTunes
    2. Did a silent install of bb link.

    Here are the steps I followed:

    I used ccleaner to uninstall:
    - iTunes
    - Blackberry 10 Desktop Software

    I went to these folders and deleted any folders with 'Blackberry', 'Research In Motion', 'Apple', 'Apple Computer' or 'iTunes'
    Warning! This will delete settings and programs. You will lose your iTunes library & more, so be careful!
    C:\ProgramData\
    C:\Users\<userid>\AppData\Local\
    C:\Users\<userid>\AppData\LocalLow\
    C:\Users\<userid>\AppData\Roaming\
    C:\Users\<userid>\Music

    In ccleaner, under 'Registry' I scanned an fixed any issues.
    In ccleaner, under 'Cleaner', I did "Run Cleaner".

    I made sure my blackberry was disconnected from PC

    I restarted the PC.

    In ccleaner, under 'Registry' I scanned an fixed any issues (again).
    In ccleaner, under 'Cleaner', I did "Run Cleaner" (again).

    I did a quiet/silent install of just blackberry link and drivers using BlackBerryDesktopSoftware_1.2.0.52_B59.exe as per: How to install BlackBerry Link without installing BlackBerry Blend using silent install

    Waited about 5 minutes and noticed blackberry link shortcut on desktop.

    Started up blackberry link and it doesn't crash.

    Connected blackberry 10 phone and it is recognized by Blackberry Link. I lost all settings though. Still works after restarting computer.
    Biggles likes this.
    09-26-16 09:40 AM
  9. freakinvibe's Avatar
    There seem to be 2 issues with Blackberry Link:

    1) Blackberry Link crashes on startup of Link

    2) Link starts fine, but when you connect your BB10 device via USB, it is not recognized by Link.


    I had problem 2). It happened when I installed iTunes 12.5.1.21. Here is how I solved it on Windows 10:

    Uninstall iTunes
    Uninstall Apple Application Support (32-Bit)
    Uninstall Apple Application Support (64-Bit)
    Uninstall Apple Mobile Device Support
    Uninstall Apple Software Update
    Uninstall Bonjour
    Uninstall Blackberry Link

    Restart your computer

    Install Blackberry Link (Just the Drivers and Blackberry Link, not Blend). File name:
    BlackBerryDesktopSoftware_1.2.0.52_B59.exe

    It worked for me afterwards. I am a happy bunny. You just can't have iTunes and Link on the same computer anymore.
    Biggles likes this.
    09-27-16 04:29 AM
  10. HighwayBob's Avatar
    I agree however a oppose to the sentiment I feel I've seen recently. I think I'll go with one of the Android BB's
    Once I'm off of BB10 I'm done with Blackberry. I would never support them with an Android purchase after seeing their track record. I'll go with another vendor.
    09-29-16 06:36 PM
  11. HighwayBob's Avatar
    Everyone seems to be having slightly different experiences here. I uninstalled Link and rebooted the computer. I then reinstalled Link (without Blend) and that seems to have done the trick. My Passport is now seen when connected and I'm running a backup now.
    09-29-16 06:41 PM
  12. FR33MAN's Avatar
    Everyone seems to be having slightly different experiences here. I uninstalled Link and rebooted the computer. I then reinstalled Link (without Blend) and that seems to have done the trick. My Passport is now seen when connected and I'm running a backup now.
    Do you have itunes installed on your computer?

    Posted via CB10
    09-30-16 02:55 AM
  13. fattyacid's Avatar
    Uninstalled, reinstalled, worked. I have no iTunes though maybe thats why.

    love your curVes and all your edges all your peRfEct imPerfections
    09-30-16 04:08 AM
  14. FR33MAN's Avatar
    Or maybe the windows update is corrupting a link file and need a reinstall. Will try this weekend, thanks

    Posted via CB10
    09-30-16 05:54 AM
  15. VeryBumpy's Avatar
    Few facts I gathered from this thread:

    Blackberry/Windows has no intentions of fixing this issue.
    There is no absolute fix.
    Some are lucky and get it to work 'somehow'.

    Best foolproof solution is to store all important data, photos, videos, etc on the device media card then back that up manually to PC.
    10-01-16 09:41 AM
  16. BB-JAM215's Avatar
    Few facts I gathered from this thread:

    Blackberry/Windows has no intentions of fixing this issue.
    There is no absolute fix.
    Some are lucky and get it to work 'somehow'.

    Best foolproof solution is to store all important data, photos, videos, etc on the device media card then back that up manually to PC.
    Also, there is a conflict with iTunes. Those without iTunes installed have the best chance of getting Link to work after a re-install.
    But how long before it's broken for everyone?
    I use iTunes to backup my iPads, so I've moved my contact and calendar backups to Outlook 2016 & Outlook.com.
    I'll just have to do without Link's backups while I think about making the move to Android.
    10-01-16 10:16 AM
  17. brookie229's Avatar
    Moral of the story..........if you want to back up your stuff reliably maybe look at an app like Ultimate Backup in BBW. Good app, I've been using it for quite awhile now.
    10-01-16 10:19 AM
  18. KenV54's Avatar
    Unfortunately, neither the methods used in posts #33 or #34 worked for me. Link simply crashes. The crazy thing is that under my "Administrator" user on the same Windows 10 computer, Link still works, at least for now.

    I'm in the process of getting out of BlackBerry altogether. I've bought an iPhone 7, have my Z10 up for sale here and on Ebay (overwhelming response--I can't keep up with all the interested parties), and will soon put up for sale my Passport SE. I'm having trouble parting with the Passport, and may have to join a BlackBerry support group to help me get through this.

    BBLink.pdf
    10-01-16 12:37 PM
  19. BB-JAM215's Avatar
    Moral of the story..........if you want to back up your stuff reliably maybe look at an app like Ultimate Backup in BBW. Good app, I've been using it for quite awhile now.
    I installed Ultimate Backup a while back and played with it a bit. I guess it's now time to really start using it.
    10-01-16 01:01 PM
  20. G_Unit MVP's Avatar
    As freakinvibe said, after the 1607 update, the easy way to fix it is uninstalling link, blend and driver, and reinstalling after a system restart.

    Done it myself, works perfect. Also BB Blend works fine. Windows 10 PRO version 1607 build 14393.187

    Windows 10 Update 1607 Broke Blackberry Link-link_win10-1607.jpg
    Last edited by G_Unit MVP; 10-03-16 at 03:55 AM.
    10-02-16 03:56 PM
  21. zocster's Avatar
    Those that have link working after a re install, can you confirm what windows 10 version you have, my pro version no workie, and I'm not about to clean my pc where everything else is working fine.
    10-03-16 02:42 AM
  22. G_Unit MVP's Avatar
    I'm using PRO version. You can also try running link in Windows 7 compatibility mode.

    Posted via CB10
    zocster likes this.
    10-03-16 03:57 AM
  23. BB-JAM215's Avatar
    I'm using PRO version. You can also try running link in Windows 7 compatibility mode.
    That sounded like a good idea until I tried it first in Windows 8 compatibility mode, then in Windows 7 compatibility mode. There was no option for a pre-1607 Windows 10 mode.
    10-03-16 09:28 AM
  24. G_Unit MVP's Avatar
    That sounded like a good idea until I tried it first in Windows 8 compatibility mode, then in Windows 7 compatibility mode. There was no option for a pre-1607 Windows 10 mode.
    Which version of Windows 10 do you have? Link and Blend both works with Windows 10 PRO version 1607 build 14393.187
    10-03-16 09:32 AM
  25. BB-JAM215's Avatar
    Which version of Windows 10 do you have? Link and Blend both works with Windows 10 PRO version 1607 build 14393.187
    Windows 10 Home version 1607, build 14393.222.
    10-03-16 09:54 AM
101 1234 ...

Similar Threads

  1. BlackBerry Link not working with Z30
    By Rev2Greg in forum BlackBerry Z30
    Replies: 6
    Last Post: 10-19-16, 01:00 AM
  2. Would a working leak of 10.3.3 keep people happy?
    By RPM_KW in forum BB10 Leaked/Beta OS
    Replies: 102
    Last Post: 09-27-16, 01:04 AM
  3. BlackBerry Protect service problam
    By veerendar naidu in forum Android Apps (Amazon Store & APK Files)
    Replies: 3
    Last Post: 09-24-16, 12:37 PM
  4. Has BlackBerry stopped the production of the Passport? Officially??
    By schumi_xtreme01 in forum BlackBerry Passport
    Replies: 39
    Last Post: 09-19-16, 11:00 AM
  5. How can I mute the sound on my BlackBerry passport phone its horrible
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 09-15-16, 11:12 AM
LINK TO POST COPIED TO CLIPBOARD