1. hennesseystealth's Avatar
    I am moving computers from Win 7 to 10. I installed the latest version of Link but there is no device manager software like there was on Win 7, just Link. When I connect my Z10 it asks for the password, but then does nothing. The phone doesn't show up as USB drives in Explorer and I Link says not connected.

    Any ideas on how to fix this?

    Thanks
    02-15-17 03:10 PM
  2. anon(9742832)'s Avatar
    I am moving computers from Win 7 to 10. I installed the latest version of Link but there is no device manager software like there was on Win 7, just Link. When I connect my Z10 it asks for the password, but then does nothing. The phone doesn't show up as USB drives in Explorer and I Link says not connected.

    Any ideas on how to fix this?

    Thanks
    Its windows 10, Blackberry never submitted new drivers and windows does not like link, even running in compatibility mode its dead.
    02-15-17 03:25 PM
  3. hennesseystealth's Avatar
    This worked for me.

    https://supportforums.blackberry.com...3130175#M10560

    Didn't work for everyone.
    02-15-17 04:52 PM
  4. hennesseystealth's Avatar
    I wanted to give an update. While I can get Link to see my Z10 and it does launch device manager, if you want to use Link to backup you files, it won't. For me, all I needed was device manager to allow me to get a USB connection to my computer so I could sync my contacts and calendar using CompanionLink. That works.
    02-17-17 08:26 PM
  5. thurask's Avatar
    I wanted to give an update. While I can get Link to see my Z10 and it does launch device manager, if you want to use Link to backup you files, it won't. For me, all I needed was device manager to allow me to get a USB connection to my computer so I could sync my contacts and calendar using CompanionLink. That works.
    10.3.3 doesn't work well with Link either, since restoring is broken from what I've heard.
    02-17-17 08:28 PM
  6. hennesseystealth's Avatar
    10.3.3 doesn't work well with Link either, since restoring is broken from what I've heard.
    And I am angering the BB10 gods by using Windows 10 and 10.3.3...
    02-17-17 08:37 PM
  7. the_igg's Avatar
    Hahaha BlackBerry Link? That piece of dung software was buggy from the start and has never gotten better! What a waste of time.
    02-17-17 09:04 PM
  8. hennesseystealth's Avatar
    Hahaha BlackBerry Link? That piece of dung software was buggy from the start and has never gotten better! What a waste of time.
    Did exactly what it was supposed to do on Windows 7...BB must be taking lessons from HP. OS upgrade? Just buy new hardware, we aren't interested in fixing software...
    02-17-17 09:19 PM
  9. anon(9742832)'s Avatar
    I am moving computers from Win 7 to 10. I installed the latest version of Link but there is no device manager software like there was on Win 7, just Link. When I connect my Z10 it asks for the password, but then does nothing. The phone doesn't show up as USB drives in Explorer and I Link says not connected.

    Any ideas on how to fix this?

    Thanks
    One of the other interesting things with link I have also found is some apps can stop it. I have a radio app iHeartRadio. When installed it will not back up, uninstall and it works fine.
    02-18-17 07:01 PM
  10. anon(9742832)'s Avatar
    I am moving computers from Win 7 to 10. I installed the latest version of Link but there is no device manager software like there was on Win 7, just Link. When I connect my Z10 it asks for the password, but then does nothing. The phone doesn't show up as USB drives in Explorer and I Link says not connected.

    Any ideas on how to fix this?

    Thanks
    One of the other interesting things with link I have also found is some apps can stop it. I have a radio app iHeartRadio. When installed it will not back up, uninstall and it works fine.
    02-18-17 07:02 PM

Similar Threads

  1. 10.3.3 update
    By NnaemekaNNN in forum BlackBerry 10 OS
    Replies: 17
    Last Post: 01-13-18, 07:35 PM
  2. Why did i lose my network connection with blackberry 10.3.3.1463 update?
    By CrackBerry Question in forum Ask a Question
    Replies: 7
    Last Post: 02-16-17, 11:58 AM
  3. Blackberry classic won't turn on and flashing yellow LED light
    By CrackBerry Question in forum Ask a Question
    Replies: 7
    Last Post: 02-15-17, 06:55 PM
  4. where can i find ALL android apps ony my bb z10 10.3
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 02-15-17, 12:14 PM
  5. No sound on fast tube??
    By David Flather in forum Ask a Question
    Replies: 1
    Last Post: 02-15-17, 11:03 AM
LINK TO POST COPIED TO CLIPBOARD