1. Jonesy1966's Avatar
    I went to do my monthly back up this morning and for some reason neither Link or Blend seem to want to connect to my Passport (10.3.0.1418) using Windows 7. I don't really care about Blend, as interesting as it is it doesn't hold any practical interest for me. Link on the other hand is vital.

    I've tried connecting via USB with USB Mass Storage both on and off, I've also attempted Bluetooth and Network connections to no avail. Now Link is not allowing me to manually sign in to my BlackBerry ID. My drive shows under "Computer" in all instances.

    The kicker is I've tried removing and reloading Link but my computer keeps telling me that BlackBerry is up to other things and it won't delete the file even when the phone's not connected. All deletion attempts came after removing the device and rebooting the computer.
    10-31-14 08:37 AM
  2. daveycrocket's Avatar
    Like you Link is really important to me, at the moment all seems ok, I wouldn't mind a passport and I wouldn't mind Blend but until these issues are dealt with I won't be upgrading, there are many others on this subject who would agree. Come on Mr Chen shake someone.
    All I would try is to clean out my computer registry manually of link and Blend, and reload the OS and restore. this not being possible if the backup won't work.
    I hop this gets solved for you.
    Jonesy1966 likes this.
    10-31-14 10:40 AM
  3. anon1727506's Avatar
    I don't know why... just that LINK is a common problem for many BlackBerry users.

    What I always do.....

    1) Make sure LINK is up to date - if you installed Blend it should be a newer version of LINK than you can download from BlackBerry.
    2) Reboot Computer
    3) Reboot Phone

    Usually that will get it going, other option might be to delete LINK and Blend and just install the older version of LINK that is on the LINK download page and the one that installs with Blend is newer.
    Jonesy1966 likes this.
    10-31-14 11:16 AM
  4. Jonesy1966's Avatar
    I don't know why... just that LINK is a common problem for many BlackBerry users.

    What I always do.....

    1) Make sure LINK is up to date - if you installed Blend it should be a newer version of LINK than you can download from BlackBerry.
    2) Reboot Computer
    3) Reboot Phone

    Usually that will get it going, other option might be to delete LINK and Blend and just install the older version of LINK that is on the LINK download page and the one that installs with Blend is newer.
    I have checked and I have the latest version of Link, I've also tried rebooting both my phone and computer to no avail. Although I haven't checked in the last hour or so, my computer won't let me delete Link for a reinstal, it comes up with "BlackBerry is running another operation, please try again later" or words along those lines. I've checked and nothing else is running in the background. I'm at a loss!

    Posted via CB10 using my BlackBerry Passport
    10-31-14 12:21 PM
  5. Jonesy1966's Avatar
    Briefly home again and tried again but still getting the same results. Just out of interest I fired up Sachesi and it recognises my Passport but neither Link or Blend do still. I have no idea what else to try. Anyone?
    10-31-14 01:33 PM
  6. Jonesy1966's Avatar
    Just tried running a back up on my wife's Mac with the same results. On the other hand, my wife's Z30 was recognised immediately on both my PC and her Mac and ran smooth back ups on both.

    I just want to add this is not the first back up I've run on my Passport, I've run two since I've had it and since then no changes have been made to the phone's settings.
    10-31-14 02:55 PM
  7. daveycrocket's Avatar
    Can it be that link is looking for the Z30 and therefore cannot see the passport. With the passport connected by USB does it show in computer as a drive. Maybe try rebooting your PC with phone already connected. You must be getting fed up with this.
    Jonesy1966 likes this.
    10-31-14 06:44 PM
  8. Jonesy1966's Avatar
    Tried all of that, nothing seems to work, I can't even delete it to reload.

    BlackBerry has since told me to go to my carrier to get help, while my carrier said they won't support it because I didn't buy the Passport from them and Link was downloaded from Blackberry.

    And you're right, I'm completely fed up with it!
    10-31-14 07:31 PM
  9. Jonesy1966's Avatar
    I'm at a complete impasse here, can anyone help?

    Tried again this morning with the same results. I tried once more to delete Link and Blend but it won't let me either through Control Panel, Program Files or even the Start Menu. Tried searching other locales to no avail. BlackBerry got me to try things I had already tired and then said to deal with my carrier who refused to have anything to do with it as they didn't sell it to me, it was bought from Shop BlackBerry.

    I need Link to work, has anyone any idea what's going on?

    TIA
    11-01-14 07:57 AM
  10. daveycrocket's Avatar
    If the computer won't allow you to uninstall, do you have administrators rights, to check whats running - go - administrator tools in control panel then open services. I don't have Blend as I use Z30 but my windows 7 64 bit shows a service called Blackberry device manager and Blackberry Link communication manager both show as started, device manager I have as manual which means it connects when I connect my phone via usb Blackberry communication manager start automatically, I also just found in the list RIM MDNS which seems to be to do with the start up - mDNS responder. exe to check this out I right clicked RIM MDNS this gives properties. example start up type mine shows auto but I note a disabled is listed in the drop down. properties also shows dependencies which on mine shows TCP/ IP protocol driver and also shows blackberry link communication manager in properties the is also a log on and recovery tab.
    I also wonder if you stop the services by right clicking all or some of the Blackberry/RIM services if it will allow an uninstall as the service would be stopped.
    I hope this is helpful.
    11-02-14 01:13 PM
  11. Mercher's Avatar
    I try to transfer Q10 Data to Passport.
    After a restart of Passport done by Link, link stops saying "no connection to passport"...
    11-04-14 05:49 AM
  12. anon(4067838)'s Avatar
    I had this problem yesterday too. It seems passport won't connect to the latest link/blend package. You need to delete/uninstall it, then if you go to BlackBerry website and under the software tab select the Link download only. Install this and you are good to go, only thing is you won't have Blend.
    My Z30 would connect ok, Passport won't for some reason with the latest link/blend package. Hope this helps

    Posted by Passport, Blackberry's Beast!
    12-13-14 05:24 PM

Similar Threads

  1. Blackberry/Passport headset and features
    By thedose in forum BlackBerry Passport
    Replies: 6
    Last Post: 12-02-14, 07:34 AM
  2. Timed Messages and Retraction are Paid features
    By SirJes in forum General BBM Chat
    Replies: 155
    Last Post: 11-04-14, 04:43 AM
  3. Best 64GB SD for Passport: SanDisk Ultra vs Extreme?
    By JamieWilson01 in forum BlackBerry Passport
    Replies: 4
    Last Post: 10-31-14, 09:21 AM
  4. Can you lock certain apps on your BlackBerry passport?
    By exeicker in forum BlackBerry Passport
    Replies: 1
    Last Post: 10-31-14, 08:02 AM
  5. Replies: 1
    Last Post: 10-31-14, 07:48 AM
LINK TO POST COPIED TO CLIPBOARD