1. CrackBerry Question's Avatar
    I have just been given a new HP Elitebook with Windows 8.1 by my firm and the BB Link software I have installed myself. When I plug in the Q10, I can't get it to register in BB Link.

    I have tried different USB ports, and just about everything else including uninstalling BB Link and drivers. Any other suggestions as to why this might be happening?
    07-10-15 03:02 PM
  2. Dunt Dunt Dunt's Avatar
    Are there any restriction on that company provided computer?

    Try running the installation as an administrator. Also check to see that there are some BlackBerry Rules in Windows Firewall.

    Also what OS are you running on your phone? Make sure you have the latest version of LINK. I had to get the Beta for my Windows 10 computer to install the right drivers for my BlackBerry. Check Device Manager when your phone is plugged in and see if it shows up.
    07-10-15 03:19 PM
  3. harshik's Avatar
    Uninstall your phone drivers from device manager.. connect the phone and wait for the drivers to be reinstalled

    Posted via CB10
    07-10-15 03:23 PM

Similar Threads

  1. Replies: 54
    Last Post: 07-16-15, 12:47 PM
  2. Android apps not working on Q10
    By Rukha in forum Ask a Question
    Replies: 3
    Last Post: 07-11-15, 10:15 AM
  3. Scrolling down in list of emails / text
    By jt597 in forum BlackBerry Z10
    Replies: 1
    Last Post: 07-11-15, 12:54 AM
  4. Replies: 1
    Last Post: 07-10-15, 03:42 PM
  5. Why is my phone not charging even though the battery is brand new?
    By CrackBerry Question in forum BlackBerry Torch 9800
    Replies: 1
    Last Post: 07-10-15, 02:21 PM
LINK TO POST COPIED TO CLIPBOARD