1. Thalestr's Avatar
    "BlackBerry Link has stopped working" is the error message I get the second I click on the Link icon. It's been doing this before the 10.3 update on my Z10 and using the new Link provided with Blend, I get the same problem.

    Well actually it worked for a few hours and now it won't start again. Reinstalling Link (and clearing old files and registry) does nothing. Refuses to start. Blend works fine.

    OS is Windows 7 64bit.
    Phone is Z10 Telus Canada
    02-21-15 03:14 AM
  2. jaydee5799's Avatar
    Use the newest version of Link and newest version of Blend. I have 8.1 windows and it works fine. Maybe use CCleaner on your windows to delete cached crap first?
    02-21-15 08:51 AM
  3. Thalestr's Avatar
    Use the newest version of Link and newest version of Blend. I have 8.1 windows and it works fine. Maybe use CCleaner on your windows to delete cached crap first?
    I am doing both those things.
    02-21-15 11:50 AM
  4. Blackberry_Boy's Avatar
    same problem here. Am now uninstalling and reinstalling. PITA.
    06-19-15 10:01 AM
  5. smodes's Avatar
    I still can't get BB link to open either...I've gone through lots of troubleshooting and still nothing...the blend works fine for me as well.
    did you ever solve this problem?

    I had previous troubleshooting suggestions in crackberry for this problem but nothing has worked...
    thanks.
    06-22-15 03:58 PM
  6. BlueRoseGeek's Avatar
    Stopped working for me a few days ago on 8.1, have spent days trying to fix it (including removing iTunes and any associated crap)
    10-06-16 11:33 PM

Similar Threads

  1. BlackBerry Classic vs Passport signal
    By Jakobroxx in forum T-Mobile
    Replies: 41
    Last Post: 08-29-15, 06:23 PM
  2. Power Button does not work after 10.3.1 update
    By m1k3_666 in forum BlackBerry Z10
    Replies: 7
    Last Post: 03-14-15, 07:15 AM
  3. Skype - BlackBerry World Vs Google Play
    By portal in forum BlackBerry 10 OS
    Replies: 11
    Last Post: 02-28-15, 09:08 AM
  4. Why will my Q10 not backup to my laptop via BB Link?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 02-25-15, 09:22 AM
  5. Replies: 2
    Last Post: 02-21-15, 07:19 AM
LINK TO POST COPIED TO CLIPBOARD